]> git.saurik.com Git - apt.git/blobdiff - debian/rules
* merged from apt--tasks
[apt.git] / debian / rules
index a8bf88762e4fed8821d9f3f8bf480caf4cd94759..2007370c45fb01526ea709c9f8f98beca00d49f7 100755 (executable)
@@ -210,10 +210,15 @@ apt: build debian/shlibs.local
 
        cp debian/bugscript debian/$@/usr/share/bug/apt/script
 
-       cp share/debian-archive.gpg debian/$@/usr/share/$@
-
+       cp share/ubuntu-archive.gpg debian/$@/usr/share/$@
+       cp debian/apt.conf.ubuntu debian/$@/etc/apt/apt.conf.d/01ubuntu
 #      head -n 500 ChangeLog > debian/ChangeLog
 
+       # make rosetta happy and remove pot files in po/ (but leave stuff
+       # in po/domains/* untouched) and cp *.po into each domain dir
+       rm -f build/po/*.pot
+       rm -f po/*.pot
+
        dh_installexamples -p$@ $(BLD)/docs/examples/*
        dh_installman -p$@ 
        dh_installcron -p$@
@@ -338,4 +343,4 @@ arch-build:
        mkdir -p debian/arch-build/apt-$(APT_DEBVER)
        tar -c --exclude=arch-build --no-recursion -f - `bzr inventory` | (cd debian/arch-build/$(PKG)-$(APT_DEBVER);tar xf -)
        $(MAKE) -C debian/arch-build/apt-$(APT_DEBVER) startup doc
-       (cd debian/arch-build/apt-$(APT_DEBVER); $(DEB_BUILD_PROG))
+       (cd debian/arch-build/apt-$(APT_DEBVER); $(DEB_BUILD_PROG); dpkg-genchanges -S > ../apt_$(APT_DEBVER)_source.changes)