-apt (0.7.17) unstable; urgency=low
+apt (0.7.21) UNRELEASED; urgency=low
+
+ [ Osamu Aoki ]
+ * Updated cron script to support backups by hardlinks and
+ verbose levels. All features turned off by default.
+ * Added more error handlings. Closes: #438803, #462734, #454989,
+ * Documented all cron script related configuration items in
+ configure-index.
+
+ [ Michael Vogt ]
+ * apt-pkg/acquire.cc:
+ - make the max pipeline depth of the acquire queue configurable
+ via Acquire::Max-Pipeline-Depth
+ * apt-pkg/deb/dpkgpm.cc:
+ - add Dpkg::UseIoNice boolean option to run dpkg with ionice -c3
+ (off by default)
+ - send "dpkg-exec" message on the status fd when dpkg is run
+ * apt-pkg/algorithms.cc:
+ - consider recommends when making the scores for the problem
+ resolver
+ * apt-pkg/acquire-worker.cc:
+ - show error details of failed methods
+ * apt-pkg/contrib/fileutl.cc:
+ - if a process aborts with signal, show signal number
+ * methods/http.cc:
+ - ignore SIGPIPE, we deal with EPIPE from write in
+ HttpMethod::ServerDie() (LP: #385144)
+ * apt-pkg/deb/dpkgpm.cc:
+ - provide DPkg::Chroot-Directory config option (useful for testing)
+ * Only run Download-Upgradable and Unattended-Upgrades if the initial
+ update was successful Closes: #341970
+
+ -- Michael Vogt <michael.vogt@ubuntu.com> Thu, 28 May 2009 17:51:42 +0200
+
+ [ Michael Vogt ]
+ * apt-pkg/indexcopy.cc:
+ - support having CDs with no Packages file (just a Packages.gz)
+ by not forcing a verification on non-existing files
+ (LP: #255545)
+ - remove the gettext from a string that consists entirely
+ of variables (LP: #56792)
+ * doc/makefile:
+ - add examples/apt-https-method-example.conf
+ * apt-pkg/cacheiterators.h:
+ - add missing checks for Owner == 0 in end()
+ * apt-pkg/deb/dpkgpm.cc:
+ - fix potential hang when in a backgroud process group
+ * apt-pkg/indexrecords.cc:
+ - fix some i18n issues
+ * apt-pkg/contrib/strutl.h:
+ - add new strprintf() function to make i18n strings easier
+ * methods/gpgv.cc:
+ - fix compiler warning
+ * cmdline/apt-get.cc:
+ - fix "apt-get source pkg=ver" if binary name != source name
+ and show a message (LP: #202219)
+ - fix "apt-get source pkg" if there is a binary package and
+ a source package of the same name but from different
+ packages (LP: #330103)
+ * apt-pkg/deb/debsystem.cc:
+ - make strings i18n able
+ * apt-pkg/contrib/strutl.cc:
+ - fix TimeToStr i18n (LP: #289807)
+ * [ABI break] merge support for http redirects, thanks to
+ Jeff Licquia and Anthony Towns
+ * [ABI break] use int for the package IDs (thanks to Steve Cotton)
+ * apt-pkg/pkgcache.cc:
+ - do not run "dpkg --configure pkg" if pkg is in trigger-awaited
+ state (LP: #322955)
+ * methods/https.cc:
+ - add Acquire::https::AllowRedirect support
+ * methods/gpgv.cc:
+ - properly check for expired and revoked keys (closes: #433091)
+ * fix problematic use of tolower() when calculating the version
+ hash by using locale independant tolower_ascii() function.
+ Thanks to M. Vefa Bicakci (LP: #80248)
+ * build fixes for g++-4.4
+ * cmdline/apt-mark:
+ - add "showauto" option to show automatically installed packages
+
+ [ Dereck Wonnacott ]
+ * apt-ftparchive might write corrupt Release files (LP: #46439)
+ * Apply --important option to apt-cache depends (LP: #16947)
+ * Clarify the --help for 'purge' (LP: #243948)
+
+
+ [ Colin Watson ]
+ * cmdline/acqprogress.cc:
+ - Call pkgAcquireStatus::Pulse even if quiet, so that we still get
+ dlstatus messages on the status-fd (LP: #290234).
+
+ -- Michael Vogt <michael.vogt@ubuntu.com> Fri, 12 Sep 2008 11:34:24 +0200
+
+apt (0.7.20) unstable; urgency=low
[ Eugene V. Lyubimkin ]
- * apt-pkg/acquire-item.cc:
- - Added fallback to uncompressed 'Packages' if neither 'bz2' nor 'gz'
- available. (Closes: #409284)
- * apt-pkg/algorithm.cc:
- - Strip username and password from source URL in error message.
- (Closes: #425150)
+ * debian/changelog:
+ - Fixed place of 'merged install-recommends and install-task branches'
+ from 0.6.46.1 to 0.7.0. (Closes: #439866)
+ * buildlib/config.{sub,guess}:
+ - Renewed. This fixes lintian errors.
+ * doc/apt.conf.5.xml, debian/apt-transport-https:
+ - Documented briefly 'APT::https' group of options. (Closes: #507398)
+ - Applied patch from Daniel Burrows to document 'Debug' group of options.
+ (Closes: #457265)
+ - Mentioned 'APT::Periodic' and 'APT::Archives' groups of options.
+ (Closes: #438559)
+
+ [ Michael Vogt ]
+ * apt-pkg/depcache.cc:
+ - when checking for new important deps, skip critical ones
+ (LP: #236360)
+ * document --install-recommends and --no-install-recommends
+ (thanks to Dereck Wonnacott, LP: #126180)
+ * make "apt-get build-dep" installed packages marked automatic
+ by default. This can be changed by setting the value of
+ APT::Get::Build-Dep-Automatic to false (thanks to Aaron
+ Haviland, closes: #44874, LP: #248268)
+
+ -- Eugene V. Lyubimkin <jackyf.devel@gmail.com> Sat, 06 Dec 2008 20:57:00 +0200
+
+apt (0.7.20~exp2) unstable; urgency=low
+
+ [ Eugene V. Lyubimkin ]
+ * doc/examples/sources.list:
+ - Removed obsolete commented non-us deb-src entry, replaced it with
+ 'deb-src security.debian.org' one. (Closes: #411298)
+ * apt-pkg/contrib/mmap.cc:
+ - Added instruction how to work around MMap error in MMap error message.
+ (Closes: #385674, 436028)
+
+ [ Christian Perrier ]
+ * Translations:
+ - French corrected (remove awful use of first person)
+
+ -- Michael Vogt <mvo@debian.org> Tue, 02 Dec 2008 20:30:14 +0100
+
+apt (0.7.19) unstable; urgency=low
+
+ [ Eugene V. Lyubimkin ]
+ * doc/sources.list.5.xml:
+ - Mentioned allowed characters in file names in /etc/apt/sources.list.d.
+ Thanks to Matthias Urlichs. (Closes: #426913)
+ * doc/apt-get.8.xml:
+ - Explicitly say that 'dist-upgrade' command may remove packages.
+ - Included '-v'/'--version' as a command to synopsis.
+ * cmdline/apt-cache.cc:
+ - Advanced built-in help. Patch by Andre Felipe Machado. (Closes: #286061)
+ - Fixed typo 'GraphVis' -> 'GraphViz'. (Closes: #349038)
+ - Removed asking to file a release-critical bug against a package if there
+ is a request to install only one package and it is not installable.
+ (Closes: #419521)
+
+
+ [ Michael Vogt ]
+ - fix SIGHUP handling (closes: #463030)
+
+ [ Christian Perrier ]
+ * Translations:
+ - French updated
+ - Bulgarian updated. Closes: #505476
+ - Slovak updated. Closes: #505483
+ - Swedish updated. Closes: #505491
+ - Japanese updated. Closes: #505495
+ - Korean updated. Closes: #505506
+ - Catalan updated. Closes: #505513
+ - British English updated. Closes: #505539
+ - Italian updated. Closes: #505518, #505683
+ - Polish updated. Closes: #505569
+ - German updated. Closes: #505614
+ - Spanish updated. Closes: #505757
+ - Romanian updated. Closes: #505762
+ - Simplified Chinese updated. Closes: #505727
+ - Portuguese updated. Closes: #505902
+ - Czech updated. Closes: #505909
+ - Norwegian Bokmål updated. Closes: #505934
+ - Brazilian Portuguese updated. Closes: #505949
+ - Basque updated. Closes: #506085
+ - Russian updated. Closes: #506452
+ - Marathi updated.
+ - Ukrainian updated. Closes: #506545
+
+ -- Michael Vogt <mvo@debian.org> Mon, 24 Nov 2008 10:33:54 +0100
+
+apt (0.7.18) unstable; urgency=low
+
+ [ Christian Perrier ]
+ * Translations:
+ - French updated
+ - Thai updated. Closes: #505067
+
+ [ Eugene V. Lyubimkin ]
+ * doc/examples/configure-index:
+ - Removed obsoleted header line. (Closes: #417638)
+ - Changed 'linux-kernel' to 'linux-image'.
+ * doc/sources.list.5.xml:
+ - Fixed typo and grammar in 'sources.list.d' section. Thanks to
+ Timothy G Abbott <tabbott@MIT.EDU>. (Closes: #478098)
+ * doc/apt-get.8.xml:
+ - Advanced descriptions for 'remove' and 'purge' options.
+ (Closes: #274283)
* debian/rules:
- - Fixed lintian warnings "debian/rules ignores make errors".
- * debian/control:
- - Substituted outdated "Source-Version" fields with "binary:Version".
- - Added 'python-apt' to Suggests, as apt-mark need it for work.
- - Drop Debian revision from 'doc-base' build dependency, this fixes
- appropriate lintian warning.
- * debian/libapt-pkg-doc.doc-base.*:
- - Changed section: from old 'Devel' to 'Debian'. This fixes appropriate
- lintian warnings.
- * debian/{postrm,prerm,preinst}:
- - Added 'set -e', fixes lintian warnings
- 'maintainer-script-ignores-error'.
- * dselect/makefile:
- - Removed unneeded 'LOCAL' entry. This allows cleaning rule to run smoothly.
- * share/lintian-overrides:
- - Added with override of 'apt must depend on python'. Script 'apt-mark'
- needs apt-python for working and checks this on fly. We don't want
- python in most cases.
- * cmdline/apt-key:
- - Added 'unset GREP_OPTIONS' to the script. This prevents 'apt-key update'
- failure when GREP_OPTIONS contains options that modify grep output.
- (Closes: #428752)
+ - Target 'apt' need to depend on 'build-doc'. Thanks for Peter Green.
+ Fixes FTBFS. (Closes: #504181)
+
+ [ Michael Vogt ]
+ * fix depend on libdb4.4 (closes: #501253)
+
+ -- Michael Vogt <mvo@debian.org> Fri, 07 Nov 2008 22:13:39 +0100
+
+apt (0.7.17) unstable; urgency=low
+
+ [ Eugene V. Lyubimkin ]
* debian/control:
- 'Vcs-Bzr' field is official, used it.
- Bumped 'Standards-Version' to 3.8.0, no changes needed.
sources.list manpage, as they are already described under in the manpage.
- Removed notice that ssh/rsh access cannot use password authentication
from sources.list manpage. Thanks to Steffen Joeris. (Closes: #434894)
+ - Added '(x)' to some referrings to manpages in apt-get manpage. Patch by
+ Andre Felipe Machado. (Closes: #309893)
+ - Added 'dist-upgrade' apt-get synopsis in apt-get manpage.
+ (Closes: #323866)
+
+ -- Michael Vogt <mvo@debian.org> Wed, 05 Nov 2008 13:14:56 +0100
+
+apt (0.7.17~exp4) experimental; urgency=low
+
+ * debian/rules:
+ - Fixed lintian warnings "debian/rules ignores make errors".
+ * debian/control:
+ - Substituted outdated "Source-Version" fields with "binary:Version".
+ - Added 'python-apt' to Suggests, as apt-mark need it for work.
+ - Drop Debian revision from 'doc-base' build dependency, this fixes
+ appropriate lintian warning.
+ * debian/libapt-pkg-doc.doc-base.*:
+ - Changed section: from old 'Devel' to 'Debian'. This fixes appropriate
+ lintian warnings.
+ * debian/{postrm,prerm,preinst}:
+ - Added 'set -e', fixes lintian warnings
+ 'maintainer-script-ignores-error'.
+ * dselect/makefile:
+ - Removed unneeded 'LOCAL' entry. This allows cleaning rule to run smoothly.
+ * share/lintian-overrides:
+ - Added with override of 'apt must depend on python'. Script 'apt-mark'
+ needs apt-python for working and checks this on fly. We don't want
+ python in most cases.
+ * cmdline/apt-key:
+ - Added 'unset GREP_OPTIONS' to the script. This prevents 'apt-key update'
+ failure when GREP_OPTIONS contains options that modify grep output.
+ (Closes: #428752)
+
+ -- Eugene V. Lyubimkin <jackyf.devel@gmail.com> Fri, 31 Oct 2008 23:45:17 +0300
- -- Eugene V. Lyubimkin <jackyf.devel@gmail.com> Fri, 24 Oct 2008 23:45:17 +0300
+apt (0.7.17~exp3) experimental; urgency=low
+
+ * apt-pkg/acquire-item.cc:
+ - fix a merge mistake that prevents the fallback to the
+ uncompressed 'Packages' to work correctly (closes: #409284)
+
+ -- Michael Vogt <mvo@debian.org> Wed, 29 Oct 2008 09:36:24 +0100
+
+apt (0.7.17~exp2) experimental; urgency=low
+
+ [ Eugene V. Lyubimkin ]
+ * apt-pkg/acquire-item.cc:
+ - Added fallback to uncompressed 'Packages' if neither 'bz2' nor 'gz'
+ available. (Closes: #409284)
+ * apt-pkg/algorithm.cc:
+ - Strip username and password from source URL in error message.
+ (Closes: #425150)
+
+ [ Michael Vogt ]
+ * fix various -Wall warnings
+
+ -- Michael Vogt <mvo@debian.org> Tue, 28 Oct 2008 18:06:38 +0100
+
+apt (0.7.17~exp1) experimental; urgency=low
+
+ [ Luca Bruno ]
+ * Fix typos:
+ - apt-pkg/depcache.cc
+ * Fix compilation warnings:
+ - apt-pkg/acquire.cc
+ - apt-pkg/versionmatch.cc
+ * Compilation fixes and portability improvement for compiling APT against non-GNU libc
+ (thanks to Martin Koeppe, closes: #392063):
+ - buildlib/apti18n.h.in:
+ + textdomain() and bindtextdomain() must not be visible when --disable-nls
+ - buildlib/inttypes.h.in: undefine standard int*_t types
+ - Append INTLLIBS to SLIBS:
+ + cmdline/makefile
+ + ftparchive/makefile
+ + methods/makefile
+ * doc/apt.conf.5.xml:
+ - clarify whether configuration items of apt.conf are case-sensitive
+ (thanks to Vincent McIntyre, closes: #345901)
+
+ -- Luca Bruno <lethalman88@gmail.com> Sat, 11 Oct 2008 09:17:46 +0200
apt (0.7.16) unstable; urgency=low
* support for unattended-upgrades (via unattended-upgrades
package)
* added apt-transport-https method
+ * merged "install-recommends" branch (ABI break):
+ - new "--install-recommends"
+ - install new recommends on "upgrade" if --install-recommends is
+ given
+ - new "--fix-policy" option to install all packages with unmet
+ important dependencies (usefull with --install-recommends to
+ see what not-installed recommends are on the system)
+ - fix of recommended packages display (only show CandidateVersion
+ fix or-group handling)
+ * merged "install-task" branch (use with "apt-get install taskname^")
-- Michael Vogt <mvo@debian.org> Fri, 12 Jan 2007 20:48:07 +0100
apt (0.6.46.1) unstable; urgency=low
- * merged "install-recommends" branch (ABI break):
- - new "--install-recommends"
- - install new recommends on "upgrade" if --install-recommends is
- given
- - new "--fix-policy" option to install all packages with unmet
- important dependencies (usefull with --install-recommends to
- see what not-installed recommends are on the system)
- - fix of recommended packages display (only show CandidateVersion
- fix or-group handling)
- * merged "install-task" branch (use with "apt-get install taskname^")
* methods/gzip.cc:
- deal with empty files
* Applied patch from Daniel Schepler to make apt bin-NMU able.