]> git.saurik.com Git - apt.git/blobdiff - debian/rules
origin can be used to match a hostname (Closes: #352667)
[apt.git] / debian / rules
index f69c0cffb7999b9dfcc5cb4dd5a20f3f51a5aa03..2fe6ed69c31ca604d879de86037b4b5842bae34f 100755 (executable)
@@ -78,8 +78,8 @@ APT_UTILS=ftparchive sortpkgs extracttemplates
 include buildlib/libversion.mak
 
 # Determine which package we should provide in the control files
-LIBAPTPKG_PROVIDE=libapt-pkg-$(LIBAPTPKG_MAJOR)
-LIBAPTINST_PROVIDE=libapt-inst-$(LIBAPTINST_MAJOR)
+LIBAPTPKG_PROVIDE=libapt-pkg$(LIBAPTPKG_MAJOR)
+LIBAPTINST_PROVIDE=libapt-inst$(LIBAPTINST_MAJOR)
 
 debian/shlibs.local: apt-pkg/makefile
        # We have 3 shlibs.local files.. One for 'apt', one for 'apt-utils' and
@@ -190,7 +190,7 @@ apt: build build-doc debian/shlibs.local
        dh_testdir -p$@
        dh_testroot -p$@
        dh_clean -p$@ -k
-       dh_installdirs -p$@ /usr/share/bug/$@ /usr/share/$@
+       dh_installdirs -p$@
 #
 # apt install
 #
@@ -213,7 +213,6 @@ apt: build build-doc debian/shlibs.local
        cp debian/bugscript debian/$@/usr/share/bug/apt/script
        cp debian/apt.logrotate debian/$@/etc/logrotate.d/apt
 
-       cp share/debian-archive.gpg debian/$@/usr/share/$@
        cp debian/apt.conf.autoremove debian/$@/etc/apt/apt.conf.d/01autoremove
 #      head -n 500 ChangeLog > debian/ChangeLog