* Updated cron script to support backups by hardlinks and
verbose levels. All features turned off by default.
* Added more error handlings. Closes: #438803, #462734, #454989,
- * Refactored condition structure to make download and upgrade performed
- if only previous steps succeeded. Closes: #341970
* Documented all cron script related configuration items in
configure-index.
* apt-pkg/algorithms.cc:
- consider recommends when making the scores for the problem
resolver
-
+ * apt-pkg/acquire-worker.cc:
+ - show error details of failed methods
+ * apt-pkg/contrib/fileutl.cc:
+ - if a process aborts with signal, show signal number
+ * methods/http.cc:
+ - ignore SIGPIPE, we deal with EPIPE from write in
+ HttpMethod::ServerDie() (LP: #385144)
+ * apt-pkg/deb/dpkgpm.cc:
+ - provide DPkg::Chroot-Directory config option (useful for testing)
+ * Only run Download-Upgradable and Unattended-Upgrades if the initial
+ update was successful Closes: #341970
+
-- Michael Vogt <michael.vogt@ubuntu.com> Thu, 28 May 2009 17:51:42 +0200
[ Michael Vogt ]