# Made with the aid of dh_make, by Craig Small
# Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
# Some lines taken from debmake, by Christoph Lameter.
-# $Id: rules,v 1.10 1999/03/18 03:30:31 doogie Exp $
-DEB_BUILD_PROG:=debuild
-APT_DEBVER=$(shell dpkg-parsechangelog |sed -n -e '/^Version:/s/^Version: //p')
-APT_CONFVER=$(shell sed -n -e 's/^AC_DEFINE_UNQUOTED(VERSION,"\(.*\)")/\1/p' configure.in)
+# build in verbose mode by default to make it easy to diangose issues
+export NOISY=1
-ifneq ($(APT_DEBVER),$(APT_CONFVER))
-.PHONY: configure.in
-configure.in:
- sed -e 's/$(APT_CONFVER)/$(APT_DEBVER)/' $@ > $@.$$$$;mv $@.$$$$ $@
+export DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
+export DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
+export DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
+
+# FOR AUTOCONF 2.52 AND NEWER ONLY
+ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
+ confflags += --build $(DEB_HOST_GNU_TYPE)
+else
+ confflags += --build $(DEB_BUILD_GNU_TYPE) --host $(DEB_HOST_GNU_TYPE)
+endif
+
+# See below
+-include build/environment.mak
+
+ifneq (,$(shell which dpkg-buildflags))
+ # make does not export to $(shell) so we need to workaround
+ # (http://savannah.gnu.org/bugs/?10593)
+ dpkg_buildflags = DEB_BUILD_MAINT_OPTIONS=hardening=+all dpkg-buildflags
+ export CXXFLAGS = $(shell $(dpkg_buildflags) --get CXXFLAGS)
+ export LDFLAGS = $(shell $(dpkg_buildflags) --get LDFLAGS)
+ export CPPFLAGS = $(shell $(dpkg_buildflags) --get CPPFLAGS)
+else
+ ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+ export CXXFLAGS = -O0 -g -Wall
+ else
+ export CXXFLAGS = -O2 -g -Wall
+ endif
+endif
+
+# Default rule
+build:
+
+PKG=apt
+DEB_BUILD_PROG:=debuild --preserve-envvar PATH --preserve-envvar CCACHE_DIR -us -uc $(DEB_BUILD_PROG_OPTS)
+
+# Determine the build directory to use
+BASE=.
+ifdef BUILD
+BUILD_POSSIBLE := $(BUILD) $(BASE)/$(BUILD)
else
-configure.in:
+BUILD_POSSIBLE := $(BASE) $(BASE)/build-$(shell uname --machine) $(BASE)/build
endif
+BUILDX:= $(foreach i,$(BUILD_POSSIBLE),$(wildcard $(i)/environment.mak*))
+BUILDX:= $(patsubst %/,%,$(firstword $(dir $(BUILDX))))
+override BLD := $(BUILDX)
+
+ifeq ($(words $(BLD)),0)
+override BLD := ./build
+endif
+
+# APT Programs in apt-utils
+APT_UTILS=ftparchive sortpkgs extracttemplates
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
# Find the libapt-pkg major version for use in other control files
-export LIBAPT_MAJOR=`egrep '^MAJOR=' apt-pkg/makefile |cut -d '=' -f 2`
+include buildlib/libversion.mak
+
+# Determine which library package names to use
+LIBAPT_PKG=libapt-pkg$(LIBAPTPKG_MAJOR)
+LIBAPT_INST=libapt-inst$(LIBAPTINST_MAJOR)
-build: build-stamp
-build-stamp: configure
+# do not fail as we are just experimenting with symbol files for now
+export DPKG_GENSYMBOLS_CHECK_LEVEL=0
+
+build-binary: build/build-binary-stamp
+build-docbook: build/build-docbook-stamp
+build-manpages: build/build-manpages-stamp
+
+# Note that this is unconditionally done first as part of loading environment.mak
+# The true is needed to force make to reload environment.mak after running
+# configure-stamp. Otherwise we can get stale or invalid, or missing config data.
+build/environment.mak: build/configure-stamp
+ @true
+
+configure: configure.ac
+build/configure-stamp: configure buildlib/config.sub buildlib/config.guess
dh_testdir
-mkdir build
- (cd build; ../configure)
-# cd build && CXXFLAGS="-g -Wall -D_POSIX_C_SOURCE=199309" ../configure --disable-nls --disable-static --prefix=/usr
-# cd build && make all-hdr
-# cd build && make -s
-
+ cp COPYING debian/copyright
+ cd build && CXXFLAGS="$(CXXFLAGS)" LDFLAGS="$(LDFLAGS)" CPPFLAGS="$(CPPFLAGS)" ../configure $(confflags)
+ touch $@
+
+build/build-binary-stamp: build/configure-stamp
+ # Add here commands to compile the package.
+ $(MAKE) binary
+ # compat symlink for the locale split
+ mkdir -p build/usr/share
+ cd build/usr/share && ln -f -s ../../locale .
+ # compile and run tests
+ifeq (,$(findstring nocheck, $(DEB_BUILD_OPTIONS)))
+ $(MAKE) test
+else
+ @echo "Tests DISABLED"
+endif
+ touch $@
+
+build/build-docbook-stamp: build/configure-stamp
+ # Add here commands to compile the package.
+ $(MAKE) docbook
+ touch $@
+
+build/build-manpages-stamp: build/configure-stamp
# Add here commands to compile the package.
- make
- touch build-stamp
+ $(MAKE) manpages
+ touch $@
clean:
dh_testdir
-# dh_testroot
- rm -f build-stamp
+ dh_clean
+
+ [ ! -f Makefile ] || $(MAKE) clean distclean
rm -rf build
+ rm -f debian/$(LIBAPT_PKG).install debian/$(LIBAPT_INST).install \
+ debian/libapt-pkg-dev.install debian/apt.install
+ test ! -L buildlib/config.guess || rm -f buildlib/config.guess
+ test ! -L buildlib/config.sub || rm -f buildlib/config.sub
- # Add here commands to clean up after the build process.
- -$(MAKE) clean
- -$(MAKE) distclean
- dh_clean
+debian/%.install: debian/%.install.in
+ sed 's/@DEB_HOST_MULTIARCH@/$(DEB_HOST_MULTIARCH)/g' $< > $@
# Build architecture-independent files here.
-binary-indep: build
- dh_testdir -i
- dh_testroot -i
- dh_clean -i -k
- dh_installdirs -i
+libapt-pkg-doc: build-docbook
+ dh_testdir -p$@
+ dh_testroot -p$@
+ dh_prep -p$@
+ dh_installdirs -p$@
#
# libapt-pkg-doc install
#
+ rm -f $(BLD)/doc/doxygen/html/*.map $(BLD)/doc/doxygen/html/*.md5
+ dh_installdocs -p$@ $(BLD)/docs/design* \
+ $(BLD)/docs/dpkg-tech* \
+ $(BLD)/docs/files* \
+ $(BLD)/docs/method* \
+ doc/libapt-pkg2_to_3.txt \
+ doc/style.txt \
+ $(BLD)/doc/doxygen/html
+ dh_installexamples -p$@
+
+ dh_installchangelogs -p$@
+ dh_strip -p$@
+ dh_compress -p$@ -X.xhtml
+ dh_fixperms -p$@
+ dh_installdeb -p$@
+ dh_gencontrol -p$@
+ dh_md5sums -p$@
+ dh_builddeb -p$@
+
+apt-doc: build-docbook
+ dh_testdir -p$@
+ dh_testroot -p$@
+ dh_prep -p$@
+#
+# apt-doc install
+#
+ # Copy the guides
+ dh_installdocs -p$@ $(BLD)/docs/guide*.text \
+ $(BLD)/docs/guide*.html \
+ $(BLD)/docs/offline*.text \
+ $(BLD)/docs/offline*.html
+ dh_installchangelogs -p$@
+ dh_compress -p$@
+ dh_fixperms -p$@
+ dh_installdeb -p$@
+ dh_gencontrol -p$@
+ dh_md5sums -p$@
+ dh_builddeb -p$@
- cp -a build/docs/cache* build/docs/design* build/docs/dpkg-tech* \
- build/docs/files* build/docs/method* debian/libapt-pkg-doc/usr/doc/apt/
- cp -a debian/libapt-pkg-doc.dhelp debian/libapt-pkg-doc/usr/doc/libapt-pkg-doc/.dhelp
- dh_installdocs -i
- dh_installexamples -i
-# dh_installmenu -i
-# dh_installinit -i
-# dh_installcron -i
- dh_installmanpages -i
-
-# dh_undocumented -i
- dh_installchangelogs -i
- dh_strip -i
- dh_compress -i
- dh_fixperms -i
-# dh_suidregister -i
- dh_installdeb -i
- dh_gencontrol -i -u -Vlibapt-pkg:major=${LIBAPT_MAJOR}
- dh_md5sums -i
- dh_builddeb -i
# Build architecture-dependent files here.
-binary-arch: build
- dh_testdir -a
- dh_testroot -a
- dh_clean -a -k
- dh_installdirs -a
+apt_MANPAGES = apt apt-cache apt-cdrom apt-config apt-get apt-key apt-mark apt-secure apt apt.conf apt_preferences sources.list
+apt: build-binary build-manpages debian/apt.install
+ dh_testdir -p$@
+ dh_testroot -p$@
+ dh_prep -p$@
+ dh_installdirs -p$@
#
# apt install
#
- cp build/bin/apt-* debian/tmp/usr/bin/
-
- # install the shared libs
- find build/bin/ -type f -name "libapt-pkg.so.*" -exec cp -a "{}" debian/tmp/usr/lib/ \;
- find build/bin/ -type l -name "libapt-pkg.so.*" -exec cp -a "{}" debian/tmp/usr/lib/ \;
-
- cp build/bin/methods/* debian/tmp/usr/lib/apt/methods/
-
- cp build/scripts/dselect/* debian/tmp/usr/lib/dpkg/methods/apt/
-# cp debian/sources.list debian/tmp/etc/apt/
-
- # Copy the users guide
- cp build/docs/guide.text debian/tmp/usr/doc/apt/users-guide.txt
- cp -a build/docs/guide.html/* debian/tmp/usr/doc/apt/users-guide.html/
-
- # Copy the offline guide
- cp build/docs/offline.text debian/tmp/usr/doc/apt/offline.txt
- cp -a build/docs/offline.html/* debian/tmp/usr/doc/apt/offline.html/
-
- cp -a debian/dhelp debian/tmp/usr/doc/apt/.dhelp
-
-# head -n 500 ChangeLog > debian/ChangeLog
+ cp debian/apt.conf.autoremove debian/$@/etc/apt/apt.conf.d/01autoremove
+ cp debian/apt.auto-removal.sh debian/$@/etc/kernel/postinst.d/apt-auto-removal
+ chmod 755 debian/$@/etc/kernel/postinst.d/apt-auto-removal
+ # install vendor specific apt confs
+ find -L vendor/current -name 'apt.conf-*' | while read conf; do cp "$${conf}" "debian/$@/etc/apt/apt.conf.d/$${conf#*-}"; done
+
+ # make rosetta happy and remove pot files in po/ (but leave stuff
+ # in po/domains/* untouched) and cp *.po into each domain dir
+ rm -f build/po/*.pot
+ rm -f po/*.pot
+
+ dh_install -p$@ --sourcedir=$(BLD)
+
+ # Remove the bits that are in apt-utils
+ rm $(addprefix debian/$@/usr/bin/apt-,$(APT_UTILS) dump-solver internal-solver)
+
+ # https has its own package
+ rm debian/$@/usr/lib/apt/methods/https
+ # move the mirror failure script in place
+ #mv debian/$@/usr/bin/apt-report-mirror-failure \
+ # debian/$@/usr/lib/apt/apt-report-mirror-failure \
+
+ # move the apt-helper in place
+ mv debian/$@/usr/bin/apt-helper debian/$@/usr/lib/apt/apt-helper
+
+ dh_bugfiles -p$@
+ dh_lintian -p$@
+ dh_installexamples -p$@ $(BLD)/docs/examples/*
+ dh_installman -p$@ $(wildcard $(patsubst %,doc/en/%.[158],$(apt_MANPAGES)) $(patsubst %,doc/*/%.*.[158],$(apt_MANPAGES)))
+ dh_installcron -p$@
+ dh_installdocs -p$@
+ dh_installchangelogs -p$@
+ dh_installlogrotate -p$@
+ dh_strip -p$@
+ dh_compress -p$@
+ dh_fixperms -p$@
+ dh_makeshlibs -p$@
+ dh_installdeb -p$@
+ dh_shlibdeps -p$@
+ dh_gencontrol -p$@ -- -Vapt:keyring="$(shell ./vendor/getinfo keyring-package)"
+ dh_md5sums -p$@
+ dh_builddeb -p$@
+
+libapt-pkg-dev: build-binary debian/libapt-pkg-dev.install
+ dh_testdir -p$@
+ dh_testroot -p$@
+ dh_prep -p$@
+ dh_installdirs -p$@
#
# libapt-pkg-dev install
#
- ln -s libapt-pkg.so.${LIBAPT_MAJOR} debian/libapt-pkg-dev/usr/lib/libapt-pkg.so
- cp build/include/apt-pkg/*.h debian/libapt-pkg-dev/usr/include/apt-pkg/
-
-
- dh_installdocs -a
- dh_installexamples -papt build/docs/examples/*
-# dh_installmenu -papt
-# dh_installinit -papt
-# dh_installcron -papt
- dh_installmanpages -a
-
-# dh_undocumented -papt
- dh_installchangelogs -a
- dh_strip -a
- dh_compress -a
- dh_fixperms -a
-# dh_suidregister -a
- dh_installdeb -a
- LD_LIBRARY_PATH=`pwd`/debian/tmp/usr/lib dh_shlibdeps -papt
- dh_gencontrol -a -u-Vlibapt-pkg:major=${LIBAPT_MAJOR}
- dh_makeshlibs -m${LIBAPT_MAJOR} -Vlibapt-pkg${LIBAPT_MAJOR} -papt
- dh_md5sums -a
- dh_builddeb -a
-
-source diff:
- @echo >&2 'source and diff are obsolete - use dpkg-source -b'; false
-
-# Update from CVS
-l33ch: really-clean
- cvs update
- buildlib/mkChangeLog
-
-# Update from CVS and then configure for build
-super-l33ch: l33ch Makefile.in
+ dh_install -p$@ --sourcedir=$(BLD)
+ dh_installdocs -p$@
+ dh_installchangelogs -p$@
+ dh_strip -p$@
+ dh_compress -p$@
+ dh_fixperms -p$@
+ dh_installdeb -p$@
+ dh_gencontrol -p$@ -- -Vlibapt-pkg-name=$(LIBAPT_PKG) -Vlibapt-inst-name=$(LIBAPT_INST)
+ dh_md5sums -p$@
+ dh_builddeb -p$@
-configure:
- make configure
+apt-utils_MANPAGES = apt-sortpkgs apt-ftparchive apt-extracttemplates
+apt-utils: build-binary build-manpages
+ dh_testdir -p$@
+ dh_testroot -p$@
+ dh_prep -p$@
+ dh_installdirs -p$@
-l33ch-stamp: super-l33ch
- touch l33ch-stamp
+ cp $(addprefix $(BLD)/bin/apt-,$(APT_UTILS)) debian/$@/usr/bin/
+ cp $(BLD)/bin/apt-dump-solver debian/$@/usr/lib/apt/solvers/dump
+ cp $(BLD)/bin/apt-internal-solver debian/$@/usr/lib/apt/solvers/apt
-really-clean: clean
- -find -name Makefile.in -print0 | xargs -0r rm -f
- find -name ChangeLog | xargs rm -f
- rm -f l33ch-stamp
+ dh_install -p$@ --sourcedir=$(BLD)
+ dh_link -p$@
+ dh_installdocs -p$@
+ dh_installexamples -p$@
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary
+ # Install the man pages..
+ dh_installman -p$@ $(wildcard $(patsubst %,doc/en/%.[158],$(apt-utils_MANPAGES)) $(patsubst %,doc/*/%.*.[158],$(apt-utils_MANPAGES)))
+
+ dh_installchangelogs -p$@
+ dh_strip -p$@
+ dh_compress -p$@
+ dh_fixperms -p$@
+ dh_makeshlibs -p$@
+ dh_installdeb -p$@
+ dh_shlibdeps -p$@
+ dh_gencontrol -p$@
+ dh_md5sums -p$@
+ dh_builddeb -p$@
+$(LIBAPT_PKG): build-binary debian/$(LIBAPT_PKG).install
+ dh_testdir -p$@
+ dh_testroot -p$@
+ dh_prep -p$@
+ dh_installdirs -p$@
-# Done by the uploader.
-#cvs update..
-#edit debian/changelog
-# configure.in has the version automatically updated now.
-# edit configure.in
-# debian/rules cvs-build
-
-cvs-build:
- rm -rf debian/cvs-build
- cvs update
- buildlib/mkChangeLog
- make doc
- tar c --exclude CVS --exclude debian/cvs-build . |\
- (mkdir -p debian/cvs-build/apt-$(APT_DEBVER);cd debian/cvs-build/apt-$(APT_DEBVER);tar x)
-# The next line isn't needed, as debuild will make the .tar.gz for us.
-# (cd debian/cvs-build;tar zcf apt_$(APT_DEBVER).tar.gz apt-$(APT_DEBVER))
- (cd debian/cvs-build/apt-$(APT_DEBVER);$(DEB_BUILD_PROG) -us -uc)
+ dh_install -p$@ --sourcedir=$(BLD)
+ dh_installdocs -p$@
+ dh_installchangelogs -p$@
+ dh_strip -p$@
+ dh_compress -p$@
+ dh_fixperms -p$@
+ dh_makeshlibs -p$@
+ dh_installdeb -p$@
+ dh_shlibdeps -p$@
+ dh_gencontrol -p$@
+ dh_md5sums -p$@
+ dh_builddeb -p$@
+
+$(LIBAPT_INST): build-binary debian/$(LIBAPT_INST).install
+ dh_testdir -p$@
+ dh_testroot -p$@
+ dh_prep -p$@
+ dh_installdirs -p$@
+
+ dh_install -p$@ --sourcedir=$(BLD)
+ dh_installdocs -p$@
+ dh_installchangelogs -p$@
+ dh_strip -p$@
+ dh_compress -p$@
+ dh_fixperms -p$@
+ dh_makeshlibs -p$@
+ dh_installdeb -p$@
+ dh_shlibdeps -p$@
+ dh_gencontrol -p$@
+ dh_md5sums -p$@
+ dh_builddeb -p$@
+
+apt-transport-https: build-binary libapt-pkg-dev
+ dh_testdir -p$@
+ dh_testroot -p$@
+ dh_prep -p$@
+ dh_installdirs -p$@
+
+ dh_install -p$@ --sourcedir=$(BLD)
+ dh_installdocs -p$@ debian/apt-transport-https.README
+ dh_installexamples -p$@
+
+ # Install the man pages..
+ dh_installman -p$@
+
+ dh_installchangelogs -p$@
+ dh_strip -p$@
+ dh_compress -p$@
+ dh_fixperms -p$@
+ dh_installdeb -p$@
+ dh_shlibdeps -p$@
+ dh_gencontrol -p$@
+ dh_md5sums -p$@
+ dh_builddeb -p$@
+
+buildlib/config.guess buildlib/config.sub:
+ $(MAKE) "$@"
+
+configure:
+ $(MAKE) configure
+
+# translate targets to targets required by debian-policy
+binary-arch: $(LIBAPT_PKG) $(LIBAPT_INST) apt libapt-pkg-dev apt-utils apt-transport-https
+binary-indep: apt-doc libapt-pkg-doc
+binary: binary-indep binary-arch
+build-arch: build-binary
+build-indep: build-manpages build-docbook
+build: build-indep build-arch
+
+.PHONY: build clean binary-indep binary-arch binary