case "$1" in
configure)
+ if dpkg --compare-versions "$2" lt 1.0.7; then
+ # apt-key before 0.9.10 could leave empty keyrings around
+ find /etc/apt/trusted.gpg.d/ -name '*.gpg' | while read keyring; do
+ if ! test -s "$keyring"; then
+ rm -f "$keyring"
+ fi
+ done
+ fi
+
if dpkg --compare-versions "$2" lt-nl 0.9.9.5; then
# we are using tmpfiles for both
rm -f /etc/apt/trustdb.gpg
fi
# add unprivileged user for the apt methods
- adduser --force-badname --system --no-create-home \
- --quiet Debian-apt || true
- chown -R Debian-apt:root \
+ adduser --force-badname --system -home /var/empty \
+ --no-create-home --quiet _apt || true
+ chown -R _apt:root \
/var/lib/apt/lists \
/var/cache/apt/archives