* cmdline/apt-get.cc:
- fix "apt-get source pkg=ver" if binary name != source name
and show a message (LP: #202219)
+ - fix "apt-get source pkg" if there is a binary package and
+ a source package of the same name but from different
+ packages (LP: #330103)
* apt-pkg/deb/debsystem.cc:
- make strings i18n able
* apt-pkg/contrib/strutl.cc:
* [ABI break] merge support for http redirects, thanks to
Jeff Licquia and Anthony Towns
* [ABI break] use int for the package IDs (thanks to Steve Cotton)
+ * apt-pkg/pkgcache.cc:
+ - do not run "dpkg --configure pkg" if pkg is in trigger-awaited
+ state (LP: #322955)
+ * methods/https.cc:
+ - add Acquire::https::AllowRedirect support
+ * methods/gpgv.cc:
+ - properly check for expired and revoked keys (closes: #433091)
+ * fix problematic use of tolower() when calculating the version
+ hash by using locale independant tolower_ascii() function.
+ Thanks to M. Vefa Bicakci (LP: #80248)
+ * build fixes for g++-4.4
[ Dereck Wonnacott ]
* apt-ftparchive might write corrupt Release files (LP: #46439)
* Apply --important option to apt-cache depends (LP: #16947)
* Clarify the --help for 'purge' (LP: #243948)
+
+ [ Colin Watson ]
+ * cmdline/acqprogress.cc:
+ - Call pkgAcquireStatus::Pulse even if quiet, so that we still get
+ dlstatus messages on the status-fd (LP: #290234).
+
-- Michael Vogt <michael.vogt@ubuntu.com> Fri, 12 Sep 2008 11:34:24 +0200
apt (0.7.20) unstable; urgency=low