# Made with the aid of dh_make, by Craig Small
# Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
# Some lines taken from debmake, by Christoph Lameter.
-# $Id: rules,v 1.67 2004/05/08 19:57:31 mdz Exp $
+# $Id: rules,v 1.68 2004/05/30 18:21:43 mdz Exp $
# LD_LIBRARY_PATH=pwd/debian/apt/usr/lib dh_shlibdeps -papt
# dpkg: /home/jgg/work/apt2/debian/apt/usr/lib/libapt-pkg.so.2.9 not found.
# Rebuild configure.in to have the correct version from the change log
ifneq ($(APT_DEBVER),$(APT_CONFVER))
+ifneq ($(APT_DEBVER),)
.PHONY: configure.in
configure.in:
sed -e 's/$(APT_CONFVER)/$(APT_DEBVER)/' $@ > $@.$$$$ && mv $@.$$$$ $@
+endif
else
configure.in:
endif
dh_testdir
-mkdir build
cp COPYING debian/copyright
- cd build && CXXFLAGS="$(confcxxflags)" ../configure $(confflags)
+ cd build && ../configure $(confflags)
touch $@
build/build-stamp: build/configure-stamp
dh_testdir -p$@
dh_testroot -p$@
dh_clean -p$@ -k
- dh_installdirs -p$@ /usr/share/bug/$@
+ dh_installdirs -p$@
#
# apt install
#
dh_installexamples -p$@ $(BLD)/docs/examples/*
dh_installman -p$@
-
+ dh_installcron -p$@
dh_installdocs -p$@
dh_installchangelogs -p$@
dh_strip -p$@
cvs-mkul:
-mkdir -p ../upload-$(APT_DEBVER)
cp `find debian/cvs-build -maxdepth 1 -type f` ../upload-$(APT_DEBVER)
+
+arch-build:
+ rm -rf debian/arch-build
+ mkdir -p debian/arch-build/apt-$(APT_DEBVER)
+ baz inventory -s | xargs cp -a --parents --target=debian/arch-build/apt-$(APT_DEBVER)
+ $(MAKE) -C debian/arch-build/apt-$(APT_DEBVER) startup doc
+ (cd debian/arch-build/apt-$(APT_DEBVER); $(DEB_BUILD_PROG))