]> git.saurik.com Git - apt.git/blobdiff - debian/changelog
Switch FileFd to not transparently gunzip, since that breaks code which expects the...
[apt.git] / debian / changelog
index bd328fd081a1a770c728369e8d009060b23e5057..f3f2d3df43ccb9e80acce1c0424334908ad4c20d 100644 (file)
@@ -5,11 +5,21 @@ apt (0.7.26~exp5) UNRELEASED; urgency=low
   * Italian translation update. Closes: #581742
 
   [ Martin Pitt ]
+  * debian/rules:
+    - Make DEB_BUILD_OPTIONS=noopt actually work by passing the right
+      CXXFLAGS.
   * apt-pkg/contrib/fileutl.{h,cc}:
-    - Add support for transparent reading of gzipped files.
+    - Add support for reading of gzipped files with the new "ReadOnlyGzip"
+      OpenMode.
     - Link against zlib (in apt-pkg/makefile) and add zlib build dependency.
-    - [ABI BREAK] This introduces a new protected member of FileFD and changes
-      the behaviour of FileFd for reading gzipped files.
+    - [ABI BREAK] This adds a new private member to FileFd, but its
+      initialization is in the public header file.
+  * configure.in:
+    - Check for zlib library and headers.
+  * apt-pkg/acquire-item.cc, apt-pkg/deb/debindexfile.cc,
+    apt-pkg/deb/debrecords.cc, apt-pkg/deb/debsrcrecords.h,
+    cmdline/apt-cache.cc:
+    - Open Packages, Sources, and Translations indexes in "ReadOnlyGzip" mode.
   * apt-pkg/deb/debindexfile.cc:
     - If we do not find uncompressed package/source/translation indexes, look
       for gzip compressed ones.
@@ -17,9 +27,17 @@ apt (0.7.26~exp5) UNRELEASED; urgency=low
     - If the Acquire::GzipIndexes option is true and we download a gzipped
       index file, keep it as it is (and rename to .gz) instead of
       uncompressing it.
+  * doc/apt.conf.5.xml:
+    - Document the new Acquire::GzipIndexes option.
+  * doc/po/apt-doc.pot, doc/po/de.po:
+    - German translation of new Acquire::GzipIndexes option.
   * Add test/test-indexes.sh:
     - Test behaviour of index retrieval and usage, in particular with
       uncompressed and gzip compressed indexes.
+  * apt-pkg/acquire-item.cc:
+    - Fix return value of pkgAcqFile::Custom600Headers() in the non-index
+      case, to avoid returning NULL and causing crashers in callers. This also
+      fixes a compiler warning.
 
  -- Christian Perrier <bubulle@debian.org>  Tue, 11 May 2010 19:52:00 +0200