+apt (1.3.1) unstable; urgency=medium
+
+ [ Julian Andres Klode ]
+ * Do not read stderr from proxy autodetection scripts
+ * travis: Move codecov from after_success to after_script
+
+ [ victory ]
+ * Japanese manpages translation update
+
+ [ Mert Dirik ]
+ * Turkish program translation update (Closes: #838731)
+
+ -- Julian Andres Klode <jak@debian.org> Tue, 04 Oct 2016 19:43:35 +0200
+
+apt (1.3) unstable; urgency=medium
+
+ [ David Kalnischkies ]
+ * abort connection on '.' target replies in SRV
+ * edsp: try 2 to read responses even if writing failed
+
+ [ Julian Andres Klode ]
+ * test: Always install dpkg into our tests, regardless of MA
+ * CMake: Add coverage build type
+ * Coverage: Do not print messages from gcov
+ * VersionHash: Do not skip too long dependency lines
+
+ -- Julian Andres Klode <jak@debian.org> Tue, 20 Sep 2016 23:53:51 +0200
+
+apt (1.3~rc4) unstable; urgency=medium
+
+ [ Julian Andres Klode ]
+ * Fix segfault and out-of-bounds read in Binary fields
+ * TagFile: Fix off-by-one errors in comment stripping
+ * Base256ToNum: Fix uninitialized value
+ * test-apt-cdrom: Fix for gnupg 2.1.15
+ * CMake: test/libapt: Use a prebuilt GTest library if available
+ * CMake: apt-pkg: Use correct ICONV_INCLUDE_DIRS variable
+ * acquire: Use priority queues and a 3 stage pipeline design
+ => faster updates with better progress reporting
+ * debian: Move bugscript to old location for overlayfs xdev issue
+ * debian: Pass -O to make to get readable build logs
+
+ [ David Kalnischkies ]
+ * try not to call memcpy with length 0 in hash calculations
+ * re-add apt breaks/replaces apt-utils (<< 1.3~exp2~) (Closes: #836220)
+ * support long keyid and fingerprint in gpgv's GOODSIG
+
+ -- Julian Andres Klode <jak@debian.org> Fri, 02 Sep 2016 20:26:36 +0200
+
apt (1.3~rc3) unstable; urgency=medium
[ Julian Andres Klode ]
* Fix select timeout to be 50msec instead of 0.5msec (Closes: #799857)
[ David Kalnischkies ]
- * M-A: allowed pkgs of unconfigured archs do not statisfy :any
+ * M-A: allowed pkgs of unconfigured archs do not satisfy :any
* implement dpkgs vision of interpreting pkg:<arch> dependencies
* add Source-Version field for EDSP
* fix insecure use of /tmp in EDSP solver 'dump' (Closes: 795600)
- handle :all and :native correctly as architectures again
in the commandline parsing (regression in 0.9.7)
* apt-pkg/packagemanager.cc:
- - do not segfault if nothing can be configured to statisfy
+ - do not segfault if nothing can be configured to satisfy
a pre-depends (e.g. in a pre-depends loop) (Closes: #681958)
* apt-pkg/contrib/mmap.cc:
- trigger the usage of the fallback code for kfreebsd also in the
- load the dpkg base arguments only one time and reuse them later
* cmdline/apt-get.cc:
- follow Provides in the evaluation of saving candidates, too, for
- statisfying garbage package dependencies (Closes: #640590)
+ satisfying garbage package dependencies (Closes: #640590)
* apt-pkg/algorithms.cc:
- if a package is garbage, don't try to save it with FixByInstall
* apt-pkg/deb/debsrcrecords.cc:
- load the dpkg base arguments only one time and reuse them later
* cmdline/apt-get.cc:
- follow Provides in the evaluation of saving candidates, too, for
- statisfying garbage package dependencies (Closes: #640590)
+ satisfying garbage package dependencies (Closes: #640590)
* apt-pkg/algorithms.cc:
- if a package is garbage, don't try to save it with FixByInstall
* apt-pkg/init.cc:
consider it as a candidate for FixByInstall
* apt-pkg/depcache.cc:
- don't install previously not installed providers in a try
- to statisfy a "Breaks: provides" dependency by upgrade
+ to satisfy a "Breaks: provides" dependency by upgrade
* cmdline/acqprogress.cc:
- don't ask the user for media change if quiet >= 2, stdout is not
a tty and assume-yes, force-yes or trivial-only option is set to