]> git.saurik.com Git - apt.git/blobdiff - debian/rules
merge with debian/sid
[apt.git] / debian / rules
index 07368bfadae0a2113b48d259c8d5ebc8cc6bf2fe..30474c06b71fb4cd9ac6adbd7a70a45119e97e52 100755 (executable)
 # Made with the aid of dh_make, by Craig Small
 # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
 # Some lines taken from debmake, by Christoph Lameter.
 # Made with the aid of dh_make, by Craig Small
 # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
 # Some lines taken from debmake, by Christoph Lameter.
-# $Id: rules,v 1.9 1999/03/16 19:30:31 che Exp $
 
 
+export DEB_HOST_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
+export DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
+
+# FOR AUTOCONF 2.52 AND NEWER ONLY
+ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
+  confflags += --build $(DEB_HOST_GNU_TYPE)
+else
+  confflags += --build $(DEB_BUILD_GNU_TYPE) --host $(DEB_HOST_GNU_TYPE)
+endif
+
+# See below
+-include build/environment.mak
+
+ifneq (,$(shell which dpkg-buildflags))
+  export CXXFLAGS = $(shell dpkg-buildflags --get CXXFLAGS)
+else
+  ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+    export CXXFLAGS = -O0 -g -Wall
+  else
+    export CXXFLAGS = -O2 -g -Wall
+  endif
+endif
+
+# Default rule
+build:
+
+PKG=apt
+DEB_BUILD_PROG:=debuild --preserve-envvar PATH --preserve-envvar CCACHE_DIR -us -uc $(DEB_BUILD_PROG_OPTS)
+APT_DEBVER=$(shell dpkg-parsechangelog |sed -n -e '/^Version:/s/^Version: //p' | sed -e 's/\+.*$$//')
+APT_CONFVER=$(shell sed -n -e 's/^AC_DEFINE_UNQUOTED(VERSION,"\(.*\)")/\1/p' configure.in)
+APT_CVSTAG=$(shell echo "$(APT_DEBVER)" | sed -e 's/^/v/' -e 's/\./_/g')
+
+# Determine the build directory to use
+BASE=.
+ifdef BUILD
+BUILD_POSSIBLE := $(BUILD) $(BASE)/$(BUILD)
+else
+BUILD_POSSIBLE := $(BASE) $(BASE)/build-$(shell uname --machine) $(BASE)/build
+endif
+BUILDX:= $(foreach i,$(BUILD_POSSIBLE),$(wildcard $(i)/environment.mak*))
+BUILDX:= $(patsubst %/,%,$(firstword $(dir $(BUILDX))))
+override BLD := $(BUILDX)
+
+ifeq ($(words $(BLD)),0)
+override BLD := ./build
+endif
+
+# Rebuild configure.in to have the correct version from the change log
+ifneq ($(APT_DEBVER),$(APT_CONFVER))
+ifneq ($(APT_DEBVER),)
+.PHONY: configure.in
+configure.in:
+       sed -e 's/$(APT_CONFVER)/$(APT_DEBVER)/' $@ > $@.$$$$ && mv $@.$$$$ $@
+endif
+else
+configure.in:
+endif
+
+# APT Programs in apt-utils
+APT_UTILS=ftparchive sortpkgs extracttemplates internal-solver
 
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
 
 # Find the libapt-pkg major version for use in other control files
 
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
 
 # Find the libapt-pkg major version for use in other control files
-export LIBAPT_MAJOR=`egrep '^MAJOR=' apt-pkg/makefile |cut -d '=' -f 2`
+include buildlib/libversion.mak
+
+# Determine which library package names to use
+LIBAPT_PKG=libapt-pkg$(LIBAPTPKG_MAJOR)
+LIBAPT_INST=libapt-inst$(LIBAPTINST_MAJOR)
+
+# do not fail as we are just experimenting with symbol files for now
+export DPKG_GENSYMBOLS_CHECK_LEVEL=0
 
 
-build: build-stamp
-build-stamp: configure
+build: build/build-stamp
+build-doc: build/build-doc-stamp
+
+# Note that this is unconditionally done first as part of loading environment.mak
+# The true is needed to force make to reload environment.mak after running
+# configure-stamp. Otherwise we can get stale or invalid, or missing config data.
+build/environment.mak: build/configure-stamp
+       @true
+
+configure: configure.in
+build/configure-stamp: configure
        dh_testdir
        -mkdir build
        dh_testdir
        -mkdir build
-       cd build; ../configure
-       cd ..
-#      cd build && CXXFLAGS="-g -Wall -D_POSIX_C_SOURCE=199309" ../configure --disable-nls --disable-static --prefix=/usr
-#      cd build && make all-hdr
-#      cd build && make -s
-       
+       cp COPYING debian/copyright
+       cd build && CXXFLAGS="$(CXXFLAGS)" ../configure $(confflags)
+       touch $@
+
+build/build-stamp: build/configure-stamp
        # Add here commands to compile the package.
        # Add here commands to compile the package.
-       make
-       touch build-stamp
+       $(MAKE) binary
+       # compat symlink for the locale split
+       mkdir -p build/usr/share 
+       cd build/usr/share && ln -f -s ../../locale .
+       # compile and run tests
+ifeq (,$(findstring nocheck, $(DEB_BUILD_OPTIONS)))
+       $(MAKE) test
+else
+       @echo "Tests DISABLED"
+endif
+       touch $@
+
+build/build-doc-stamp: build/configure-stamp
+       # Add here commands to compile the package.
+       $(MAKE) doc
+       touch $@
 
 clean:
        dh_testdir
 
 clean:
        dh_testdir
-#      dh_testroot
-       rm -f build-stamp
-       rm -rf build
 
 
-       # Add here commands to clean up after the build process.
-       -$(MAKE) clean
-       -$(MAKE) distclean
-       dh_clean
+       [ ! -f Makefile ] || $(MAKE) clean distclean
+       rm -rf build
 
 
+binary-indep: apt-doc libapt-pkg-doc
 # Build architecture-independent files here.
 # Build architecture-independent files here.
-binary-indep: build libapt-pkg-doc
-# We have nothing to do by default.
+libapt-pkg-doc: build-doc
+       dh_testdir -p$@
+       dh_testroot -p$@
+       dh_prep -p$@
+       dh_installdirs -p$@
+#
+# libapt-pkg-doc install
+#
+       dh_installdocs -p$@ $(BLD)/docs/design* \
+                           $(BLD)/docs/dpkg-tech* \
+                           $(BLD)/docs/files* \
+                           $(BLD)/docs/method* \
+                           doc/libapt-pkg2_to_3.txt \
+                           doc/style.txt \
+                           $(BLD)/doc/doxygen/html
+       dh_installexamples -p$@
+
+       dh_installchangelogs -p$@
+       dh_strip -p$@
+       dh_compress -p$@
+       dh_fixperms -p$@
+       dh_installdeb -p$@
+       dh_gencontrol -p$@
+       dh_md5sums -p$@
+       dh_builddeb -p$@
+
+apt-doc: build-doc
+       dh_testdir -p$@
+       dh_testroot -p$@
+       dh_prep -p$@
+#
+# apt-doc install
+#
+       # Copy the guides
+       dh_installdocs -p$@ $(BLD)/docs/guide*.text \
+                           $(BLD)/docs/guide*.html \
+                           $(BLD)/docs/offline*.text \
+                           $(BLD)/docs/offline*.html
+       dh_installchangelogs -p$@
+       dh_compress -p$@
+       dh_fixperms -p$@
+       dh_installdeb -p$@
+       dh_gencontrol -p$@
+       dh_md5sums -p$@
+       dh_builddeb -p$@
+
+
 
 # Build architecture-dependent files here.
 
 # Build architecture-dependent files here.
-binary-arch: build apt libapt-pkg-dev
-
-apt: build
-#      dh_testversion -papt
-       dh_testdir -papt
-       dh_testroot -papt
-       dh_clean -papt -k
-       dh_installdirs -papt usr/bin usr/lib/apt/methods usr/lib/dpkg/methods/apt etc/apt usr/doc/apt var/cache/apt/archives/partial var/state/apt/lists/partial
-
-       cp build/bin/apt-* debian/tmp/usr/bin/
-       
-       # install the shared libs
-       find build/bin/ -type f -name "libapt-pkg.so.*" -exec cp -a "{}" debian/tmp/usr/lib/ \;
-       find build/bin/ -type l -name "libapt-pkg.so.*" -exec cp -a "{}" debian/tmp/usr/lib/ \;
-
-       cp build/bin/methods/* debian/tmp/usr/lib/apt/methods/
-
-       cp build/scripts/dselect/* debian/tmp/usr/lib/dpkg/methods/apt/
-#      cp debian/sources.list debian/tmp/etc/apt/
-
-       # Copy the users guide  
-       cp build/docs/guide.text debian/tmp/usr/doc/apt/users-guide.txt
-       mkdir debian/tmp/usr/doc/apt/users-guide.html/
-       cp -a build/docs/guide.html/* debian/tmp/usr/doc/apt/users-guide.html/
-       
-       # Copy the offline guide        
-       cp build/docs/offline.text debian/tmp/usr/doc/apt/offline.txt
-       mkdir debian/tmp/usr/doc/apt/offline.html/
-       cp -a build/docs/offline.html/* debian/tmp/usr/doc/apt/offline.html/
-       
-       cp -a debian/dhelp debian/tmp/usr/doc/apt/.dhelp
-       
-#      head -n 500 ChangeLog > debian/ChangeLog
-
-       dh_installdocs -papt 
-       dh_installexamples -papt build/docs/examples/*
-#      dh_installmenu -papt
-#      dh_installinit -papt
-#      dh_installcron -papt
-       dh_installmanpages -papt
-
-#      dh_undocumented -papt
-       dh_installchangelogs -papt
-       dh_strip -papt
-       dh_compress -papt
-       dh_fixperms -papt
-       dh_suidregister -papt
-       dh_installdeb -papt
-       LD_LIBRARY_PATH=debian/tmp/usr/lib dh_shlibdeps -papt
-       echo libapt-pkg:major=${LIBAPT_MAJOR} >> debian/substvars
-       dh_gencontrol -papt
-       dh_makeshlibs -m${LIBAPT_MAJOR} -Vlibapt-pkg${LIBAPT_MAJOR} -papt
-       dh_md5sums -papt
-       dh_builddeb -papt
+
+binary-arch: $(LIBAPT_PKG) $(LIBAPT_INST) apt libapt-pkg-dev apt-utils apt-transport-https
+apt_MANPAGES = apt-cache apt-cdrom apt-config apt-get apt-key apt-mark apt-secure apt apt.conf apt_preferences sources.list
+apt: build build-doc
+       dh_testdir -p$@
+       dh_testroot -p$@
+       dh_prep -p$@
+       dh_installdirs -p$@
+#
+# apt install
+#
+       cp debian/apt.conf.autoremove debian/$@/etc/apt/apt.conf.d/01autoremove
+
+       # make rosetta happy and remove pot files in po/ (but leave stuff
+       # in po/domains/* untouched) and cp *.po into each domain dir
+       rm -f build/po/*.pot
+       rm -f po/*.pot
+
+       dh_install -p$@ --sourcedir=$(BLD)
+
+       # Remove the bits that are in apt-utils
+       rm $(addprefix debian/$@/usr/bin/apt-,$(APT_UTILS) dump-solver)
+
+       # https has its own package
+       rm debian/$@/usr/lib/apt/methods/https
+
+       # move the mirror failure script in place
+       #mv debian/$@/usr/bin/apt-report-mirror-failure \
+       #   debian/$@/usr/lib/apt/apt-report-mirror-failure \
+
+       dh_bugfiles -p$@
+       dh_lintian -p$@
+       dh_installexamples -p$@ $(BLD)/docs/examples/*
+       dh_installman -p$@ $(wildcard $(patsubst %,doc/%.[158],$(apt_MANPAGES)) $(patsubst %,doc/*/%.*.[158],$(apt_MANPAGES)))
+       dh_installcron -p$@
+       dh_installdocs -p$@
+       dh_installchangelogs -p$@
+       dh_installlogrotate -p$@
+       dh_strip -p$@
+       dh_compress -p$@
+       dh_fixperms -p$@
+       dh_installdeb -p$@
+       dh_shlibdeps -p$@
+       dh_gencontrol -p$@
+       dh_md5sums -p$@
+       dh_builddeb -p$@
 
 libapt-pkg-dev: build
 
 libapt-pkg-dev: build
-       dh_testdir -plibapt-pkg-dev
-       dh_testroot -plibapt-pkg-dev
-       dh_clean -plibapt-pkg-dev -k
-       dh_installdirs -plibapt-pkg-dev usr/lib usr/include/apt-pkg
-       
-       ln -s libapt-pkg.so.${LIBAPT_MAJOR} debian/libapt-pkg-dev/usr/lib/libapt-pkg.so
-
-       cp build/include/apt-pkg/*.h debian/libapt-pkg-dev/usr/include/apt-pkg/
-
-       dh_installdocs -plibapt-pkg-dev
-       dh_installchangelogs -plibapt-pkg-dev
-       dh_strip -plibapt-pkg-dev
-       dh_compress -plibapt-pkg-dev
-       dh_fixperms -plibapt-pkg-dev
-       dh_installdeb -plibapt-pkg-dev
-       dh_shlibdeps -plibapt-pkg-dev
-       echo libapt-pkg:major=${LIBAPT_MAJOR} >> debian/libapt-pkg-dev.substvars
-       dh_gencontrol -plibapt-pkg-dev
-       dh_md5sums -plibapt-pkg-dev
-       dh_builddeb -plibapt-pkg-dev
-
-libapt-pkg-doc: build
-       dh_testdir -plibapt-pkg-doc
-       dh_testroot -plibapt-pkg-doc
-       dh_clean -plibapt-pkg-doc -k
-       dh_installdirs -plibapt-pkg-doc usr/doc/apt usr/doc/libapt-pkg-doc
-
-       cp -a build/docs/cache* build/docs/design* build/docs/dpkg-tech* \
-         build/docs/files* build/docs/method* debian/libapt-pkg-doc/usr/doc/apt/
-       cp -a debian/libapt-pkg-doc.dhelp debian/libapt-pkg-doc/usr/doc/libapt-pkg-doc/.dhelp
-
-       dh_installdocs -plibapt-pkg-doc
-       dh_installchangelogs -plibapt-pkg-doc
-       dh_strip -plibapt-pkg-doc
-       dh_compress -plibapt-pkg-doc
-       dh_fixperms -plibapt-pkg-doc
-       dh_installdeb -plibapt-pkg-doc
-       dh_shlibdeps -plibapt-pkg-doc
-       dh_gencontrol -plibapt-pkg-doc
-       dh_md5sums -plibapt-pkg-doc
-       dh_builddeb -plibapt-pkg-doc
-
-source diff:                                                                  
-       @echo >&2 'source and diff are obsolete - use dpkg-source -b'; false
-
-# Update from CVS
-l33ch: really-clean
-       cvs update
-       buildlib/mkChangeLog
-
-# Update from CVS and then configure for build
-super-l33ch: l33ch Makefile.in
+       dh_testdir -p$@
+       dh_testroot -p$@
+       dh_prep -p$@
+       dh_installdirs -p$@
+#
+# libapt-pkg-dev install
+#
+       dh_install -p$@ --sourcedir=$(BLD)
+       dh_installdocs -p$@
+       dh_installchangelogs -p$@
+       dh_strip -p$@
+       dh_compress -p$@
+       dh_fixperms -p$@
+       dh_installdeb -p$@
+       dh_gencontrol -p$@ -- -Vlibapt-pkg-name=$(LIBAPT_PKG) -Vlibapt-inst-name=$(LIBAPT_INST)
+       dh_md5sums -p$@
+       dh_builddeb -p$@
 
 
-configure:
-       make startup
+apt-utils_MANPAGES = apt-sortpkgs apt-ftparchive apt-extracttemplates
+apt-utils: build
+       dh_testdir -p$@
+       dh_testroot -p$@
+       dh_prep -p$@
+       dh_installdirs -p$@
+
+       cp $(addprefix $(BLD)/bin/apt-,$(APT_UTILS)) debian/$@/usr/bin/
+       cp $(BLD)/bin/apt-dump-solver debian/$@/usr/lib/apt/solvers/dump
+
+       dh_install -p$@ --sourcedir=$(BLD)
+       dh_link -p$@
+       dh_installdocs -p$@
+       dh_installexamples -p$@
+
+       # Install the man pages..
+       dh_installman -p$@ $(wildcard $(patsubst %,doc/%.[158],$(apt-utils_MANPAGES)) $(patsubst %,doc/*/%.*.[158],$(apt-utils_MANPAGES)))
 
 
-l33ch-stamp: super-l33ch
-       touch l33ch-stamp
+       dh_installchangelogs -p$@
+       dh_strip -p$@
+       dh_compress -p$@
+       dh_fixperms -p$@
+       dh_makeshlibs -p$@
+       dh_installdeb -p$@
+       dh_shlibdeps -p$@
+       dh_gencontrol -p$@
+       dh_md5sums -p$@
+       dh_builddeb -p$@
+
+$(LIBAPT_PKG): build
+       dh_testdir -p$@
+       dh_testroot -p$@
+       dh_prep -p$@
+       dh_installdirs -p$@
+
+       dh_install -p$@ --sourcedir=$(BLD)
+       dh_installdocs -p$@
+       dh_installchangelogs -p$@
+       dh_strip -p$@
+       dh_compress -p$@
+       dh_fixperms -p$@
+       dh_makeshlibs -p$@
+       dh_installdeb -p$@
+       dh_shlibdeps -p$@ 
+       dh_gencontrol -p$@
+       dh_md5sums -p$@
+       dh_builddeb -p$@
+
+$(LIBAPT_INST): build
+       dh_testdir -p$@
+       dh_testroot -p$@
+       dh_prep -p$@
+       dh_installdirs -p$@
+
+       dh_install -p$@ --sourcedir=$(BLD)
+       dh_installdocs -p$@
+       dh_installchangelogs -p$@
+       dh_strip -p$@
+       dh_compress -p$@
+       dh_fixperms -p$@
+       dh_makeshlibs -p$@
+       dh_installdeb -p$@
+       dh_shlibdeps -p$@ 
+       dh_gencontrol -p$@
+       dh_md5sums -p$@
+       dh_builddeb -p$@
+
+apt-transport-https: build libapt-pkg-dev
+       dh_testdir -p$@
+       dh_testroot -p$@
+       dh_prep -p$@
+       dh_installdirs -p$@
+
+       dh_install -p$@ --sourcedir=$(BLD)
+       dh_installdocs -p$@ debian/apt-transport-https.README
+       dh_installexamples -p$@
+
+       # Install the man pages..
+       dh_installman -p$@
+
+       dh_installchangelogs -p$@
+       dh_strip -p$@
+       dh_compress -p$@
+       dh_fixperms -p$@
+       dh_installdeb -p$@
+       dh_shlibdeps -p$@ 
+       dh_gencontrol -p$@
+       dh_md5sums -p$@
+       dh_builddeb -p$@
+
+configure:
+       $(MAKE) configure
 
 really-clean: clean
 
 really-clean: clean
-       -find -name Makefile.in -print0 | xargs -0r rm -f
+       -find . -name Makefile.in -print0 | xargs --null --no-run-if-empty -- rm -f
        find -name ChangeLog | xargs rm -f
        rm -f l33ch-stamp
 
        find -name ChangeLog | xargs rm -f
        rm -f l33ch-stamp