]> git.saurik.com Git - apt.git/blobdiff - debian/changelog
eliminate (hopefully all) segfaults in pkgcachegen.cc and mmap.cc
[apt.git] / debian / changelog
index f4aa1eebfbb60a454eceba83f48ae03a74cdc269..ea7e0469bdf514d16f24c1d1e05da992f729ce1a 100644 (file)
@@ -13,6 +13,7 @@ apt (0.7.22) UNRELEASED; urgency=low
     - fr.po
     - it.po. Closes: #531758
     - ca.po. Closes: #531921
+    - de.po. Closes: #536430
   * Added translations
     - ast.po (Asturian by Marcos Alvareez Costales).
       Closes: #529007, #529730, #535328
@@ -29,14 +30,22 @@ apt (0.7.22) UNRELEASED; urgency=low
   * add Debug::pkgProblemResolver::ShowScores and make the scores
     adjustable
   * do not write state file in simulate mode (closes: #433007)
-  * add hook for auto-install (closes: #470035)
-  * support IsAutoInstallOk in the resolver too
+  * add hook for MarkInstall and MarkDelete (closes: #470035)
   * fix typo in apt-pkg/acquire.cc which prevents Dl-Limit to work
     correctly when downloading from multiple sites (Closes: #534752)
+  * add the various foldmarkers in apt-pkg & cmdline (no code change)
+  * versions with a pin of -1 shouldn't be a candidate (Closes: #355237)
+  * prefer mmap as memory allocator in MMap instead of a static char
+    array which can (at least in theory) grow dynamic
+  * eliminate (hopefully all) segfaults in pkgcachegen.cc and mmap.cc
+    which can arise if cache doesn't fit into the mmap (Closes: #535218)
+  * display warnings instead of errors if the parts dirs doesn't exist
 
   [ Michael Vogt ]
-  * honor the dpkg hold state in AutoInstOk (closes: #64141)
-  
+  * honor the dpkg hold state in new Marker hooks (closes: #64141)
+  * debian/apt.cron.daily:
+    - if the timestamp is too far in the future, delete it
+
   [ Julian Andres Klode ]
   * apt-pkg/contrib/configuration.cc: Fix a small memory leak in
     ReadConfigFile.