]> git.saurik.com Git - apt.git/blobdiff - debian/rules
[ Nicolas François ]
[apt.git] / debian / rules
index 333d4ad5b802fe935a26e768d2c3b36ccaf7592f..d19531dfcf41e774e8e66628e11f512af333deda 100755 (executable)
@@ -38,7 +38,7 @@ build:
 
 PKG=apt
 DEB_BUILD_PROG:=debuild --preserve-envvar PATH --preserve-envvar CCACHE_DIR -us -uc $(DEB_BUILD_PROG_OPTS)
-APT_DEBVER=$(shell dpkg-parsechangelog |sed -n -e '/^Version:/s/^Version: //p')
+APT_DEBVER=$(shell dpkg-parsechangelog |sed -n -e '/^Version:/s/^Version: //p' | sed -e 's/\+.*$$//')
 APT_CONFVER=$(shell sed -n -e 's/^AC_DEFINE_UNQUOTED(VERSION,"\(.*\)")/\1/p' configure.in)
 APT_CVSTAG=$(shell echo "$(APT_DEBVER)" | sed -e 's/^/v/' -e 's/\./_/g')
 
@@ -125,8 +125,8 @@ build/build-doc-stamp: build/configure-stamp
 clean:
        dh_testdir
 #      dh_testroot
-       -$(MAKE) clean
-       -$(MAKE) distclean
+       [ -f Makefile ] && $(MAKE) clean
+       [ -f Makefile ] && $(MAKE) distclean
 
        rm -rf build
 
@@ -185,8 +185,9 @@ apt-doc: build-doc
 
 # Build architecture-dependent files here.
 
-binary-arch: apt libapt-pkg-dev apt-utils 
-apt: build debian/shlibs.local
+binary-arch: apt libapt-pkg-dev apt-utils apt-transport-https
+apt_MANPAGES = apt-cache apt-cdrom apt-config apt-get apt-key apt-mark apt-secure apt apt.conf apt_preferences sources.list
+apt: build build-doc debian/shlibs.local
        dh_testdir -p$@
        dh_testroot -p$@
        dh_clean -p$@ -k
@@ -204,23 +205,29 @@ apt: build debian/shlibs.local
        find $(BLD)/bin/ -type l -name "libapt-pkg*.so.*" -exec cp -a "{}" debian/$@/usr/lib/ \;
 
        cp $(BLD)/bin/methods/* debian/$@/usr/lib/apt/methods/
+       # https has its own package
+       rm debian/$@/usr/lib/apt/methods/https
 
        cp $(BLD)/scripts/dselect/* debian/$@/usr/lib/dpkg/methods/apt/
        cp -r $(BLD)/locale debian/$@/usr/share/
 
        cp debian/bugscript debian/$@/usr/share/bug/apt/script
+       cp debian/apt.logrotate debian/$@/etc/logrotate.d/apt
 
-       cp share/ubuntu-archive.gpg debian/$@/usr/share/$@
-
+       cp share/debian-archive.gpg debian/$@/usr/share/$@
+       cp debian/apt.conf.autoremove debian/$@/etc/apt/apt.conf.d/01autoremove
 #      head -n 500 ChangeLog > debian/ChangeLog
 
+       # copy lintian override
+       cp share/lintian-overrides debian/$@/usr/share/lintian/overrides/apt
+
        # make rosetta happy and remove pot files in po/ (but leave stuff
        # in po/domains/* untouched) and cp *.po into each domain dir
        rm -f build/po/*.pot
        rm -f po/*.pot
 
        dh_installexamples -p$@ $(BLD)/docs/examples/*
-       dh_installman -p$@ 
+       dh_installman -p$@ $(wildcard $(patsubst %,doc/%.[158],$(apt_MANPAGES)) $(patsubst %,doc/*/%.*.[158],$(apt_MANPAGES)))
        dh_installcron -p$@
        dh_installdocs -p$@
        dh_installchangelogs -p$@
@@ -263,6 +270,7 @@ libapt-pkg-dev: build debian/shlibs.local
        dh_md5sums -p$@
        dh_builddeb -p$@
 
+apt-utils_MANPAGES = apt-sortpkgs apt-ftparchive apt-extracttemplates
 apt-utils: build debian/shlibs.local
        dh_testdir -p$@
        dh_testroot -p$@
@@ -278,7 +286,7 @@ apt-utils: build debian/shlibs.local
        dh_installexamples -p$@
 
        # Install the man pages..
-       dh_installman -p$@
+       dh_installman -p$@ $(wildcard $(patsubst %,doc/%.[158],$(apt-utils_MANPAGES)) $(patsubst %,doc/*/%.*.[158],$(apt-utils_MANPAGES)))
 
        dh_installchangelogs -p$@
        dh_strip -p$@
@@ -291,6 +299,32 @@ apt-utils: build debian/shlibs.local
        dh_md5sums -p$@
        dh_builddeb -p$@
 
+apt-transport-https: build debian/shlibs.local libapt-pkg-dev
+       dh_testdir -p$@
+       dh_testroot -p$@
+       dh_clean -p$@ -k
+       dh_installdirs -p$@
+
+       # install the method
+       mkdir -p debian/$@/usr/lib/apt/methods
+       cp $(BLD)/bin/methods/https debian/$@/usr/lib/apt/methods
+
+       dh_installdocs -p$@ debian/apt-transport-https.README
+       dh_installexamples -p$@
+
+       # Install the man pages..
+       dh_installman -p$@
+
+       dh_installchangelogs -p$@
+       dh_strip -p$@
+       dh_compress -p$@
+       dh_fixperms -p$@
+       dh_installdeb -p$@
+       dh_shlibdeps -p$@ -l`pwd`/debian/apt/usr/lib:`pwd`/debian/$@/usr/lib 
+       dh_gencontrol -p$@
+       dh_md5sums -p$@
+       dh_builddeb -p$@
+
 source diff:
        @echo >&2 'source and diff are obsolete - use dpkg-source -b'; false