+apt (0.8.1) UNRELEASED; urgency=low
+
+ [ Programs translations ]
+ * Thai (Theppitak Karoonboonyanan). Closes: #592695
+ * Russian (Yuri Kozlov). Closes: #594232
+ * Slovak (Ivan Masár). Closes: #594255
+ * Swedish (Daniel Nylander). Closes: #594241
+ * Japanese (Kenshi Muto, Osamu Aoki). Closes: #594265
+ * Italian (Milo Casagrande). Closes: #594238
+ * Asturian (maacub). Closes: #594303
+
+ [ Christian Perrier ]
+ * Fix spelling error in cmdline/apt-get.cc. Thanks to Osamu Aoki
+ Closes: #594211
+
+ [ David Kalnischkies ]
+ * show in madison command again also source packages (LP: #614589)
+
+ -- David Kalnischkies <kalnischkies@gmail.com> Wed, 25 Aug 2010 17:46:48 +0200
+
+apt (0.8.0) unstable; urgency=low
+
+ [ Michael Vogt ]
+ * merge of the debian-expermental-ma branch
+ * refresh po/pot files in doc/ and po/
+
+ [ Programs translations ]
+ * Swedish (Daniel Nylander). Closes: #592366
+ * French (Christian Perrier)
+
+ [ Manpages translations ]
+ * French (Christian Perrier)
+
+ -- Michael Vogt <mvo@debian.org> Tue, 24 Aug 2010 16:32:19 +0200
+
+apt (0.8.0~pre2) experimental; urgency=low
+
+ [ David Kalnischkies ]
+ * apt-pkg/contrib/strutl.cc:
+ - fix error checking for vsnprintf in its safe variant
+ * methods/bzip2.cc:
+ - fix error checking for read in case of failing bzip2/lzma/whatever
+ * debian/apt.cron.daily:
+ - create backups for our extended_states file (Closes: #593430)
+ * apt-pkg/init.cc:
+ - set the default values for dir::etc::trusted options correctly
+ * ftparchive/writer.cc:
+ - init valid-until correctly to prevent garbage entering Release file
+ * apt-pkg/deb/debsystem.cc:
+ - set dir::state::status based at least on dir
+ * apt-pkg/deb/dpkgpm.cc:
+ - use the InstVer instead of the CurrentVer for the autobit transfer
+ * methods/http.cc:
+ - some http servers violate HTTP1.1 by not issuing a Reason-Phrase
+ (or at least a space after the code) especially for 200, but lets
+ be nice and ignore it as we don't need the reason in general
+ * apt-pkg/acquire-item.cc:
+ - don't use ReadOnlyGzip mode for PDiffs as this mode doesn't work
+ in combination with the AddFd methods of our hashclasses
+
+ -- Michael Vogt <mvo@debian.org> Mon, 23 Aug 2010 19:09:08 +0200
+
+apt (0.8.0~pre1) experimental; urgency=low
+
+ [ Programs translations ]
+ * Swedish translation update. Closes: #592366
+
+ [ Michael Vogt ]
+ * merge of the debian-expermental-ma branch
+ * refresh po/pot files in doc/ and po/
+ * apt-pkg/pkgcache.cc:
+ - re-evaluate the architectures cache when the cache is (re)opened
+
+ [ Colin Watson ]
+ * apt-pkg/cdrom.cc:
+ - fix off-by-one error in DropBinaryArch
+
+ [ Julian Andres Klode ]
+ * apt-pkg/contrib/fileutl.cc:
+ - Add WriteAtomic mode.
+ - Revert WriteEmpty to old behavior (LP: #613211)
+ * apt-pkg, methods:
+ - Convert users of WriteEmpty to WriteAtomic.
+ * apt-pkg/depcache.cc:
+ - Only try upgrade for Breaks if there is a newer version, otherwise
+ handle it as Conflicts (by removing it) (helps for #591882).
+ * debian/control:
+ - Add dependency on gnupg to apt, apt-key uses it.
+
+ [ David Kalnischkies ]
+ * apt-pkg/algorithms.cc:
+ - let the problem resolver install packages to fix or-groups
+ as a needed remove nuked another or-member (helps for #591882)
+ - change the debug outputs to display also arch of the
+ package and version dependencies information
+ * cmdline/apt-get.cc:
+ - let APT::Get::Arch-Only in build-dep default to false again
+ (Closes: #592628) Thanks Mohamed Amine IL Idrissi for report!
+ - purge packages in 'rc' state, thanks Rogier! (Closes: #150831)
+ * apt-pkg/pkgcache.cc:
+ - fix LongDesc handling in LANG=C environment
+
+ -- Michael Vogt <mvo@debian.org> Fri, 13 Aug 2010 17:00:49 +0200
+
+apt (0.7.26~exp12) experimental; urgency=low
+
+ [ Michael Vogt ]
+ * debian/control:
+ - add dependency on zlib-dev for libapt-pkg-dev
+
+ [ David Kalnischkies ]
+ * apt-pkg/cacheset.cc:
+ - [ABI BREAK] add an ErrorType option to CacheSetHelper
+ * cmdline/apt-cache.cc:
+ - use Notice instead of Error in the CacheSetHelper messages
+ for compat reasons. Otherwise tools like sbuild blow up
+ - return success in show if a virtual package was given
+ * debian/control:
+ - remove libcurl3-gnutls-dev alternative as the package is gone
+ - increase needed version of libcurl4-gnutls-dev to >= 7.19.0
+ as we use CURLOPT_{ISSUERCERT,CRLFILE} (Closes: #589642)
+
+ -- Michael Vogt <mvo@debian.org> Fri, 30 Jul 2010 11:55:48 +0200
+
+apt (0.7.26~exp11) experimental; urgency=low
+
+ [ Julian Andres Klode ]
+ * apt-pkg/deb/dpkgpm.cc:
+ - Write architecture information to history file.
+ - Add to history whether a change was automatic or not.
+ * apt-pkg/contrib/fileutl.cc:
+ - Add FileFd::OpenDescriptor() (needed for python-apt's #383617).
+ * cmdline/apt-get.cc:
+ - Support large filesystems by using statvfs64() instead of statvfs()
+ and statfs64() instead of statfs() (Closes: #590513).
+ * apt-pkg/cdrom.cc:
+ - Use link() instead of rename() for creating the CD database backup;
+ otherwise there would be a short time without any database.
+
+ [ David Kalnischkies ]
+ * apt-pkg/depcache.cc:
+ - handle "circular" conflicts for "all" packages correctly
+ * cmdline/apt-cache.cc:
+ - be able to omit dependency types in (r)depends (Closes: #319006)
+ - show in (r)depends the canidate per default instead of newest
+ - share the (r)depends code instead of codecopy
+ * apt-pkg/cacheset.cc:
+ - move them back to the library as they look stable now
+ - add a 'newest' pseudo target release as in pkg/newest
+ * apt-pkg/pkgcache.cc:
+ - prefer non-virtual packages in FindPreferredPkg (Closes: #590041)
+ * test/integration/*:
+ - add with bug#590041 testcase a small test "framework"
+ * apt-pkg/orderlist.cc:
+ - try to install another or-group member in DepRemove before
+ breaking the or group (Closes: #590438)
+ - configure also the replacement before remove by adding Immediate flag
+
+ [ Michael Vogt ]
+ * apt-pkg/contrib/error.{cc,h}
+ - docstring cleanup
+ - add inline DumpError() to avoid subtle API break
+
+ -- Michael Vogt <mvo@debian.org> Thu, 29 Jul 2010 16:40:58 +0200
+
apt (0.7.26~exp10) experimental; urgency=low
[ David Kalnischkies ]
[ Christian Perrier ]
* Slovak translation update. Closes: #581159
* Italian translation update. Closes: #581742
+ * Swedish translation update. Closes: #592366
-- Michael Vogt <mvo@debian.org> Tue, 25 May 2010 16:01:42 +0200