-apt (0.7.22.3) unstable; urgency=low
+apt (0.7.25) UNRELEASED; urgency=low
+ [ Christian Perrier ]
+ * Fix apt-ftparchive(1) wrt description of the "-o" option.
+ Thanks to Dann Frazier for the patch. Closes: #273100
+ * po/LINGUAS. Re-disable Hebrew. Closes: #534992
+ * po/LINGUAS. Enable Asturian and Lithuanian
+ * Fix typo in apt-cache.8.xml: nessasarily
+ * Fix "with with" in apt-get.8.xml
+ * Fix some of the typos mentioned by the german team
+ Closes: #479997
+ * Polish translation update by Wiktor Wandachowicz
+ Closes: #548571
+
+ [ David Kalnischkies ]
+ * apt-pkg/packagemanager.cc:
+ - better debug output for ImmediateAdd with depth and why
+ - improve the message shown for failing immediate configuration
+ * doc/guide.it.sgml: moved to doc/it/guide.it.sgml
+ * doc/po4a.conf: activate translation of guide.sgml and offline.sgml
+ * doc/apt.conf.5.xml:
+ - provide a few more details about APT::Immediate-Configure
+ * doc/sources.list.5.xml:
+ - add note about additional apt-transport-methods
+
+ [ Julian Andres Klode ]
+ * doc/apt.conf.5.xml:
+ - Deprecate unquoted values, string concatenation and explain what should
+ not be written inside a value (quotes,backslash).
+ - Restrict option names to alphanumerical characters and "/-:._+".
+ - Deprecate #include, we have apt.conf.d nowadays which should be
+ sufficient.
+ * methods/https.cc:
+ - Add support for authentication using netrc (Closes: #518473), patch
+ by Jussi Hakala <jussi.hakala@hut.fi>.
+
+ -- Michael Vogt <michael.vogt@ubuntu.com> Tue, 29 Sep 2009 15:51:34 +0200
+
+apt (0.7.24) unstable; urgency=low
+
+ [ Nicolas François ]
+ * Cleaned up the first patch draft from KURASAWA Nozomu to finally
+ get po4a support for translating the man pages.
+ Many thanks to both for this excellent work! (Closes: #441608)
+ * doc/ja/*, doc/po/ja.po:
+ - remove the old ja man page translation and replace it with
+ the new po4a-powered translation by KURASAWA Nozomu.
+ * doc/*.?.xml (manpages):
+ - add contrib to author tags and also add refmiscinfo to fix warnings
+ * doc/style.txt, buildlib/defaults.mak, buildlib/manpage.mak:
+ - fix a few typos in the comments of this files
+
+ [ Michael Vogt ]
+ * apt-pkg/deb/dpkgpm.cc:
+ - when tcgetattr() returns non-zero skip all pty magic
+ (thanks to Simon Richter, closes: #509866)
+ * apt-inst/contrib/arfile.cc:
+ - show propper error message for Invalid archive members
+
+ [ David Kalnischkies ]
+ * doc/Doxyfile.in:
+ - update file with doxygen 1.6.1 (current unstable)
+ - activate DOT_MULTI_TARGETS, it is default on since doxygen 1.5.9
+ * buildlib/po4a_manpage.mak, doc/makefile, configure:
+ - simplify the makefiles needed for po4a manpages
+ * apt-pkg/contrib/configuration.cc:
+ - add a helper to easily get a vector of strings from the config
+ * apt-pkg/contrib/strutl.cc:
+ - replace unknown multibytes with ? in UTF8ToCharset (Closes: #545208)
+ * doc/apt-get.8.xml:
+ - fix two little typos in the --simulate description. (Closes: #545059)
+ * apt-pkg/aptconfiguration.cc, doc/apt.conf.5.xml:
+ - add an order subgroup to the compression types to simplify reordering
+ a bit and improve the documentation for this option group.
+ * doc/apt.conf.5.xml:
+ - document the Acquire::http::Dl-Limit option
+ - try to be crystal clear about the usage of :: and {} (Closes: #503481)
+ * doc/apt-cache.8.xml:
+ - clarify the note for the pkgnames command (Closes: #547599)
+ * doc/apt.ent, all man pages:
+ - move the description of files to globally usable entities
+ * doc/apt_preferences.5.xml:
+ - document the new preferences.d folder (Closes: #544017)
+ * methods/rred.cc:
+ - add at the top without failing (by Bernhard R. Link, Closes: #545694)
+ * buildlib/sizetable:
+ - add amd64 for cross building (by Mikhail Gusarov, Closes: #513058)
+ * debian/prerm:
+ - remove file as nobody will upgrade from 0.4.10 anymore
+ * debian/control:
+ - remove gnome-apt suggestion as it was removed from debian
+ * apt-pkg/deb/dpkgpm.cc, apt-pkg/packagemanager.cc, apt-pkg/orderlist.cc:
+ - add and document _experimental_ options to make (aggressive)
+ use of dpkg's trigger and configuration handling (Closes: #473461)
+ * cmdline/apt-get.cc:
+ - ignore versions that are not candidates when selecting a package
+ instead of a virtual one (by Marius Vollmer, Closes: #547788)
+
+ [ Christian Perrier ]
+ * doc/fr/*, doc/po/fr.po:
+ - remove the old fr man page translation and replace it with
+ the new po4a-powered translation
+ * doc/de: dropped (translation is too incomplete to be useful in
+ the transition to the po4a-powered translations)
+
+ -- Michael Vogt <mvo@debian.org> Fri, 25 Sep 2009 19:57:25 +0200
+
+apt (0.7.23.1) unstable; urgency=low
+
+ [ Michael Vogt ]
+ * apt-pkg/pkgcache.cc:
+ - do not set internel "needs-configure" state for packages in
+ triggers-pending state. dpkg will deal with the trigger and
+ it if does it before we trigger it, dpkg will error out
+ (LP: #414631)
+ * apt-pkg/acquire-item.cc:
+ - do not segfault on invalid items (closes: #544080)
+
+ -- Michael Vogt <mvo@debian.org> Fri, 28 Aug 2009 21:53:20 +0200
+
+apt (0.7.23) unstable; urgency=low
+
+ [ Eugene V. Lyubimkin ]
+ * methods/{http,https,ftp}, doc/apt.conf.5.xml:
+ - Changed and unified the code that determines which proxy to use. Now
+ 'Acquire::{http,ftp}::Proxy[::<host>]' options have the highest priority,
+ and '{http,ftp}_proxy' environment variables are used only if options
+ mentioned above are not specified.
+ (Closes: #445985, #157759, #320184, #365880, #479617)
+
[ David Kalnischkies ]
* cmdline/apt-get.cc:
- add APT::Get::HideAutoRemove=small to display only a short line
* apt-pkg/acquire-item.cc:
- use configsettings for dynamic compression type use and order.
Based on a patch by Jyrki Muukkonen, thanks! (LP: #71746)
- * apt-pkg/init.cc:
+ * apt-pkg/aptconfiguration.cc:
- add default configuration for compression types and add lzma
support. Order is now bzip2, lzma, gzip, none (Closes: #510526)
* ftparchive/writer.cc:
* methods/http.cc:
- allow empty Reason-Phase in Status-Line to please squid,
thanks Modestas Vainius for noticing! (Closes: #531157, LP: #411435)
- * doc/Doxyfile.in:
- - update file with doxygen 1.6.1 (current unstable)
- - activate DOT_MULTI_TARGETS, it is default on since doxygen 1.5.9
[ George Danchev ]
* cmdline/apt-cache.cc:
* apt-pkg/indexcopy.cc:
- fix a memory leak then the Release file not exists (Closes: #511556)
- [ Nicolas François ]
- * Cleaned up the first patch draft from KURASAWA Nozomu to finally
- get po4a support for translating the man pages.
- Many thanks to both for this excellent work! (Closes: #441608)
- * doc/*.?.xml (manpages):
- - add contrib to author tags and also add refmiscinfo to fix warnings
- * doc/style.txt, buildlib/defaults.mak, buildlib/manpage.mak:
- - fix a few typos in the comments of this files
-
- -- David Kalnischkies <david@kalnischkies.com> Sat, 08 Aug 2009 09:40:08 +0200
+ -- Michael Vogt <mvo@debian.org> Thu, 27 Aug 2009 14:44:39 +0200
apt (0.7.22.2) unstable; urgency=low
* buildlib/config.{sub,guess}:
- Renewed. This fixes lintian errors.
* doc/apt.conf.5.xml, debian/apt-transport-https:
- - Documented briefly 'APT::https' group of options. (Closes: #507398)
+ - Documented briefly 'Acquire::https' group of options. (Closes: #507398)
- Applied patch from Daniel Burrows to document 'Debug' group of options.
(Closes: #457265)
- Mentioned 'APT::Periodic' and 'APT::Archives' groups of options.