]> git.saurik.com Git - apt.git/blobdiff - debian/rules
* Fix building to properly support binNMUs. Thanks to Daniel Schepler
[apt.git] / debian / rules
index bd9073ad28e6e3e3db56b2eda355ec88996037d4..473821f16c2c731c7c48fd68de97f19373428b6e 100755 (executable)
@@ -38,7 +38,7 @@ build:
 
 PKG=apt
 DEB_BUILD_PROG:=debuild --preserve-envvar PATH --preserve-envvar CCACHE_DIR -us -uc $(DEB_BUILD_PROG_OPTS)
-APT_DEBVER=$(shell dpkg-parsechangelog |sed -n -e '/^Version:/s/^Version: //p')
+APT_DEBVER=$(shell dpkg-parsechangelog |sed -n -e '/^Version:/s/^Version: //p' | sed -e 's/\+.*$$//')
 APT_CONFVER=$(shell sed -n -e 's/^AC_DEFINE_UNQUOTED(VERSION,"\(.*\)")/\1/p' configure.in)
 APT_CVSTAG=$(shell echo "$(APT_DEBVER)" | sed -e 's/^/v/' -e 's/\./_/g')
 
@@ -185,7 +185,7 @@ apt-doc: build-doc
 
 # Build architecture-dependent files here.
 
-binary-arch: apt libapt-pkg-dev apt-utils 
+binary-arch: apt-transport-https apt libapt-pkg-dev apt-utils
 apt: build debian/shlibs.local
        dh_testdir -p$@
        dh_testroot -p$@
@@ -211,7 +211,7 @@ apt: build debian/shlibs.local
        cp debian/bugscript debian/$@/usr/share/bug/apt/script
 
        cp share/debian-archive.gpg debian/$@/usr/share/$@
-
+       cp debian/apt.conf.autoremove debian/$@/etc/apt/apt.conf.d/01autoremove
 #      head -n 500 ChangeLog > debian/ChangeLog
 
        # make rosetta happy and remove pot files in po/ (but leave stuff
@@ -291,6 +291,32 @@ apt-utils: build debian/shlibs.local
        dh_md5sums -p$@
        dh_builddeb -p$@
 
+apt-transport-https: build debian/shlibs.local
+       dh_testdir -p$@
+       dh_testroot -p$@
+       dh_clean -p$@ -k
+       dh_installdirs -p$@
+
+       # install the method
+       mkdir -p debian/$@/usr/lib/apt/methods
+       mv $(BLD)/bin/methods/https debian/$@/usr/lib/apt/methods
+
+       dh_installdocs -p$@
+       dh_installexamples -p$@
+
+       # Install the man pages..
+       dh_installman -p$@
+
+       dh_installchangelogs -p$@
+       dh_strip -p$@
+       dh_compress -p$@
+       dh_fixperms -p$@
+       dh_installdeb -p$@
+       dh_shlibdeps -p$@ -l`pwd`/debian/apt/usr/lib:`pwd`/debian/$@/usr/lib 
+       dh_gencontrol -p$@
+       dh_md5sums -p$@
+       dh_builddeb -p$@
+
 source diff:
        @echo >&2 'source and diff are obsolete - use dpkg-source -b'; false
 
@@ -341,6 +367,6 @@ cvs-mkul:
 arch-build:
        rm -rf debian/arch-build
        mkdir -p debian/arch-build/apt-$(APT_DEBVER)
-       tar -c --exclude=arch-build -f - `bzr inventory` | (cd debian/arch-build/$(PKG)-$(APT_DEBVER);tar xf -)
+       tar -c --exclude=arch-build --no-recursion -f - `bzr inventory` | (cd debian/arch-build/$(PKG)-$(APT_DEBVER);tar xf -)
        $(MAKE) -C debian/arch-build/apt-$(APT_DEBVER) startup doc
        (cd debian/arch-build/apt-$(APT_DEBVER); $(DEB_BUILD_PROG); dpkg-genchanges -S > ../apt_$(APT_DEBVER)_source.changes)