-apt (0.8.15.3) UNRELEASED; urgency=low
+apt (0.8.15.4) unstable; urgency=low
+
+ [ David Miller ]
+ * apt-pkg/contrib/sha1.cc:
+ - fix illegally casts of on-stack buffer to a type requiring more
+ alignment than it has resulting in segfaults on sparc (Closes: #634696)
+
+ -- David Kalnischkies <kalnischkies@gmail.com> Tue, 26 Jul 2011 08:26:53 +0200
+
+apt (0.8.15.3) unstable; urgency=low
[ Michael Vogt ]
* apt-pkg/acquire-item.cc:
* apt-pkg/algorithms.cc:
- Hold back packages that would enter "policy-broken" state on upgrade
when doing a "apt-get upgrade"
+ * cmdline/apt-get.cc:
+ - fix missing download progress in apt-get download
[ David Kalnischkies ]
* apt-pkg/pkgcachegen.cc:
- document APT::Architectures list (Closes: #612102)
* cmdline/apt-get.cc:
- restore all important dependencies for garbage packages (LP: #806274)
+ - do not require unused partial dirs in 'source' (Closes: #633510)
+ - buildconflicts effect all architectures
+ - implement MultiarchCross for build-dep and source (Closes: #632221)
* apt-pkg/init.cc:
- use CndSet in pkgInitConfig (Closes: #629617)
* apt-pkg/depcache.cc:
- use a tmpfile instead of /etc/apt/secring.gpg (Closes: #632596)
* debian/apt.postinst:
- remove /etc/apt/secring.gpg if it is an empty file
+ * doc/apt-cache.8.xml:
+ - apply madison typofix from John Feuerstein, thanks! (Closes: #633455)
+ * apt-pkg/policy.cc:
+ - emit an error on unknown APT::Default-Release value (Closes: #407511)
+ * apt-pkg/aptconfiguration.cc:
+ - ensure that native architecture is if not specified otherwise the
+ first architecture in the Architectures vector
+ * apt-pkg/deb/deblistparser.cc:
+ - Strip only :any and :native if MultiArch should be stripped as it is
+ save to ignore them in non-MultiArch contexts but if the dependency
+ is a specific architecture (and not the native) do not strip
- -- David Kalnischkies <kalnischkies@gmail.com> Sat, 16 Jul 2011 14:19:51 +0200
+ -- Michael Vogt <mvo@debian.org> Mon, 25 Jul 2011 15:04:43 +0200
apt (0.8.15.2) unstable; urgency=high