]> git.saurik.com Git - apt.git/blobdiff - debian/rules
* apt-pkg/depcache.cc:
[apt.git] / debian / rules
index dd2c993ca4c47c680d08e32b566a0801459eef9c..2007370c45fb01526ea709c9f8f98beca00d49f7 100755 (executable)
@@ -2,7 +2,7 @@
 # Made with the aid of dh_make, by Craig Small
 # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
 # Some lines taken from debmake, by Christoph Lameter.
-# $Id: rules,v 1.61 2003/12/21 00:37:58 mdz Exp $
+# $Id: rules,v 1.68 2004/05/30 18:21:43 mdz Exp $
 
 # LD_LIBRARY_PATH=pwd/debian/apt/usr/lib dh_shlibdeps -papt
 # dpkg: /home/jgg/work/apt2/debian/apt/usr/lib/libapt-pkg.so.2.9 not found.
@@ -27,12 +27,20 @@ endif
 # See below
 -include build/environment.mak
 
+ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+  export CXXFLAGS = -O0 -g -Wall
+else
+  export CXXFLAGS = -O2 -g -Wall
+endif
+
 # Default rule
 build:
 
-DEB_BUILD_PROG:=debuild --preserve-envvar PATH --preserve-envvar CCACHE_DIR -us -uc
+PKG=apt
+DEB_BUILD_PROG:=debuild --preserve-envvar PATH --preserve-envvar CCACHE_DIR -us -uc $(DEB_BUILD_PROG_OPTS)
 APT_DEBVER=$(shell dpkg-parsechangelog |sed -n -e '/^Version:/s/^Version: //p')
 APT_CONFVER=$(shell sed -n -e 's/^AC_DEFINE_UNQUOTED(VERSION,"\(.*\)")/\1/p' configure.in)
+APT_CVSTAG=$(shell echo "$(APT_DEBVER)" | sed -e 's/^/v/' -e 's/\./_/g')
 
 # Determine the build directory to use
 BASE=.
@@ -51,9 +59,11 @@ endif
 
 # Rebuild configure.in to have the correct version from the change log
 ifneq ($(APT_DEBVER),$(APT_CONFVER))
+ifneq ($(APT_DEBVER),)
 .PHONY: configure.in
 configure.in:
-       sed -e 's/$(APT_CONFVER)/$(APT_DEBVER)/' $@ > $@.$$$$;mv $@.$$$$ $@
+       sed -e 's/$(APT_CONFVER)/$(APT_DEBVER)/' $@ > $@.$$$$ && mv $@.$$$$ $@
+endif
 else
 configure.in:
 endif
@@ -99,7 +109,7 @@ build/configure-stamp: configure
        dh_testdir
        -mkdir build
        cp COPYING debian/copyright
-       cd build && ../configure $(confflags)
+       cd build && CXXFLAGS="$(confcxxflags)" ../configure $(confflags)
        touch $@
 
 build/build-stamp: build/configure-stamp
@@ -162,7 +172,7 @@ apt-doc: build-doc
 #
        # Copy the guides
        dh_installdocs -p$@ $(BLD)/docs/guide*.text $(BLD)/docs/guide*.html \
-                      $(BLD)/docs/offline.text $(BLD)/docs/offline.html
+                      $(BLD)/docs/offline*.text $(BLD)/docs/offline*.html
        dh_installchangelogs -p$@
        dh_compress -p$@
        dh_fixperms -p$@
@@ -180,39 +190,46 @@ apt: build debian/shlibs.local
        dh_testdir -p$@
        dh_testroot -p$@
        dh_clean -p$@ -k
-       dh_installdirs -p$@ /usr/share/bug/$@
+       dh_installdirs -p$@ /usr/share/bug/$@ /usr/share/$@
 #
 # apt install
 #
-       cp $(BLD)/bin/apt-* debian/apt/usr/bin/
+       cp $(BLD)/bin/apt-* debian/$@/usr/bin/
 
        # Remove the bits that are in apt-utils
-       rm $(addprefix debian/apt/usr/bin/apt-,$(APT_UTILS))
+       rm $(addprefix debian/$@/usr/bin/apt-,$(APT_UTILS))
 
        # install the shared libs
-       find $(BLD)/bin/ -type f -name "libapt-pkg*.so.*" -exec cp -a "{}" debian/apt/usr/lib/ \;
-       find $(BLD)/bin/ -type l -name "libapt-pkg*.so.*" -exec cp -a "{}" debian/apt/usr/lib/ \;
+       find $(BLD)/bin/ -type f -name "libapt-pkg*.so.*" -exec cp -a "{}" debian/$@/usr/lib/ \;
+       find $(BLD)/bin/ -type l -name "libapt-pkg*.so.*" -exec cp -a "{}" debian/$@/usr/lib/ \;
 
-       cp $(BLD)/bin/methods/* debian/apt/usr/lib/apt/methods/
+       cp $(BLD)/bin/methods/* debian/$@/usr/lib/apt/methods/
 
-       cp $(BLD)/scripts/dselect/* debian/apt/usr/lib/dpkg/methods/apt/
-       cp -r $(BLD)/locale debian/apt/usr/share/
+       cp $(BLD)/scripts/dselect/* debian/$@/usr/lib/dpkg/methods/apt/
+       cp -r $(BLD)/locale debian/$@/usr/share/
 
-       cp debian/bugscript debian/apt/usr/share/bug/apt/script
+       cp debian/bugscript debian/$@/usr/share/bug/apt/script
 
+       cp share/ubuntu-archive.gpg debian/$@/usr/share/$@
+       cp debian/apt.conf.ubuntu debian/$@/etc/apt/apt.conf.d/01ubuntu
 #      head -n 500 ChangeLog > debian/ChangeLog
 
+       # make rosetta happy and remove pot files in po/ (but leave stuff
+       # in po/domains/* untouched) and cp *.po into each domain dir
+       rm -f build/po/*.pot
+       rm -f po/*.pot
+
        dh_installexamples -p$@ $(BLD)/docs/examples/*
        dh_installman -p$@ 
-
+       dh_installcron -p$@
        dh_installdocs -p$@
        dh_installchangelogs -p$@
        dh_strip -p$@
        dh_compress -p$@
        dh_fixperms -p$@
-       dh_makeshlibs -m$(LIBAPTPKG_MAJOR) -V '$(LIBAPTPKG_PROVIDE)' -papt
+       dh_makeshlibs -p$@ -m$(LIBAPTPKG_MAJOR) -V '$(LIBAPTPKG_PROVIDE)'
        dh_installdeb -p$@
-       dh_shlibdeps -papt -l`pwd`/debian/apt/usr/lib -- -Ldebian/shlibs.local.apt
+       dh_shlibdeps -p$@ -l`pwd`/debian/apt/usr/lib:`pwd`/debian/$@/usr/lib -- -Ldebian/shlibs.local.apt
        dh_gencontrol -p$@ -u -Vlibapt-pkg:provides=$(LIBAPTPKG_PROVIDE)
        dh_md5sums -p$@
        dh_builddeb -p$@
@@ -258,6 +275,7 @@ apt-utils: build debian/shlibs.local
 
        cp $(addprefix $(BLD)/bin/apt-,$(APT_UTILS)) debian/$@/usr/bin/
        dh_installdocs -p$@
+       dh_installexamples -p$@
 
        # Install the man pages..
        dh_installman -p$@
@@ -268,7 +286,7 @@ apt-utils: build debian/shlibs.local
        dh_fixperms -p$@
        dh_makeshlibs -m$(LIBAPTINST_MAJOR) -V '$(LIBAPTINST_PROVIDE)' -p$@
        dh_installdeb -p$@
-       LD_LIBRARY_PATH=$$LD_LIBRARY_PATH:`pwd`/debian/apt/usr/lib:`pwd`/debian/$@/usr/lib dh_shlibdeps -p$@ -- -Ldebian/shlibs.local.apt-utils
+       dh_shlibdeps -p$@ -l`pwd`/debian/apt/usr/lib:`pwd`/debian/$@/usr/lib -- -Ldebian/shlibs.local.apt-utils
        dh_gencontrol -p$@ -u -Vlibapt-inst:provides=$(LIBAPTINST_PROVIDE)
        dh_md5sums -p$@
        dh_builddeb -p$@
@@ -306,15 +324,23 @@ binary: binary-indep binary-arch
 # edit configure.in
 # debian/rules cvs-build
 
+CVS_BUILDDIR=apt-$(APT_DEBVER)
+CVS_ROOT=$(shell cat CVS/Root)
+CVS_MODULE=$(shell cat CVS/Repository)
 cvs-build:
        rm -rf debian/cvs-build
-       cvs update -d
-       $(MAKE) startup
-       $(MAKE) doc
-       tar c --exclude CVS --exclude cvs-build --exclude '.#*' . |\
-               (mkdir -p debian/cvs-build/apt-$(APT_DEBVER);cd debian/cvs-build/apt-$(APT_DEBVER);tar x)
-       (cd debian/cvs-build/apt-$(APT_DEBVER);$(DEB_BUILD_PROG))
+       mkdir -p debian/cvs-build
+       (cd debian/cvs-build;cvs -d $(CVS_ROOT) export -r$(APT_CVSTAG) -d apt-$(APT_DEBVER) $(CVS_MODULE))
+       $(MAKE) -C debian/cvs-build/$(CVS_BUILDDIR) startup doc
+       (cd debian/cvs-build/$(CVS_BUILDDIR);$(DEB_BUILD_PROG))
 
 cvs-mkul:
        -mkdir -p ../upload-$(APT_DEBVER)
        cp `find debian/cvs-build -maxdepth 1 -type f` ../upload-$(APT_DEBVER)
+
+arch-build:
+       rm -rf debian/arch-build
+       mkdir -p debian/arch-build/apt-$(APT_DEBVER)
+       tar -c --exclude=arch-build --no-recursion -f - `bzr inventory` | (cd debian/arch-build/$(PKG)-$(APT_DEBVER);tar xf -)
+       $(MAKE) -C debian/arch-build/apt-$(APT_DEBVER) startup doc
+       (cd debian/arch-build/apt-$(APT_DEBVER); $(DEB_BUILD_PROG); dpkg-genchanges -S > ../apt_$(APT_DEBVER)_source.changes)