]> git.saurik.com Git - apt.git/blobdiff - debian/rules
Offline users guide
[apt.git] / debian / rules
index 517addf3670927f4b78ca6f94cec852ed656c135..31f2089fb57832a9be2526e013d5aec2cf33c496 100755 (executable)
@@ -2,7 +2,7 @@
 # Made with the aid of dh_make, by Craig Small
 # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
 # Some lines taken from debmake, by Christoph Lameter.
-# $Id: rules,v 1.2 1999/01/27 05:30:16 jgg Exp $
+# $Id: rules,v 1.6 1999/02/15 08:23:10 jgg Exp $
 
 
 # Uncomment this to turn on verbose mode.
@@ -58,10 +58,18 @@ apt: build
        cp build/scripts/dselect/* debian/tmp/usr/lib/dpkg/methods/apt/
 #      cp debian/sources.list debian/tmp/etc/apt/
 
+       # Copy the users guide  
        cp build/docs/guide.text debian/tmp/usr/doc/apt/users-guide.txt
        mkdir debian/tmp/usr/doc/apt/users-guide.html/
        cp -a build/docs/guide.html/* debian/tmp/usr/doc/apt/users-guide.html/
-
+       
+       # Copy the offline guide        
+       cp build/docs/offline.text debian/tmp/usr/doc/apt/offline.txt
+       mkdir debian/tmp/usr/doc/apt/offline.html/
+       cp -a build/docs/offline.html/* debian/tmp/usr/doc/apt/offline.html/
+       
+       cp -a debian/dhelp debian/tmp/usr/doc/apt/.dhelp
+       
 #      head -n 500 ChangeLog > debian/ChangeLog
 
        dh_installdocs -papt 
@@ -109,10 +117,11 @@ libapt-pkg-doc: build
        dh_testdir -plibapt-pkg-doc
        dh_testroot -plibapt-pkg-doc
        dh_clean -plibapt-pkg-doc -k
-       dh_installdirs -plibapt-pkg-doc usr/doc/apt
+       dh_installdirs -plibapt-pkg-doc usr/doc/apt usr/doc/libapt-pkg-doc
 
        cp -a build/docs/cache* build/docs/design* build/docs/dpkg-tech* \
          build/docs/files* build/docs/method* debian/libapt-pkg-doc/usr/doc/apt/
+       cp -a debian/libapt-pkg-doc.dhelp debian/libapt-pkg-doc/usr/doc/libapt-pkg-doc/.dhelp
 
        dh_installdocs -plibapt-pkg-doc
        dh_installchangelogs -plibapt-pkg-doc
@@ -131,7 +140,7 @@ source diff:
 # Update from CVS
 l33ch: really-clean
        cvs update
-       utils/mkChangeLog
+       buildlib/mkChangeLog
 
 # Update from CVS and then configure for build
 super-l33ch: l33ch Makefile.in