]> git.saurik.com Git - apt.git/blobdiff - debian/rules
- Don't fall off the end of the buffer when comparing v...
[apt.git] / debian / rules
index 23d26cc2b760efc309eab7aca0e90834ae5d98e3..144189189c7c8c14b3463b7e5614fe7daf3c10a2 100755 (executable)
@@ -2,7 +2,7 @@
 # Made with the aid of dh_make, by Craig Small
 # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
 # Some lines taken from debmake, by Christoph Lameter.
-# $Id: rules,v 1.37 2002/09/15 22:51:44 jgg Exp $
+# $Id: rules,v 1.49 2003/04/27 06:20:40 doogie Exp $
 
 # LD_LIBRARY_PATH=pwd/debian/apt/usr/lib dh_shlibdeps -papt
 # dpkg: /home/jgg/work/apt2/debian/apt/usr/lib/libapt-pkg.so.2.9 not found.
 
 export DH_COMPAT=2
 
+export DEB_HOST_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
+export DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
+
+# FOR AUTOCONF 2.52 AND NEWER ONLY
+ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
+  confflags += --build $(DEB_HOST_GNU_TYPE)
+else
+  confflags += --build $(DEB_BUILD_GNU_TYPE) --host $(DEB_HOST_GNU_TYPE)
+endif
+
 # See below
-include build/environment.mak
+-include build/environment.mak
 
 # Default rule
 build:
@@ -78,6 +88,7 @@ debian/shlibs.local: apt-pkg/makefile
        echo "libapt-inst$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTINST_MAJOR) $(LIBAPTINST_PROVIDE)" >> $@
 
 build: build/build-stamp       
+build-doc: build/build-doc-stamp       
 
 # Note that this is unconditionally done first as part of loading environment.mak
 # The true is needed to force make to reload environment.mak after running
@@ -90,29 +101,41 @@ build/configure-stamp: configure
        dh_testdir
        -mkdir build
        cp COPYING debian/copyright
-       (cd build; ../configure)
+ifneq ($(wildcard /usr/share/misc/config.sub),)
+       cp -a /usr/share/misc/config.sub buildlib/config.sub
+       echo Updating buildlib/config.sub
+endif
+ifneq ($(wildcard /usr/share/misc/config.guess),)
+       cp -a /usr/share/misc/config.guess buildlib/config.guess
+       echo Updating buildlib/config.guess
+endif
+       cd build && ../configure $(confflags)
        touch $@
 
 build/build-stamp: build/configure-stamp
        # Add here commands to compile the package.
-       $(MAKE) -s
+       $(MAKE) binary
+       touch $@
+
+build/build-doc-stamp: build/configure-stamp
+       # Add here commands to compile the package.
+       $(MAKE) doc
        touch $@
 
 clean:
        dh_testdir
 #      dh_testroot
-       rm -f build-stamp debian/shlibs.local
+       -$(MAKE) clean
+       -$(MAKE) distclean
+
        rm -rf build
-       rm -f debian/shlibs.local.apt debian/shlibs.local.apt-utils
 
        # Add here commands to clean up after the build process.
-       -$(MAKE) clean
-       -$(MAKE) distclean
-       dh_clean
+       dh_clean debian/copyright debian/shlibs.local debian/shlibs.local.apt debian/shlibs.local.apt-utils
 
-binary-indep: libapt-pkg-doc
+binary-indep: apt-doc libapt-pkg-doc
 # Build architecture-independent files here.
-libapt-pkg-doc: build debian/shlibs.local
+libapt-pkg-doc: build-doc debian/shlibs.local
        dh_testdir -p$@
        dh_testroot -p$@
        dh_clean -p$@ -k
@@ -123,10 +146,6 @@ libapt-pkg-doc: build debian/shlibs.local
        dh_installdocs -p$@ $(BLD)/docs/cache* $(BLD)/docs/design* $(BLD)/docs/dpkg-tech* \
                             $(BLD)/docs/files* $(BLD)/docs/method* \
                            doc/libapt-pkg2_to_3.txt doc/style.txt
-
-       -cp -a debian/libapt-pkg-doc.dhelp debian/libapt-pkg-doc/usr/doc/libapt-pkg-doc/.dhelp
-       -cp -a debian/libapt-pkg-doc.dhelp debian/libapt-pkg-doc/usr/share/doc/libapt-pkg-doc/.dhelp
-
        dh_installexamples -p$@
 #      dh_installmenu -p$@
 #      dh_installinit -p$@
@@ -144,6 +163,25 @@ libapt-pkg-doc: build debian/shlibs.local
        dh_md5sums -p$@
        dh_builddeb -p$@
 
+apt-doc: build-doc
+       dh_testdir -p$@
+       dh_testroot -p$@
+       dh_clean -p$@ -k
+#
+# apt-doc install
+#
+       # Copy the guides
+       dh_installdocs -p$@ $(BLD)/docs/guide*.text $(BLD)/docs/guide*.html \
+                      $(BLD)/docs/offline.text $(BLD)/docs/offline.html
+       dh_installchangelogs -p$@
+       dh_compress -p$@
+       dh_fixperms -p$@
+       dh_installdeb -p$@
+       dh_gencontrol -p$@
+       dh_md5sums -p$@
+       dh_builddeb -p$@
+
+
 
 # Build architecture-dependent files here.
 
@@ -152,7 +190,7 @@ apt: build debian/shlibs.local
        dh_testdir -p$@
        dh_testroot -p$@
        dh_clean -p$@ -k
-       dh_installdirs -p$@
+       dh_installdirs -p$@ /usr/share
 #
 # apt install
 #
@@ -168,20 +206,14 @@ apt: build debian/shlibs.local
        cp $(BLD)/bin/methods/* debian/apt/usr/lib/apt/methods/
 
        cp $(BLD)/scripts/dselect/* debian/apt/usr/lib/dpkg/methods/apt/
-
-       # Copy the guides
-       dh_installdocs -p$@ $(BLD)/docs/guide*.text $(BLD)/docs/guide*.html \
-                      $(BLD)/docs/offline.text $(BLD)/docs/offline.html
-
-       # One or the other..
-       -cp -a debian/dhelp debian/apt/usr/doc/apt/.dhelp
-       -cp -a debian/dhelp debian/apt/usr/share/doc/apt/.dhelp
+       cp -r $(BLD)/locale debian/apt/usr/share/
 
 #      head -n 500 ChangeLog > debian/ChangeLog
 
        dh_installexamples -p$@ $(BLD)/docs/examples/*
        dh_installmanpages -p$@ apt-ftparchive.1 apt-sortpkgs.1 apt-extracttemplates.1
 
+       dh_installdocs -p$@
        dh_installchangelogs -p$@
        dh_strip -p$@
        dh_compress -p$@
@@ -218,7 +250,7 @@ libapt-pkg-dev: build debian/shlibs.local
        dh_fixperms -p$@
 #      dh_suidregister -p$@
        dh_installdeb -p$@
-       dh_gencontrol -p$@ -u -Vlibapt-pkg:provides=$(LIBAPTPKG_PROVIDE)
+       dh_gencontrol -p$@ -u -Vlibapt-pkg:provides=$(LIBAPTPKG_PROVIDE) -Vlibapt-inst:provides=$(LIBAPTINST_PROVIDE)
        dh_md5sums -p$@
        dh_builddeb -p$@