]> git.saurik.com Git - apt.git/blobdiff - debian/rules
Add support for DEB_HOST_GNU_TYPE and DEB_BUILD_GNU_TYP...
[apt.git] / debian / rules
index 23d26cc2b760efc309eab7aca0e90834ae5d98e3..e8a3363259b9ab2a12a1dba2c263fda474e05db6 100755 (executable)
@@ -2,7 +2,7 @@
 # Made with the aid of dh_make, by Craig Small
 # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
 # Some lines taken from debmake, by Christoph Lameter.
-# $Id: rules,v 1.37 2002/09/15 22:51:44 jgg Exp $
+# $Id: rules,v 1.40 2002/11/09 20:13:27 doogie Exp $
 
 # LD_LIBRARY_PATH=pwd/debian/apt/usr/lib dh_shlibdeps -papt
 # dpkg: /home/jgg/work/apt2/debian/apt/usr/lib/libapt-pkg.so.2.9 not found.
 
 export DH_COMPAT=2
 
+export DEB_HOST_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
+export DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
+
+# FOR AUTOCONF 2.52 AND NEWER ONLY
+ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
+  confflags += --build $(DEB_HOST_GNU_TYPE)
+else
+  confflags += --build $(DEB_BUILD_GNU_TYPE) --host $(DEB_HOST_GNU_TYPE)
+endif
+
 # See below
-include build/environment.mak
+-include build/environment.mak
 
 # Default rule
 build:
@@ -90,7 +100,7 @@ build/configure-stamp: configure
        dh_testdir
        -mkdir build
        cp COPYING debian/copyright
-       (cd build; ../configure)
+       (cd build; ../configure $(confflags))
        touch $@
 
 build/build-stamp: build/configure-stamp
@@ -108,7 +118,7 @@ clean:
        # Add here commands to clean up after the build process.
        -$(MAKE) clean
        -$(MAKE) distclean
-       dh_clean
+       dh_clean debian/copyright
 
 binary-indep: libapt-pkg-doc
 # Build architecture-independent files here.
@@ -168,6 +178,7 @@ apt: build debian/shlibs.local
        cp $(BLD)/bin/methods/* debian/apt/usr/lib/apt/methods/
 
        cp $(BLD)/scripts/dselect/* debian/apt/usr/lib/dpkg/methods/apt/
+       cp -r $(BLD)/locale debian/apt/usr/
 
        # Copy the guides
        dh_installdocs -p$@ $(BLD)/docs/guide*.text $(BLD)/docs/guide*.html \