]> git.saurik.com Git - apt.git/blobdiff - debian/rules
* merged/removed conflicts with apt--main--0
[apt.git] / debian / rules
index 68f0427d8069a7682dd0f9e0a5952c4ef969f329..d6ae540ee0cc31289eb8b13f13231e91f1ba6137 100755 (executable)
@@ -2,8 +2,10 @@
 # Made with the aid of dh_make, by Craig Small
 # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
 # Some lines taken from debmake, by Christoph Lameter.
-# $Id: rules,v 1.22 2000/06/04 05:36:15 doogie Exp $
+# $Id: rules,v 1.68 2004/05/30 18:21:43 mdz Exp $
 
+# LD_LIBRARY_PATH=pwd/debian/apt/usr/lib dh_shlibdeps -papt
+# dpkg: /home/jgg/work/apt2/debian/apt/usr/lib/libapt-pkg.so.2.9 not found.
 
 # For the deb builder, you can run 'debian/rules cvs-build', which does all
 # steps nescessary to produce a proper source tarball with the CVS/ removed.
 # create ../upload-<VER>, with all the files needed to be uploaded placed
 # in it.
 
-DEB_BUILD_PROG:=debuild -us -uc
+export DEB_HOST_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
+export DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
+
+# FOR AUTOCONF 2.52 AND NEWER ONLY
+ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
+  confflags += --build $(DEB_HOST_GNU_TYPE)
+else
+  confflags += --build $(DEB_BUILD_GNU_TYPE) --host $(DEB_HOST_GNU_TYPE)
+endif
+
+# See below
+-include build/environment.mak
+
+ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+  export CXXFLAGS = -O0 -g -Wall
+else
+  export CXXFLAGS = -O2 -g -Wall
+endif
+
+# Default rule
+build:
+
+DEB_BUILD_PROG:=debuild --preserve-envvar PATH --preserve-envvar CCACHE_DIR -us -uc $(DEB_BUILD_PROG_OPTS)
 APT_DEBVER=$(shell dpkg-parsechangelog |sed -n -e '/^Version:/s/^Version: //p')
 APT_CONFVER=$(shell sed -n -e 's/^AC_DEFINE_UNQUOTED(VERSION,"\(.*\)")/\1/p' configure.in)
+APT_CVSTAG=$(shell echo "$(APT_DEBVER)" | sed -e 's/^/v/' -e 's/\./_/g')
 
 # Determine the build directory to use
 BASE=.
@@ -31,51 +56,85 @@ ifeq ($(words $(BLD)),0)
 override BLD := ./build
 endif
 
+# Rebuild configure.in to have the correct version from the change log
 ifneq ($(APT_DEBVER),$(APT_CONFVER))
+ifneq ($(APT_DEBVER),)
 .PHONY: configure.in
 configure.in:
-       sed -e 's/$(APT_CONFVER)/$(APT_DEBVER)/' $@ > $@.$$$$;mv $@.$$$$ $@
+       sed -e 's/$(APT_CONFVER)/$(APT_DEBVER)/' $@ > $@.$$$$ && mv $@.$$$$ $@
+endif
 else
 configure.in:
 endif
 
+# APT Programs in apt-utils
+APT_UTILS=ftparchive sortpkgs extracttemplates
+
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
 
 # Find the libapt-pkg major version for use in other control files
-export LIBAPT_MAJOR:=$(shell egrep '^MAJOR=' apt-pkg/makefile |cut -d '=' -f 2)
+export LIBAPTPKG_MAJOR:=$(shell egrep '^MAJOR=' apt-pkg/makefile |cut -d '=' -f 2)
+export LIBAPTINST_MAJOR:=$(shell egrep '^MAJOR=' apt-inst/makefile |cut -d '=' -f 2)
+
+# Determine which package we should provide in the control files
+LIBAPTPKG_PROVIDE=libapt-pkg$(GLIBC_VER)$(LIBSTDCPP_VER)-$(LIBAPTPKG_MAJOR)
+LIBAPTINST_PROVIDE=libapt-inst$(GLIBC_VER)$(LIBSTDCPP_VER)-$(LIBAPTINST_MAJOR)
+
 debian/shlibs.local: apt-pkg/makefile
-       rm -f $@
-       echo "libapt-pkg $(LIBAPT_MAJOR) libapt-pkg$(LIBAPT_MAJOR)" >> $@
-       echo "libapt-pkg $(LIBAPT_MAJOR) apt $(APT_DEBVER)" >> $@
+       # We have 3 shlibs.local files.. One for 'apt', one for 'apt-utils' and
+       # one for the rest of the packages. This ensures that each package gets
+       # the right overrides.. 
+       rm -rf $@ $@.apt $@.apt-utils
+       echo "libapt-pkg$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTPKG_MAJOR)" > $@.apt
+
+       echo "libapt-pkg$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTPKG_MAJOR) $(LIBAPTPKG_PROVIDE)" > $@.apt-utils
+       echo "libapt-inst$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTINST_MAJOR)" >> $@.apt-utils
 
-build: build-stamp
-build-stamp: configure
+       echo "libapt-pkg$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTPKG_MAJOR) $(LIBAPTPKG_PROVIDE)" > $@
+       echo "libapt-inst$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTINST_MAJOR) $(LIBAPTINST_PROVIDE)" >> $@
+
+build: build/build-stamp       
+build-doc: build/build-doc-stamp       
+
+# Note that this is unconditionally done first as part of loading environment.mak
+# The true is needed to force make to reload environment.mak after running
+# configure-stamp. Otherwise we can get stale or invalid, or missing config data.
+build/environment.mak: build/configure-stamp
+       @true
+
+configure: configure.in
+build/configure-stamp: configure
        dh_testdir
        -mkdir build
-       (cd build; ../configure)
-#      cd build && CXXFLAGS="-g -Wall -D_POSIX_C_SOURCE=199309" ../configure --disable-nls --disable-static --prefix=/usr
-#      cd build && make all-hdr
-#      cd build && make -s
+       cp COPYING debian/copyright
+       cd build && CXXFLAGS="$(confcxxflags)" ../configure $(confflags)
+       touch $@
 
+build/build-stamp: build/configure-stamp
        # Add here commands to compile the package.
-       $(MAKE)
-       touch build-stamp
+       $(MAKE) binary
+       touch $@
+
+build/build-doc-stamp: build/configure-stamp
+       # Add here commands to compile the package.
+       $(MAKE) doc
+       touch $@
 
 clean:
        dh_testdir
 #      dh_testroot
-       rm -f build-stamp debian/shlibs.local
+       -$(MAKE) clean
+       -$(MAKE) distclean
+
        rm -rf build
 
        # Add here commands to clean up after the build process.
-       -$(MAKE) clean
-       -$(MAKE) distclean
-       dh_clean
+       dh_clean debian/copyright debian/shlibs.local debian/shlibs.local.apt debian/shlibs.local.apt-utils
 
-binary-indep: libapt-pkg-doc
+binary-indep: apt-doc libapt-pkg-doc
 # Build architecture-independent files here.
-libapt-pkg-doc: build debian/shlibs.local
+libapt-pkg-doc: build-doc debian/shlibs.local
        dh_testdir -p$@
        dh_testroot -p$@
        dh_clean -p$@ -k
@@ -84,16 +143,13 @@ libapt-pkg-doc: build debian/shlibs.local
 # libapt-pkg-doc install
 #      
        dh_installdocs -p$@ $(BLD)/docs/cache* $(BLD)/docs/design* $(BLD)/docs/dpkg-tech* \
-                            $(BLD)/docs/files* $(BLD)/docs/method*
-                           
-       -cp -a debian/libapt-pkg-doc.dhelp debian/libapt-pkg-doc/usr/doc/libapt-pkg-doc/.dhelp
-       -cp -a debian/libapt-pkg-doc.dhelp debian/libapt-pkg-doc/usr/share/doc/libapt-pkg-doc/.dhelp
-       
+                            $(BLD)/docs/files* $(BLD)/docs/method* \
+                           doc/libapt-pkg2_to_3.txt doc/style.txt
        dh_installexamples -p$@
 #      dh_installmenu -p$@
 #      dh_installinit -p$@
 #      dh_installcron -p$@
-#      dh_installmanpages -p$@
+#      dh_installman -p$@
 
 #      dh_undocumented -p$@
        dh_installchangelogs -p$@
@@ -102,53 +158,73 @@ libapt-pkg-doc: build debian/shlibs.local
        dh_fixperms -p$@
 #      dh_suidregister -p$@
        dh_installdeb -p$@
-       dh_gencontrol -p$@ -u -Vlibapt-pkg:major=${LIBAPT_MAJOR}
+       dh_gencontrol -p$@ -u -Vlibapt-pkg:provides=$(LIBAPTPKG_PROVIDE)
+       dh_md5sums -p$@
+       dh_builddeb -p$@
+
+apt-doc: build-doc
+       dh_testdir -p$@
+       dh_testroot -p$@
+       dh_clean -p$@ -k
+#
+# apt-doc install
+#
+       # Copy the guides
+       dh_installdocs -p$@ $(BLD)/docs/guide*.text $(BLD)/docs/guide*.html \
+                      $(BLD)/docs/offline*.text $(BLD)/docs/offline*.html
+       dh_installchangelogs -p$@
+       dh_compress -p$@
+       dh_fixperms -p$@
+       dh_installdeb -p$@
+       dh_gencontrol -p$@
        dh_md5sums -p$@
        dh_builddeb -p$@
 
 
+
 # Build architecture-dependent files here.
 
-binary-arch: apt libapt-pkg-dev
+binary-arch: apt libapt-pkg-dev apt-utils 
 apt: build debian/shlibs.local
        dh_testdir -p$@
        dh_testroot -p$@
        dh_clean -p$@ -k
-       dh_installdirs -p$@
+       dh_installdirs -p$@ /usr/share/bug/$@ /usr/share/$@
 #
 # apt install
 #
-       cp $(BLD)/bin/apt-* debian/tmp/usr/bin/
-       
+       cp $(BLD)/bin/apt-* debian/$@/usr/bin/
+
+       # Remove the bits that are in apt-utils
+       rm $(addprefix debian/$@/usr/bin/apt-,$(APT_UTILS))
+
        # install the shared libs
-       find $(BLD)/bin/ -type f -name "libapt-pkg.so.*" -exec cp -a "{}" debian/tmp/usr/lib/ \;
-       find $(BLD)/bin/ -type l -name "libapt-pkg.so.*" -exec cp -a "{}" debian/tmp/usr/lib/ \;
+       find $(BLD)/bin/ -type f -name "libapt-pkg*.so.*" -exec cp -a "{}" debian/$@/usr/lib/ \;
+       find $(BLD)/bin/ -type l -name "libapt-pkg*.so.*" -exec cp -a "{}" debian/$@/usr/lib/ \;
 
-       cp $(BLD)/bin/methods/* debian/tmp/usr/lib/apt/methods/
+       cp $(BLD)/bin/methods/* debian/$@/usr/lib/apt/methods/
 
-       cp $(BLD)/scripts/dselect/* debian/tmp/usr/lib/dpkg/methods/apt/
+       cp $(BLD)/scripts/dselect/* debian/$@/usr/lib/dpkg/methods/apt/
+       cp -r $(BLD)/locale debian/$@/usr/share/
+
+       cp debian/bugscript debian/$@/usr/share/bug/apt/script
+
+       cp share/*.gpg debian/$@/usr/share/$@
 
-       # Copy the guides
-       dh_installdocs -p$@ $(BLD)/docs/guide.text $(BLD)/docs/guide.html \
-                      $(BLD)/docs/offline.text $(BLD)/docs/offline.html
-       
-       # One or the other..
-       -cp -a debian/dhelp debian/tmp/usr/doc/apt/.dhelp
-       -cp -a debian/dhelp debian/tmp/usr/share/doc/apt/.dhelp 
-       
 #      head -n 500 ChangeLog > debian/ChangeLog
 
        dh_installexamples -p$@ $(BLD)/docs/examples/*
-       dh_installmanpages -p$@
-
+       dh_installman -p$@ 
+       dh_installcron -p$@
+       dh_installdocs -p$@
        dh_installchangelogs -p$@
        dh_strip -p$@
        dh_compress -p$@
        dh_fixperms -p$@
+       dh_makeshlibs -p$@ -m$(LIBAPTPKG_MAJOR) -V '$(LIBAPTPKG_PROVIDE)'
        dh_installdeb -p$@
-       LD_LIBRARY_PATH=`pwd`/debian/tmp/usr/lib dh_shlibdeps -papt
-       dh_gencontrol -p$@ -u -Vlibapt-pkg:major=${LIBAPT_MAJOR}
-       dh_makeshlibs -m${LIBAPT_MAJOR} -Vlibapt-pkg${LIBAPT_MAJOR} -papt
+       dh_shlibdeps -p$@ -l`pwd`/debian/apt/usr/lib:`pwd`/debian/$@/usr/lib -- -Ldebian/shlibs.local.apt
+       dh_gencontrol -p$@ -u -Vlibapt-pkg:provides=$(LIBAPTPKG_PROVIDE)
        dh_md5sums -p$@
        dh_builddeb -p$@
 
@@ -160,15 +236,16 @@ libapt-pkg-dev: build debian/shlibs.local
 #
 # libapt-pkg-dev install
 #
-       cp -a $(BLD)/bin/libapt-pkg.so debian/libapt-pkg-dev/usr/lib/
-       #ln -s libapt-pkg.so.${LIBAPT_MAJOR} debian/libapt-pkg-dev/usr/lib/libapt-pkg.so
+       cp -a $(BLD)/bin/libapt-pkg*.so debian/libapt-pkg-dev/usr/lib/
+       cp -a $(BLD)/bin/libapt-inst*.so debian/libapt-pkg-dev/usr/lib/
+#      ln -s libapt-pkg.so.$(LIBAPTPKG_MAJOR) debian/libapt-pkg-dev/usr/lib/libapt-pkg.so
        cp $(BLD)/include/apt-pkg/*.h debian/libapt-pkg-dev/usr/include/apt-pkg/
 
        dh_installdocs -p$@
 #      dh_installmenu -p$@
 #      dh_installinit -p$@
 #      dh_installcron -p$@
-#      dh_installmanpages -p$@
+#      dh_installman -p$@
 
        dh_installchangelogs -p$@
        dh_strip -p$@
@@ -176,11 +253,38 @@ libapt-pkg-dev: build debian/shlibs.local
        dh_fixperms -p$@
 #      dh_suidregister -p$@
        dh_installdeb -p$@
-       dh_gencontrol -p$@ -u -Vlibapt-pkg:major=${LIBAPT_MAJOR}
+       dh_gencontrol -p$@ -u -Vlibapt-pkg:provides=$(LIBAPTPKG_PROVIDE) -Vlibapt-inst:provides=$(LIBAPTINST_PROVIDE)
+       dh_md5sums -p$@
+       dh_builddeb -p$@
+
+apt-utils: build debian/shlibs.local
+       dh_testdir -p$@
+       dh_testroot -p$@
+       dh_clean -p$@ -k
+       dh_installdirs -p$@
+
+       # install the shared libs
+       find $(BLD)/bin/ -type f -name "libapt-inst*.so.*" -exec cp -a "{}" debian/$@/usr/lib/ \;
+       find $(BLD)/bin/ -type l -name "libapt-inst*.so.*" -exec cp -a "{}" debian/$@/usr/lib/ \;
+
+       cp $(addprefix $(BLD)/bin/apt-,$(APT_UTILS)) debian/$@/usr/bin/
+       dh_installdocs -p$@
+
+       # Install the man pages..
+       dh_installman -p$@
+
+       dh_installchangelogs -p$@
+       dh_strip -p$@
+       dh_compress -p$@
+       dh_fixperms -p$@
+       dh_makeshlibs -m$(LIBAPTINST_MAJOR) -V '$(LIBAPTINST_PROVIDE)' -p$@
+       dh_installdeb -p$@
+       dh_shlibdeps -p$@ -l`pwd`/debian/apt/usr/lib:`pwd`/debian/$@/usr/lib -- -Ldebian/shlibs.local.apt-utils
+       dh_gencontrol -p$@ -u -Vlibapt-inst:provides=$(LIBAPTINST_PROVIDE)
        dh_md5sums -p$@
        dh_builddeb -p$@
 
-source diff:                                                                  
+source diff:
        @echo >&2 'source and diff are obsolete - use dpkg-source -b'; false
 
 # Update from CVS
@@ -195,7 +299,7 @@ configure:
        $(MAKE) configure
 
 l33ch-stamp: super-l33ch
-       touch l33ch-stamp
+       touch $@
 
 really-clean: clean
        -find -name Makefile.in -print0 | xargs -0r rm -f
@@ -213,19 +317,23 @@ binary: binary-indep binary-arch
 # edit configure.in
 # debian/rules cvs-build
 
+CVS_BUILDDIR=apt-$(APT_DEBVER)
+CVS_ROOT=$(shell cat CVS/Root)
+CVS_MODULE=$(shell cat CVS/Repository)
 cvs-build:
        rm -rf debian/cvs-build
-       cvs update
-       buildlib/mkChangeLog
-       $(MAKE) startup
-       $(MAKE) doc
-       tar c --exclude CVS --exclude debian/cvs-build . |\
-               (mkdir -p debian/cvs-build/apt-$(APT_DEBVER);cd debian/cvs-build/apt-$(APT_DEBVER);tar x)
-# The next line isn't needed, as debuild will make the .tar.gz for us.
-#      (cd debian/cvs-build;tar zcf apt_$(APT_DEBVER).tar.gz apt-$(APT_DEBVER))
-       (cd debian/cvs-build/apt-$(APT_DEBVER);$(DEB_BUILD_PROG))
-       rm ChangeLog
+       mkdir -p debian/cvs-build
+       (cd debian/cvs-build;cvs -d $(CVS_ROOT) export -r$(APT_CVSTAG) -d apt-$(APT_DEBVER) $(CVS_MODULE))
+       $(MAKE) -C debian/cvs-build/$(CVS_BUILDDIR) startup doc
+       (cd debian/cvs-build/$(CVS_BUILDDIR);$(DEB_BUILD_PROG))
 
 cvs-mkul:
        -mkdir -p ../upload-$(APT_DEBVER)
        cp `find debian/cvs-build -maxdepth 1 -type f` ../upload-$(APT_DEBVER)
+
+arch-build:
+       rm -rf debian/arch-build
+       mkdir -p debian/arch-build/apt-$(APT_DEBVER)
+       baz inventory -s | xargs cp -a --parents --target=debian/arch-build/apt-$(APT_DEBVER)
+       $(MAKE) -C debian/arch-build/apt-$(APT_DEBVER) startup doc
+       (cd debian/arch-build/apt-$(APT_DEBVER); $(DEB_BUILD_PROG))