]> git.saurik.com Git - apt.git/blobdiff - debian/changelog
* apt-pkg/deb/debversion.cc:
[apt.git] / debian / changelog
index 607dddcfa50b0ac8b17c92e9aab4016cc96fe831..b0e66912923aac48a561e2399b5b02eb81ae40f0 100644 (file)
-apt (0.9.7.6) UNRELEASED; urgency=low
+apt (0.9.7.8~exp2+nmu1) UNRELEASED; urgency=low
+
+  [ David Kalnischkies ]
+  * various simple changes to fix cppcheck warnings
+  * apt-pkg/pkgcachegen.cc:
+    - do not store the MD5Sum for every description language variant as
+      it will be the same for all so it can be shared to save cache space
+    - handle language tags for descriptions are unique strings to be shared
+    - factor version string creation out of NewDepends, so we can easily reuse
+      version strings e.g. for implicit multi-arch dependencies
+  * apt-pkg/deb/debversion.cc:
+    - add a string-equal shortcut for equal version comparisions
+
+ -- David Kalnischkies <kalnischkies@gmail.com>  Sun, 10 Mar 2013 12:23:24 +0100
+
+apt (0.9.7.8~exp2) experimental; urgency=low
+
+  * include two missing patches to really fix bug #696225, thanks to
+    Guillem Jover 
+  * ensure sha512 is really used when available, thanks to Tyler Hicks
+   (LP: #1098752)
+
+ -- Michael Vogt <mvo@debian.org>  Fri, 01 Mar 2013 19:06:55 +0100
+
+apt (0.9.7.8~exp1) experimental; urgency=low
+
+  [ Manpages translation updates ]
+  * Italian (Beatrice Torracca). Closes: #696601
+  
+  [ Programs translation updates ]
+  * Japanese (Kenshi Muto). Closes: #699783
+  
+  [ Michael Vogt ]
+  * fix pkgProblemResolver::Scores, thanks to Paul Wise. 
+    Closes: #697577
+  * fix missing translated apt.8 manpages, thanks to Helge Kreutzmann
+    for the report. Closes: #696923
+  * apt-pkg/contrib/progress.cc:
+    - Make "..." translatable to fix inconsistencies in the output
+      of e.g. apt-get update. While this adds new translatable strings,
+      not having translations for them will not break anything.
+      Thanks to Guillem Jover. Closes: #696225
+  * debian/apt.cron.daily:
+    - when reading from /dev/urandom, use less entropy and fix a rare
+      bug when the random number chksum is less than 1000.
+      Closes: #695285
+  * methods/https.cc:
+    - reuse connection in https, thanks to Thomas Bushnell, BSG for the
+      patch. LP: #1087543, Closes: #695359
+    - add missing curl_easy_cleanup()
+  * methods/http.cc:
+    - quote spaces in filenames to ensure as the http method is also
+      (potentially) used for non deb,dsc content that may contain
+      spaces, thanks to Daniel Hartwig and Thomas Bushnell 
+      (LP: #1086997)
+    - quote plus in filenames to work around a bug in the S3 server
+      (LP: #1003633)
+  * apt-pkg/indexrecords.cc:
+    - support '\r' in the Release file
+
+  [ David Kalnischkies ]
+  * apt-pkg/depcache.cc:
+    - prefer to install packages which have an already installed M-A:same
+      sibling while choosing providers (LP: #1130419)
+
+ -- Michael Vogt <mvo@debian.org>  Fri, 01 Mar 2013 14:16:42 +0100
+
+apt (0.9.7.7) unstable; urgency=low
+
+  [ Program translation updates ]
+  * Catalan (Jordi Mallach)
+  * Drop a confusing non-breaking space. Closes: #691024
+  * Thai (Theppitak Karoonboonyanan). Closes: #691613
+  * Vietnamese (Trần Ngọc Quân). Closes: #693773
+  * Fix Plural forms in German, French, Japanese and Portuguese
+    translations. Thanks to Jakub Wilk for reporting these errors.
+
+  [ David Kalnischkies ]
+  * apt-pkg/packagemanager.cc:
+    - do not do lock-step configuration for a M-A:same package if it isn't
+      unpacked yet in SmartConfigure and do not unpack a M-A:same package
+      again in SmartUnPack if we have already configured it (LP: #1062503)
+  * apt-pkg/depcache.cc:
+    - don't call MarkInstall with the FromUser flag set for packages
+      which are dependencies of APT::Never-MarkAuto-Sections matchers
+    - no mode changes should obviously be ok for pkgDepCache::IsModeChangeOk
+  * cmdline/apt-get.cc:
+    - do not call Mark{Install,Delete} from the autoremove code with
+      the FromUser bit set to avoid modifying the auto-installed bit
+  * apt-pkg/algorithms.cc:
+    - ensure pkgProblemResolver calls MarkDelete without FromUser set
+      so that it can't overrule holds and the protection flag
+  
+  [ Michael Vogt ]
+  * change permissions of /var/log/apt/term.log to 0640 (LP: #975199)
+
+  [ Jonathan Thomas ]
+  * apt-pkg/algorithms.cc:
+    - fix package-pointer array memory leak in ResolveByKeepInternal()
+
+ -- Michael Vogt <mvo@debian.org>  Thu, 13 Dec 2012 09:52:19 +0100
+
+apt (0.9.7.6) unstable; urgency=low
+
+  [ Program translation updates ]
+  * Ukrainian (A. Bondarenko)
 
   [ David Kalnischkies ]
   * apt-pkg/pkgcachegen.cc:
     - ensure that dependencies for packages:none are always generated
-    - add 3 missing remap registrations causing a segfault in case
+    - add 2 missing remap registrations causing a segfault in case
       we use the not remapped iterators after a move of the mmap again
+    - write the native architecture as unique string into the cache header
+      as it is used for arch:all packages as a map to arch:native.
+      Otherwise arch comparisons later will see differences (Closes: #689323)
   * apt-pkg/pkgcache.cc:
-    - ignore negative dependencies applying in the same group for
-      M-A:same packages on the real package name as self-conflicts
+    - ignore negative dependencies applying in the same group for M-A:same
+      packages on the real package name as self-conflicts (Closes: #688863)
   * cmdline/apt-cache.cc:
     - print versioned dependency relations in (r)depends if the option
       APT::Cache::ShowVersion is true (default: false) as discussed in
       #218995 to help debian-cd fixing #687949. Thanks to Sam Lidder
       for initial patch and Steve McIntyre for nagging and testing!
+  * apt-pkg/edsp.cc:
+    - include reinstall requests and already installed (= protected) packages
+      in the install-request for external resolvers (Closes: #689331)
+  * apt-pkg/policy.cc:
+    - match pins with(out) an architecture as we do on the commandline
+      (partly fixing #687255, b= support has to wait for jessie)
+  * apt-pkg/contrib/netrc.cc:
+    - remove the 64 char limit for login/password in internal usage
+    - remove 256 char line limit by using getline() (POSIX.1-2008)
+  
+  [ Colin Watson ]
+  * apt-pkg/pkgcachegen.cc:
+    - Fix crash if the cache is remapped while writing a Provides version
+      (LP: #1066445).
 
- -- David Kalnischkies <kalnischkies@gmail.com>  Wed, 19 Sep 2012 11:29:56 +0200
+ -- Michael Vogt <mvo@debian.org>  Tue, 16 Oct 2012 18:08:53 +0200
 
 apt (0.9.7.5) unstable; urgency=low