]> git.saurik.com Git - apt.git/blobdiff - debian/changelog
* apt-pkg/deb/debsrcrecords.cc:
[apt.git] / debian / changelog
index 7e1ce4f4ea7775e43cb2e12a8b5be7e84289a1f7..0e7ffb80ff337d0b7ae8aab628c17bed62ec6d4c 100644 (file)
@@ -1,3 +1,23 @@
+apt (0.8.16~exp7) experimental; urgency=low
+
+  [ David Kalnischkies ]
+  * do not pollute namespace in the headers with using (Closes: #500198)
+  * use forward declaration in headers if possible instead of includes
+  * remove old APT_COMPATIBILITY ifdef's
+  * apt-pkg/deb/dpkgpm.cc:
+    - use std::vector instead of fixed size arrays to store args and
+      multiarch-packagename strings
+    - load the dpkg base arguments only one time and reuse them later
+  * cmdline/apt-get.cc:
+    - follow Provides in the evaluation of saving candidates, too, for
+      statisfying garbage package dependencies (Closes: #640590)
+  * apt-pkg/algorithms.cc:
+    - if a package is garbage, don't try to save it with FixByInstall
+  * apt-pkg/deb/debsrcrecords.cc:
+    - remove the limit of 400 Binaries for a source package (Closes: #622110)
+
+ -- David Kalnischkies <kalnischkies@gmail.com>  Wed, 21 Sep 2011 19:29:55 +0200
+
 apt (0.8.16~exp6) experimental; urgency=low
 
   [ Christopher Baines ]