]> git.saurik.com Git - apt.git/blobdiff - debian/rules
* Use debian/compat rather than DH_COMPAT
[apt.git] / debian / rules
index 40f6087bb47effa4a32883076fe40fce9297a421..86b191e17e7b32ae87874a81981e8191fa7f967c 100755 (executable)
@@ -2,7 +2,7 @@
 # Made with the aid of dh_make, by Craig Small
 # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
 # Some lines taken from debmake, by Christoph Lameter.
-# $Id: rules,v 1.46 2003/02/12 07:39:45 doogie Exp $
+# $Id: rules,v 1.52 2003/08/09 19:14:49 mdz Exp $
 
 # LD_LIBRARY_PATH=pwd/debian/apt/usr/lib dh_shlibdeps -papt
 # dpkg: /home/jgg/work/apt2/debian/apt/usr/lib/libapt-pkg.so.2.9 not found.
@@ -14,8 +14,6 @@
 # create ../upload-<VER>, with all the files needed to be uploaded placed
 # in it.
 
-export DH_COMPAT=2
-
 export DEB_HOST_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
 export DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
 
@@ -146,15 +144,11 @@ libapt-pkg-doc: build-doc debian/shlibs.local
        dh_installdocs -p$@ $(BLD)/docs/cache* $(BLD)/docs/design* $(BLD)/docs/dpkg-tech* \
                             $(BLD)/docs/files* $(BLD)/docs/method* \
                            doc/libapt-pkg2_to_3.txt doc/style.txt
-
-       -cp -a debian/libapt-pkg-doc.dhelp debian/libapt-pkg-doc/usr/doc/libapt-pkg-doc/.dhelp
-       -cp -a debian/libapt-pkg-doc.dhelp debian/libapt-pkg-doc/usr/share/doc/libapt-pkg-doc/.dhelp
-
        dh_installexamples -p$@
 #      dh_installmenu -p$@
 #      dh_installinit -p$@
 #      dh_installcron -p$@
-#      dh_installmanpages -p$@
+#      dh_installman -p$@
 
 #      dh_undocumented -p$@
        dh_installchangelogs -p$@
@@ -177,11 +171,6 @@ apt-doc: build-doc
        # Copy the guides
        dh_installdocs -p$@ $(BLD)/docs/guide*.text $(BLD)/docs/guide*.html \
                       $(BLD)/docs/offline.text $(BLD)/docs/offline.html
-
-       # One or the other..
-       -cp -a debian/apt-doc.dhelp debian/apt/usr/doc/apt-doc/.dhelp
-       -cp -a debian/apt-doc.dhelp debian/apt/usr/share/doc/apt-doc/.dhelp
-
        dh_installchangelogs -p$@
        dh_compress -p$@
        dh_fixperms -p$@
@@ -199,7 +188,7 @@ apt: build debian/shlibs.local
        dh_testdir -p$@
        dh_testroot -p$@
        dh_clean -p$@ -k
-       dh_installdirs -p$@ /usr/share
+       dh_installdirs -p$@ /usr/share/bug/$@
 #
 # apt install
 #
@@ -217,19 +206,14 @@ apt: build debian/shlibs.local
        cp $(BLD)/scripts/dselect/* debian/apt/usr/lib/dpkg/methods/apt/
        cp -r $(BLD)/locale debian/apt/usr/share/
 
-       # Copy the guides
-       dh_installdocs -p$@ $(BLD)/docs/guide*.text $(BLD)/docs/guide*.html \
-                      $(BLD)/docs/offline.text $(BLD)/docs/offline.html
-
-       # One or the other..
-       -cp -a debian/dhelp debian/apt/usr/doc/apt/.dhelp
-       -cp -a debian/dhelp debian/apt/usr/share/doc/apt/.dhelp
+       cp debian/bugscript debian/apt/usr/share/bug/apt/script
 
 #      head -n 500 ChangeLog > debian/ChangeLog
 
        dh_installexamples -p$@ $(BLD)/docs/examples/*
-       dh_installmanpages -p$@ apt-ftparchive.1 apt-sortpkgs.1 apt-extracttemplates.1
+       dh_installman -p$@ 
 
+       dh_installdocs -p$@
        dh_installchangelogs -p$@
        dh_strip -p$@
        dh_compress -p$@
@@ -258,7 +242,7 @@ libapt-pkg-dev: build debian/shlibs.local
 #      dh_installmenu -p$@
 #      dh_installinit -p$@
 #      dh_installcron -p$@
-#      dh_installmanpages -p$@
+#      dh_installman -p$@
 
        dh_installchangelogs -p$@
        dh_strip -p$@
@@ -284,8 +268,7 @@ apt-utils: build debian/shlibs.local
        dh_installdocs -p$@
 
        # Install the man pages..
-       mkdir -p debian/$@/usr/share/man/man1
-       -cp doc/apt-sortpkgs.1 doc/apt-ftparchive.1 doc/apt-extracttemplates.1 debian/$@/usr/share/man/man1/
+       dh_installman -p$@
 
        dh_installchangelogs -p$@
        dh_strip -p$@