]> git.saurik.com Git - apt.git/blobdiff - debian/rules
* debian/rules:
[apt.git] / debian / rules
index 25e4d4d1f4867a7df6270a5a83c26ec5dcdff020..ba19f25265e9e75336580e3f98fe7ddf19351b25 100755 (executable)
@@ -36,8 +36,9 @@ endif
 # Default rule
 build:
 
-DEB_BUILD_PROG:=debuild --preserve-envvar PATH --preserve-envvar CCACHE_DIR -us -uc $(DEBUILD_DPKG_BUILDPACKAGE_OPTS)
-APT_DEBVER=$(shell dpkg-parsechangelog |sed -n -e '/^Version:/s/^Version: //p')
+PKG=apt
+DEB_BUILD_PROG:=debuild --preserve-envvar PATH --preserve-envvar CCACHE_DIR -us -uc $(DEB_BUILD_PROG_OPTS)
+APT_DEBVER=$(shell dpkg-parsechangelog |sed -n -e '/^Version:/s/^Version: //p' | sed -e 's/\+.*$$//')
 APT_CONFVER=$(shell sed -n -e 's/^AC_DEFINE_UNQUOTED(VERSION,"\(.*\)")/\1/p' configure.in)
 APT_CVSTAG=$(shell echo "$(APT_DEBVER)" | sed -e 's/^/v/' -e 's/\./_/g')
 
@@ -46,7 +47,7 @@ BASE=.
 ifdef BUILD
 BUILD_POSSIBLE := $(BUILD) $(BASE)/$(BUILD)
 else
-BUILD_POSSIBLE := $(BASE) $(BASE)/build-$(shell uname -m) $(BASE)/build
+BUILD_POSSIBLE := $(BASE) $(BASE)/build-$(shell uname --machine) $(BASE)/build
 endif
 BUILDX:= $(foreach i,$(BUILD_POSSIBLE),$(wildcard $(i)/environment.mak*))
 BUILDX:= $(patsubst %/,%,$(firstword $(dir $(BUILDX))))
@@ -74,28 +75,27 @@ APT_UTILS=ftparchive sortpkgs extracttemplates
 #export DH_VERBOSE=1
 
 # Find the libapt-pkg major version for use in other control files
-export LIBAPTPKG_MAJOR:=$(shell egrep '^MAJOR=' apt-pkg/makefile |cut -d '=' -f 2)
-export LIBAPTINST_MAJOR:=$(shell egrep '^MAJOR=' apt-inst/makefile |cut -d '=' -f 2)
+include buildlib/libversion.mak
 
 # Determine which package we should provide in the control files
-LIBAPTPKG_PROVIDE=libapt-pkg$(GLIBC_VER)$(LIBSTDCPP_VER)-$(LIBAPTPKG_MAJOR)
-LIBAPTINST_PROVIDE=libapt-inst$(GLIBC_VER)$(LIBSTDCPP_VER)-$(LIBAPTINST_MAJOR)
+LIBAPTPKG_PROVIDE=libapt-pkg$(LIBAPTPKG_MAJOR)
+LIBAPTINST_PROVIDE=libapt-inst$(LIBAPTINST_MAJOR)
 
 debian/shlibs.local: apt-pkg/makefile
-       # We have 3 shlibs.local files.. One for 'apt', one for 'apt-utils' and
+       # We have 3 shlibs.local files: One for 'apt', one for 'apt-utils' and
        # one for the rest of the packages. This ensures that each package gets
-       # the right overrides.. 
+       # the right overrides
        rm -rf $@ $@.apt $@.apt-utils
-       echo "libapt-pkg$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTPKG_MAJOR)" > $@.apt
+       echo "libapt-pkg $(LIBAPTPKG_MAJOR)" > $@.apt
 
-       echo "libapt-pkg$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTPKG_MAJOR) $(LIBAPTPKG_PROVIDE)" > $@.apt-utils
-       echo "libapt-inst$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTINST_MAJOR)" >> $@.apt-utils
+       echo "libapt-pkg $(LIBAPTPKG_MAJOR) $(LIBAPTPKG_PROVIDE)" > $@.apt-utils
+       echo "libapt-inst $(LIBAPTINST_MAJOR)" >> $@.apt-utils
 
-       echo "libapt-pkg$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTPKG_MAJOR) $(LIBAPTPKG_PROVIDE)" > $@
-       echo "libapt-inst$(GLIBC_VER)$(LIBSTDCPP_VER) $(LIBAPTINST_MAJOR) $(LIBAPTINST_PROVIDE)" >> $@
+       echo "libapt-pkg $(LIBAPTPKG_MAJOR) $(LIBAPTPKG_PROVIDE)" > $@
+       echo "libapt-inst $(LIBAPTINST_MAJOR) $(LIBAPTINST_PROVIDE)" >> $@
 
-build: build/build-stamp       
-build-doc: build/build-doc-stamp       
+build: build/build-stamp
+build-doc: build/build-doc-stamp
 
 # Note that this is unconditionally done first as part of loading environment.mak
 # The true is needed to force make to reload environment.mak after running
@@ -123,10 +123,8 @@ build/build-doc-stamp: build/configure-stamp
 
 clean:
        dh_testdir
-#      dh_testroot
-       -$(MAKE) clean
-       -$(MAKE) distclean
 
+       [ ! -f Makefile ] || $(MAKE) clean distclean
        rm -rf build
 
        # Add here commands to clean up after the build process.
@@ -141,22 +139,19 @@ libapt-pkg-doc: build-doc debian/shlibs.local
        dh_installdirs -p$@
 #
 # libapt-pkg-doc install
-#      
-       dh_installdocs -p$@ $(BLD)/docs/cache* $(BLD)/docs/design* $(BLD)/docs/dpkg-tech* \
-                            $(BLD)/docs/files* $(BLD)/docs/method* \
-                           doc/libapt-pkg2_to_3.txt doc/style.txt
+#
+       dh_installdocs -p$@ $(BLD)/docs/design* \
+                           $(BLD)/docs/dpkg-tech* \
+                           $(BLD)/docs/files* \
+                           $(BLD)/docs/method* \
+                           doc/libapt-pkg2_to_3.txt \
+                           doc/style.txt
        dh_installexamples -p$@
-#      dh_installmenu -p$@
-#      dh_installinit -p$@
-#      dh_installcron -p$@
-#      dh_installman -p$@
 
-#      dh_undocumented -p$@
        dh_installchangelogs -p$@
        dh_strip -p$@
        dh_compress -p$@
        dh_fixperms -p$@
-#      dh_suidregister -p$@
        dh_installdeb -p$@
        dh_gencontrol -p$@ -u -Vlibapt-pkg:provides=$(LIBAPTPKG_PROVIDE)
        dh_md5sums -p$@
@@ -170,8 +165,10 @@ apt-doc: build-doc
 # apt-doc install
 #
        # Copy the guides
-       dh_installdocs -p$@ $(BLD)/docs/guide*.text $(BLD)/docs/guide*.html \
-                      $(BLD)/docs/offline*.text $(BLD)/docs/offline*.html
+       dh_installdocs -p$@ $(BLD)/docs/guide*.text \
+                           $(BLD)/docs/guide*.html \
+                           $(BLD)/docs/offline*.text \
+                           $(BLD)/docs/offline*.html
        dh_installchangelogs -p$@
        dh_compress -p$@
        dh_fixperms -p$@
@@ -184,12 +181,13 @@ apt-doc: build-doc
 
 # Build architecture-dependent files here.
 
-binary-arch: apt libapt-pkg-dev apt-utils 
-apt: build debian/shlibs.local
+binary-arch: apt libapt-pkg-dev apt-utils apt-transport-https
+apt_MANPAGES = apt-cache apt-cdrom apt-config apt-get apt-key apt-mark apt-secure apt apt.conf apt_preferences sources.list
+apt: build build-doc debian/shlibs.local
        dh_testdir -p$@
        dh_testroot -p$@
        dh_clean -p$@ -k
-       dh_installdirs -p$@ /usr/share/bug/$@ /usr/share/$@
+       dh_installdirs -p$@
 #
 # apt install
 #
@@ -203,27 +201,36 @@ apt: build debian/shlibs.local
        find $(BLD)/bin/ -type l -name "libapt-pkg*.so.*" -exec cp -a "{}" debian/$@/usr/lib/ \;
 
        cp $(BLD)/bin/methods/* debian/$@/usr/lib/apt/methods/
+       # https has its own package
+       rm debian/$@/usr/lib/apt/methods/https
 
        cp $(BLD)/scripts/dselect/* debian/$@/usr/lib/dpkg/methods/apt/
        cp -r $(BLD)/locale debian/$@/usr/share/
 
        cp debian/bugscript debian/$@/usr/share/bug/apt/script
+       cp debian/apt.logrotate debian/$@/etc/logrotate.d/apt
 
-       cp share/debian-archive.gpg debian/$@/usr/share/$@
+       cp debian/apt.conf.autoremove debian/$@/etc/apt/apt.conf.d/01autoremove
 
-#      head -n 500 ChangeLog > debian/ChangeLog
+       # copy lintian override
+       cp share/lintian-overrides debian/$@/usr/share/lintian/overrides/apt
+
+       # make rosetta happy and remove pot files in po/ (but leave stuff
+       # in po/domains/* untouched) and cp *.po into each domain dir
+       rm -f build/po/*.pot
+       rm -f po/*.pot
 
        dh_installexamples -p$@ $(BLD)/docs/examples/*
-       dh_installman -p$@ 
+       dh_installman -p$@ $(wildcard $(patsubst %,doc/%.[158],$(apt_MANPAGES)) $(patsubst %,doc/*/%.*.[158],$(apt_MANPAGES)))
        dh_installcron -p$@
        dh_installdocs -p$@
        dh_installchangelogs -p$@
        dh_strip -p$@
        dh_compress -p$@
        dh_fixperms -p$@
-       dh_makeshlibs -p$@ -m$(LIBAPTPKG_MAJOR) -V '$(LIBAPTPKG_PROVIDE)'
+       dh_makeshlibs -p$@ --major=$(LIBAPTPKG_MAJOR) --version-info='$(LIBAPTPKG_PROVIDE)'
        dh_installdeb -p$@
-       dh_shlibdeps -p$@ -l`pwd`/debian/apt/usr/lib:`pwd`/debian/$@/usr/lib -- -Ldebian/shlibs.local.apt
+       dh_shlibdeps -p$@ -l$(pwd)/debian/apt/usr/lib:$(pwd)/debian/$@/usr/lib -- -Ldebian/shlibs.local.apt
        dh_gencontrol -p$@ -u -Vlibapt-pkg:provides=$(LIBAPTPKG_PROVIDE)
        dh_md5sums -p$@
        dh_builddeb -p$@
@@ -242,21 +249,17 @@ libapt-pkg-dev: build debian/shlibs.local
        cp $(BLD)/include/apt-pkg/*.h debian/libapt-pkg-dev/usr/include/apt-pkg/
 
        dh_installdocs -p$@
-#      dh_installmenu -p$@
-#      dh_installinit -p$@
-#      dh_installcron -p$@
-#      dh_installman -p$@
 
        dh_installchangelogs -p$@
        dh_strip -p$@
        dh_compress -p$@
        dh_fixperms -p$@
-#      dh_suidregister -p$@
        dh_installdeb -p$@
        dh_gencontrol -p$@ -u -Vlibapt-pkg:provides=$(LIBAPTPKG_PROVIDE) -Vlibapt-inst:provides=$(LIBAPTINST_PROVIDE)
        dh_md5sums -p$@
        dh_builddeb -p$@
 
+apt-utils_MANPAGES = apt-sortpkgs apt-ftparchive apt-extracttemplates
 apt-utils: build debian/shlibs.local
        dh_testdir -p$@
        dh_testroot -p$@
@@ -269,21 +272,48 @@ apt-utils: build debian/shlibs.local
 
        cp $(addprefix $(BLD)/bin/apt-,$(APT_UTILS)) debian/$@/usr/bin/
        dh_installdocs -p$@
+       dh_installexamples -p$@
 
        # Install the man pages..
-       dh_installman -p$@
+       dh_installman -p$@ $(wildcard $(patsubst %,doc/%.[158],$(apt-utils_MANPAGES)) $(patsubst %,doc/*/%.*.[158],$(apt-utils_MANPAGES)))
 
        dh_installchangelogs -p$@
        dh_strip -p$@
        dh_compress -p$@
        dh_fixperms -p$@
-       dh_makeshlibs -m$(LIBAPTINST_MAJOR) -V '$(LIBAPTINST_PROVIDE)' -p$@
+       dh_makeshlibs -p$@ --major=$(LIBAPTINST_MAJOR) --version-info='$(LIBAPTINST_PROVIDE)'
        dh_installdeb -p$@
-       dh_shlibdeps -p$@ -l`pwd`/debian/apt/usr/lib:`pwd`/debian/$@/usr/lib -- -Ldebian/shlibs.local.apt-utils
+       dh_shlibdeps -p$@ -l$(pwd)/debian/apt/usr/lib:$(pwd)/debian/$@/usr/lib -- -Ldebian/shlibs.local.apt-utils
        dh_gencontrol -p$@ -u -Vlibapt-inst:provides=$(LIBAPTINST_PROVIDE)
        dh_md5sums -p$@
        dh_builddeb -p$@
 
+apt-transport-https: build debian/shlibs.local libapt-pkg-dev
+       dh_testdir -p$@
+       dh_testroot -p$@
+       dh_clean -p$@ -k
+       dh_installdirs -p$@
+
+       # install the method
+       mkdir --parents debian/$@/usr/lib/apt/methods
+       cp $(BLD)/bin/methods/https debian/$@/usr/lib/apt/methods
+
+       dh_installdocs -p$@ debian/apt-transport-https.README
+       dh_installexamples -p$@
+
+       # Install the man pages..
+       dh_installman -p$@
+
+       dh_installchangelogs -p$@
+       dh_strip -p$@
+       dh_compress -p$@
+       dh_fixperms -p$@
+       dh_installdeb -p$@
+       dh_shlibdeps -p$@ -l$(pwd)/debian/apt/usr/lib:$(pwd)/debian/$@/usr/lib 
+       dh_gencontrol -p$@
+       dh_md5sums -p$@
+       dh_builddeb -p$@
+
 source diff:
        @echo >&2 'source and diff are obsolete - use dpkg-source -b'; false
 
@@ -302,7 +332,7 @@ l33ch-stamp: super-l33ch
        touch $@
 
 really-clean: clean
-       -find -name Makefile.in -print0 | xargs -0r rm -f
+       -find . -name Makefile.in -print0 | xargs --null --no-run-if-empty -- rm -f
        find -name ChangeLog | xargs rm -f
        rm -f l33ch-stamp
 
@@ -311,7 +341,7 @@ binary: binary-indep binary-arch
 
 
 # Done by the uploader.
-#cvs update.. 
+#cvs update
 #edit debian/changelog
 # configure.in has the version automatically updated now.
 # edit configure.in
@@ -322,18 +352,18 @@ CVS_ROOT=$(shell cat CVS/Root)
 CVS_MODULE=$(shell cat CVS/Repository)
 cvs-build:
        rm -rf debian/cvs-build
-       mkdir -p debian/cvs-build
+       mkdir --parents debian/cvs-build
        (cd debian/cvs-build;cvs -d $(CVS_ROOT) export -r$(APT_CVSTAG) -d apt-$(APT_DEBVER) $(CVS_MODULE))
        $(MAKE) -C debian/cvs-build/$(CVS_BUILDDIR) startup doc
        (cd debian/cvs-build/$(CVS_BUILDDIR);$(DEB_BUILD_PROG))
 
 cvs-mkul:
-       -mkdir -p ../upload-$(APT_DEBVER)
-       cp `find debian/cvs-build -maxdepth 1 -type f` ../upload-$(APT_DEBVER)
+       -mkdir --parents ../upload-$(APT_DEBVER)
+       cp $(find debian/cvs-build -maxdepth 1 -type f) ../upload-$(APT_DEBVER)
 
 arch-build:
        rm -rf debian/arch-build
-       mkdir -p debian/arch-build/apt-$(APT_DEBVER)
-       baz inventory -s | xargs cp -a --parents --target=debian/arch-build/apt-$(APT_DEBVER)
+       mkdir --parents debian/arch-build/apt-$(APT_DEBVER)
+       tar -c --exclude=arch-build --no-recursion -f - $(bzr inventory) | (cd debian/arch-build/$(PKG)-$(APT_DEBVER);tar xf -)
        $(MAKE) -C debian/arch-build/apt-$(APT_DEBVER) startup doc
-       (cd debian/arch-build/apt-$(APT_DEBVER); $(DEB_BUILD_PROG))
+       (cd debian/arch-build/apt-$(APT_DEBVER); $(DEB_BUILD_PROG); dpkg-genchanges -S > ../apt_$(APT_DEBVER)_source.changes)