]> git.saurik.com Git - apt.git/blobdiff - debian/changelog
Only run Download-Upgradable and Unattended-Upgrades if the initial
[apt.git] / debian / changelog
index caef53bafc80f07b156896e47c4d5ffee175e291..668cf5596b18e4434fc2f37e80a1dc5b3465462d 100644 (file)
@@ -4,11 +4,34 @@ apt (0.7.21) UNRELEASED; urgency=low
   * Updated cron script to support backups by hardlinks and 
     verbose levels.  All features turned off by default. 
   * Added more error handlings.  Closes: #438803, #462734, #454989, 
-  * Refactored condition structure to make download and upgrade performed 
-    if only previous steps succeeded. Closes: #341970
   * Documented all cron script related configuration items in 
     configure-index.
 
+  [ Michael Vogt ]
+  * apt-pkg/acquire.cc:
+    - make the max pipeline depth of the acquire queue configurable
+      via Acquire::Max-Pipeline-Depth
+  * apt-pkg/deb/dpkgpm.cc:
+    - add Dpkg::UseIoNice boolean option to run dpkg with ionice -c3
+      (off by default)
+    - send "dpkg-exec" message on the status fd when dpkg is run
+  * apt-pkg/algorithms.cc:
+    - consider recommends when making the scores for the problem 
+      resolver
+  * apt-pkg/acquire-worker.cc:
+    - show error details of failed methods
+  * apt-pkg/contrib/fileutl.cc:
+    - if a process aborts with signal, show signal number
+  * methods/http.cc:
+    - ignore SIGPIPE, we deal with EPIPE from write in 
+      HttpMethod::ServerDie() (LP: #385144)
+  * apt-pkg/deb/dpkgpm.cc:
+    - provide DPkg::Chroot-Directory config option (useful for testing)
+  * Only run Download-Upgradable and Unattended-Upgrades if the initial
+    update was successful Closes: #341970
+  
+ -- Michael Vogt <michael.vogt@ubuntu.com>  Thu, 28 May 2009 17:51:42 +0200
+
   [ Michael Vogt ]
   * apt-pkg/indexcopy.cc:
     - support having CDs with no Packages file (just a Packages.gz)
@@ -31,18 +54,41 @@ apt (0.7.21) UNRELEASED; urgency=low
   * cmdline/apt-get.cc:
     - fix "apt-get source pkg=ver" if binary name != source name
       and show a message (LP: #202219)
+    - fix "apt-get source pkg" if there is a binary package and
+      a source package of the same name but from different 
+      packages (LP: #330103)
   * apt-pkg/deb/debsystem.cc:
     - make strings i18n able 
   * apt-pkg/contrib/strutl.cc:
     - fix TimeToStr i18n (LP: #289807)
   * [ABI break] merge support for http redirects, thanks to
     Jeff Licquia and Anthony Towns
+  * [ABI break] use int for the package IDs (thanks to Steve Cotton)
+  * apt-pkg/pkgcache.cc:
+    - do not run "dpkg --configure pkg" if pkg is in trigger-awaited
+      state (LP: #322955)
+  * methods/https.cc:
+    - add Acquire::https::AllowRedirect support
+  * methods/gpgv.cc:
+    - properly check for expired and revoked keys (closes: #433091)
+  * fix problematic use of tolower() when calculating the version 
+    hash by using locale independant tolower_ascii() function. 
+    Thanks to M. Vefa Bicakci (LP: #80248)
+  * build fixes for g++-4.4
+  * cmdline/apt-mark:
+    - add "showauto" option to show automatically installed packages
 
   [ Dereck Wonnacott ]
   * apt-ftparchive might write corrupt Release files (LP: #46439)
   * Apply --important option to apt-cache depends (LP: #16947) 
   * Clarify the --help for 'purge' (LP: #243948)
 
+
+  [ Colin Watson ]
+  * cmdline/acqprogress.cc:
+    - Call pkgAcquireStatus::Pulse even if quiet, so that we still get
+      dlstatus messages on the status-fd (LP: #290234).
+
  -- Michael Vogt <michael.vogt@ubuntu.com>  Fri, 12 Sep 2008 11:34:24 +0200
 
 apt (0.7.20) unstable; urgency=low