]> git.saurik.com Git - apt.git/blobdiff - debian/rules
* debian/rules:
[apt.git] / debian / rules
index d1b77e17257c2913146e7f7fa7398ea1a5a0f2d3..7677708b25b9988aad7d545c9282a01bc02dea41 100755 (executable)
@@ -75,12 +75,11 @@ APT_UTILS=ftparchive sortpkgs extracttemplates
 #export DH_VERBOSE=1
 
 # Find the libapt-pkg major version for use in other control files
-export LIBAPTPKG_MAJOR:=$(shell egrep '^MAJOR=' apt-pkg/makefile |cut -d '=' -f 2)
-export LIBAPTINST_MAJOR:=$(shell egrep '^MAJOR=' apt-inst/makefile |cut -d '=' -f 2)
+include buildlib/libversion.mak
 
 # Determine which package we should provide in the control files
-LIBAPTPKG_PROVIDE=libapt-pkg-$(LIBAPTPKG_MAJOR)
-LIBAPTINST_PROVIDE=libapt-inst-$(LIBAPTINST_MAJOR)
+LIBAPTPKG_PROVIDE=libapt-pkg$(LIBAPTPKG_MAJOR)
+LIBAPTINST_PROVIDE=libapt-inst$(LIBAPTINST_MAJOR)
 
 debian/shlibs.local: apt-pkg/makefile
        # We have 3 shlibs.local files.. One for 'apt', one for 'apt-utils' and
@@ -145,7 +144,8 @@ libapt-pkg-doc: build-doc debian/shlibs.local
 #      
        dh_installdocs -p$@ $(BLD)/docs/cache* $(BLD)/docs/design* $(BLD)/docs/dpkg-tech* \
                             $(BLD)/docs/files* $(BLD)/docs/method* \
-                           doc/libapt-pkg2_to_3.txt doc/style.txt
+                           doc/libapt-pkg2_to_3.txt doc/style.txt \
+                           $(BLD)/doc/doxygen/html/*
        dh_installexamples -p$@
 #      dh_installmenu -p$@
 #      dh_installinit -p$@
@@ -191,7 +191,7 @@ apt: build build-doc debian/shlibs.local
        dh_testdir -p$@
        dh_testroot -p$@
        dh_clean -p$@ -k
-       dh_installdirs -p$@ /usr/share/bug/$@ /usr/share/$@
+       dh_installdirs -p$@
 #
 # apt install
 #
@@ -214,7 +214,6 @@ apt: build build-doc debian/shlibs.local
        cp debian/bugscript debian/$@/usr/share/bug/apt/script
        cp debian/apt.logrotate debian/$@/etc/logrotate.d/apt
 
-       cp share/debian-archive.gpg debian/$@/usr/share/$@
        cp debian/apt.conf.autoremove debian/$@/etc/apt/apt.conf.d/01autoremove
 #      head -n 500 ChangeLog > debian/ChangeLog