]> git.saurik.com Git - apt.git/blobdiff - debian/rules
refactor the buildsystem to extract library versions from one file,
[apt.git] / debian / rules
index d1b77e17257c2913146e7f7fa7398ea1a5a0f2d3..f69c0cffb7999b9dfcc5cb4dd5a20f3f51a5aa03 100755 (executable)
@@ -75,8 +75,7 @@ APT_UTILS=ftparchive sortpkgs extracttemplates
 #export DH_VERBOSE=1
 
 # Find the libapt-pkg major version for use in other control files
-export LIBAPTPKG_MAJOR:=$(shell egrep '^MAJOR=' apt-pkg/makefile |cut -d '=' -f 2)
-export LIBAPTINST_MAJOR:=$(shell egrep '^MAJOR=' apt-inst/makefile |cut -d '=' -f 2)
+include buildlib/libversion.mak
 
 # Determine which package we should provide in the control files
 LIBAPTPKG_PROVIDE=libapt-pkg-$(LIBAPTPKG_MAJOR)