-apt (0.7.25) UNRELEASED; urgency=low
+apt (0.7.25.2) UNRELEASED; urgency=low
+
+ [ Michael Vogt ]
+ * apt-pkg/contrib/cdromutl.cc:
+ - fix UnmountCdrom() fails, give it a bit more time and try
+ the umount again
+ * apt-pkg/cdrom.cc:
+ - fix crash in pkgUdevCdromDevices
+ * methods/cdrom.cc:
+ - fixes in multi cdrom setup code
+ - add new "Acquire::cdrom::AutoDetect" config that enables/disables
+ the dlopen of libudev for automatic cdrom detection. Off by default
+ currently, feedback/testing welcome
+ * cmdline/apt-cdrom.cc:
+ - add new --auto-detect option that uses libudev to figure out
+ the cdrom/mount-point
+ * cmdline/apt-mark:
+ - merge fix from Gene Cash that supports markauto for
+ packages that are not in the extended_states file yet
+ (closes: #534920)
+ * ftparchive/writer.{cc,h}:
+ - merge crash fix for apt-ftparchive on hurd, thanks to
+ Samuel Thibault for the patch (closes: #566664)
+
+ [ David Kalnischkies ]
+ * apt-pkg/contrib/fileutl.cc:
+ - Fix the newly introduced method GetListOfFilesInDir to not
+ accept every file if no extension is enforced
+ (= restore old behaviour). (Closes: #565213)
+ * apt-pkg/policy.cc:
+ - accept also partfiles with "pref" file extension as valid
+ * apt-pkg/contrib/configuration.cc:
+ - accept also partfiles with "conf" file extension as valid
+ * doc/apt.conf.5.xml:
+ - reorder description and split out syntax
+ - add partfile name convention (Closes: #558348)
+ * doc/apt_preferences.conf.5.xml:
+ - describe partfile name convention also here
+ * apt-pkg/deb/dpkgpm.cc:
+ - don't segfault if term.log file can't be opened.
+ Thanks Sam Brightman for the patch! (Closes: #475770)
+ * doc/*:
+ - replace the per language addendum with a global addendum
+ - add a explanation why translations include (maybe) english
+ parts to the new global addendum (Closes: #561636)
+ * apt-pkg/contrib/strutl.cc:
+ - fix malloc asseration fail with ja_JP.eucJP locale in
+ apt-cache search. Thanks Kusanagi Kouichi! (Closes: #548884)
+
+ [ Christian Perrier ]
+ * Italian translation update. Closes: #567532
+ * French translation update.
+
+ -- David Kalnischkies <kalnischkies@gmail.com> Sat, 16 Jan 2010 21:06:38 +0100
+
+apt (0.7.25.1) unstable; urgency=low
+
+ [ Christian Perrier ]
+ * French manpage translation update
+ * French translation update
+ * Russian translation update by Yuri Kozlov
+ Closes: #564171
+
+ [Chris Leick]
+ * spot & fix various typos in all manpages
+ * German manpage translation update
+
+ [ David Kalnischkies ]
+ * cmdline/apt-cache.cc:
+ - remove translatable marker from the "%4i %s\n" string
+ * buildlib/po4a_manpage.mak:
+ - instruct debiandoc to build files with utf-8 encoding
+ * buildlib/tools.m4:
+ - fix some warning from the buildtools
+ * apt-pkg/acquire-item.cc:
+ - add configuration PDiffs::Limit-options to not download
+ too many or too big patches (Closes: #554349)
+ * debian/control:
+ - let all packages depend on ${misc:Depends}
+ * share/*-archive.gpg:
+ - remove the horrible outdated files. We already depend on
+ the keyring so we don't need to ship our own version
+ * cmdline/apt-key:
+ - errors out if wget is not installed (Closes: #545754)
+ - add --keyring option as we have now possibly many
+ * methods/gpgv.cc:
+ - pass all keyrings (TrustedParts) to gpgv instead of
+ using only one trusted.gpg keyring (Closes: #304846)
+ * methods/https.cc:
+ - finally merge the rest of the patchset from Arnaud Ebalard
+ with the CRL and Issuers options, thanks! (Closes: #485963)
+ * apt-pkg/deb/debindexfile.cc, apt-pkg/pkgcachegen.cc:
+ - add debug option Debug::pkgCacheGen
+
+ [ Michael Vogt ]
+ * cmdline/apt-get.cc:
+ - merge fix for apt-get source pkg=version regression
+ (closes: #561971)
+ * po/ru.po:
+ - merged updated ru.po, thanks to Yuri Kozlov (closes: #564171)
+
+ -- Michael Vogt <mvo@debian.org> Sat, 09 Jan 2010 21:52:36 +0100
+
+apt (0.7.25) unstable; urgency=low
[ Christian Perrier ]
* Fix apt-ftparchive(1) wrt description of the "-o" option.
Closes: #479997
* Polish translation update by Wiktor Wandachowicz
Closes: #548571
+ * German translation update by Holger Wansing
+ Closes: #551534
+ * Italian translation update by Milo Casagrande
+ Closes: #555797
+ * Simplified Chinese translation update by Aron Xu
+ Closes: #558737
+ * Slovak translation update by Ivan Masár
+ Closes: #559277
+
+ [ Michael Vogt ]
+ * apt-pkg/packagemanager.cc:
+ - add output about pre-depends configuring when debug::pkgPackageManager
+ is used
+ * methods/https.cc:
+ - fix incorrect use of CURLOPT_TIMEOUT, closes: #497983, LP: #354972
+ thanks to Brian Thomason for the patch
+ * merge lp:~mvo/apt/netrc branch, this adds support for a
+ /etc/apt/auth.conf that can be used to store username/passwords
+ in a "netrc" style file (with the extension that it supports "/"
+ in a machine definition). Based on the maemo git branch (Closes: #518473)
+ (thanks also to Jussi Hakala and Julian Andres Klode)
+ * apt-pkg/deb/dpkgpm.cc:
+ - add "purge" to list of known actions
+ * apt-pkg/init.h:
+ - add compatibility with old ABI name until the next ABI break
+ * merge segfault fix from Mario Sanchez Prada, many thanks
+ (closes: #561109)
+
+ [ Brian Murray ]
+ * apt-pkg/depcache.cc, apt-pkg/indexcopy.cc:
+ - typo fix (LP: #462328)
+
+ [ Loïc Minier ]
+ * cmdline/apt-key:
+ - Emit a warning if removed keys keyring is missing and skip associated
+ checks (LP: #218971)
[ David Kalnischkies ]
* apt-pkg/packagemanager.cc:
* doc/po4a.conf: activate translation of guide.sgml and offline.sgml
* doc/apt.conf.5.xml:
- provide a few more details about APT::Immediate-Configure
+ - briefly document the behaviour of the new https options
* doc/sources.list.5.xml:
- add note about additional apt-transport-methods
* doc/apt-mark.8.xml:
- correct showauto synopsis, thanks Andrew Schulman (Closes: #551440)
* cmdline/apt-get.cc:
- - source should displays his final pkg pick (Closes: #249383, #550952)
+ - source should display his final pkg pick (Closes: #249383, #550952)
- source doesn't need the complete version for match (Closes: #245250)
- source ignores versions/releases if not available (Closes: #377424)
- only warn if (free) space overflows (Closes: #522238)
+ - add --debian-only as alias for --diff-only
* methods/connect.cc:
- display also strerror of "wicked" getaddrinfo errors
+ - add AI_ADDRCONFIG to ai_flags as suggested by Aurelien Jarno
+ in response to Bernhard R. Link, thanks! (Closes: #505020)
+ * buildlib/configure.mak, buildlib/config.{sub,guess}:
+ - remove (outdated) config.{sub,guess} and use the ones provided
+ by the new added build-dependency autotools-dev instead
+ * configure.in, buildlib/{xml,yodl,sgml}_manpage.mak:
+ - remove the now obsolete manpage buildsystems
+ * doc/{pl,pt_BR,es,it}/*.{sgml,xml}:
+ - convert all remaining translation to the po4a system
+ * debian/control:
+ - drop build-dependency on docbook-utils and xmlto
+ - add build-dependency on autotools-dev
+ - bump policy to 3.8.3 as we have no outdated manpages anymore
+ * debian/NEWS:
+ - fix a typo in 0.7.24: Allready -> Already (Closes: #557674)
+ * ftparchive/writer.{cc,h}:
+ - add APT::FTPArchive::LongDescription to be able to disable them
+ * apt-pkg/deb/debsrcrecords.cc:
+ - use "diff" filetype for .debian.tar.* files (Closes: #554898)
+ * methods/rred.cc:
+ - rewrite to be able to handle even big patch files
+ - adopt optional mmap+iovec patch from Morten Hustveit
+ (Closes: #463354) which should speed up a bit. Thanks!
+ * methods/http{,s}.cc
+ - add config setting for User-Agent to the Acquire group,
+ thanks Timothy J. Miller! (Closes: #355782)
+ - add https options which default to http ones (Closes: #557085)
+ * debian/apt.cron.daily:
+ - check cache size even if we do nothing else otherwise, thanks
+ Francesco Poli for patch(s) and patience! (Closes: #459344)
+ * ftparchive/*:
+ - fix a few typos in strings, comments and manpage,
+ thanks Karl Goetz! (Closes: #558757)
+
+ [ Carl Chenet ]
+ * cmdline/apt-mark:
+ - print an error if a new state file can't be created
+ (Closes: #521289) and
+ - exit nicely if python-apt is not installed (Closes: #521284)
+
+ [ Chris Leick ]
+ * doc/de: German translation of manpages (Closes: #552606)
+ * doc/ various manpages:
+ - correct various errors, typos and oddities (Closes: #552535)
+ * doc/apt-secure.8.xml:
+ - replace literal with emphasis tags in Archive configuration
+ * doc/apt-ftparchive.1.xml:
+ - remove informalexample tag which hides the programlisting
+ * doc/apt-get.8.xml:
+ - change equivalent "for" to "to the" (purge command)
+ - clarify --fix-broken sentence about specifying packages
[ Eugene V. Lyubimkin ]
* apt-pkg/contib/strutl.h
- Restrict option names to alphanumerical characters and "/-:._+".
- Deprecate #include, we have apt.conf.d nowadays which should be
sufficient.
- * methods/https.cc:
- - Add support for authentication using netrc (Closes: #518473), patch
- by Jussi Hakala <jussi.hakala@hut.fi>.
+ * ftparchive/apt-ftparchive.cc:
+ - Call setlocale() so translations are actually used.
+ * debian/apt.conf.autoremove:
+ - Add kfreebsd-image-* to the list (Closes: #558803)
- -- Michael Vogt <michael.vogt@ubuntu.com> Tue, 29 Sep 2009 15:51:34 +0200
+ -- Michael Vogt <mvo@debian.org> Tue, 15 Dec 2009 09:21:55 +0100
apt (0.7.24) unstable; urgency=low