* apt-pkg/depcache.cc:
- really include 'rc' packages in the delete count by fixing a
typo which exists since 1999 in the sourceā¦ (LP: #761175)
+ - if critical or-group can't be satisfied, exit directly.
* apt-pkg/acquire-method.cc:
- write directly to stdout instead of creating the message in
memory first before writing to avoid hitting limits
+ - fix order of CurrentURI and UsedMirror in Status() and Log()
* apt-pkg/orderlist.cc:
- let VisitRProvides report if the calls were successful
* apt-pkg/deb/dpkgpm.cc:
* cmdline/apt-mark.cc:
- reimplement apt-mark in c++
- provide a 'showmanual' command (Closes: #582791)
+ - provide a 'dpkg --set-selections' wrapper to set/release holds
* cmdline/apt-get.cc:
- deprecate mostly undocumented 'markauto' in favor of 'apt-mark'
* cmdline/apt-cache.cc:
- deprecate mostly undocumented 'showauto' in favor of 'apt-mark'
+ * apt-pkg/pkgcache.cc:
+ - really ignore :arch in FindPkg() in non-multiarch environment
+ * doc/po/de.po:
+ - undo the translation of the command 'dump' in manpage of apt-config
+ as report by Burghard Grossmann on debian-l10n-german, thanks!
+ * apt-pkg/deb/debmetaindex.cc:
+ - do not download TranslationIndex if no Translation-* will be
+ downloaded later on anyway (Closes: #624218)
+ * test/versions.lst:
+ - disable obscure version number tests with versions dpkg doesn't
+ allow any more as they don't start with a number
+ * apt-pkg/acquire-worker.cc:
+ - print filename in the unmatching size warning (Closes: #623137)
+ * apt-pkg/acquire-item.cc:
+ - apply fix for poorly worded 'locate file' error message from
+ Ben Finney, thanks! (Closes: #623171)
+ * methods/http.cc:
+ - add config option to ignore a closed stdin to be able to easily
+ use the method as a simple standalone downloader
+ - Location header in redirects should be absolute URI, but some
+ servers just send an absolute path so still deal with it properly
+ - dequote URL taken from Location in redirects as we will otherwise
+ quote an already quoted string in the request later (Closes: #602412)
+ * apt-pkg/contrib/netrc.cc:
+ - replace non-posix gnu-extension strdupa with strdup
+ * apt-pkg/packagemanager.cc:
+ - ensure for Multi-Arch:same packages that they are unpacked in
+ lock step even in immediate configuration (Closes: #618288)
- -- David Kalnischkies <kalnischkies@gmail.com> Thu, 21 Apr 2011 17:00:41 +0200
+ -- David Kalnischkies <kalnischkies@gmail.com> Mon, 16 May 2011 11:41:05 +0200
apt (0.8.14.1) unstable; urgency=low