]> git.saurik.com Git - apt.git/blobdiff - debian/changelog
add a few tests to check that arch-specific qualifiers work
[apt.git] / debian / changelog
index e4cdc3a28173374f810944ccefd72eadad8c6327..a89f78de91ca541de0afa843218af50a53cb2f0f 100644 (file)
@@ -1,9 +1,17 @@
 apt (0.9.5.2) UNRELEASED; urgency=low
 
   [ David Kalnischkies ]
+  * apt-pkg/cdrom.cc:
+    - fix regression from 0.9.3 which dumped the main configuration
+      _config instead of the cdrom settings (Cnf) as identified and
+      tested by Milan Kupcevic, thanks! (Closes: #674100)
   * cmdline/apt-get.cc:
     - do not show 'list of broken packages' header if no package
       is broken as it happens e.g. for external resolver errors
+    - print URIs for all changelogs in case of --print-uris,
+      thanks to Daniel Hartwig for the patch! (Closes: #674897)
+    - show 'bzr branch' as 'bzr get' is deprecated (LP: #1011032)
+    - check build-dep candidate if install is forbidden
   * debian/apt-utils.links:
     - the internal resolver 'apt' is now directly installed in
       /usr/lib/apt/solvers, so don't instruct dh to create a broken link
@@ -15,6 +23,22 @@ apt (0.9.5.2) UNRELEASED; urgency=low
       as we do in the manpage and as the debian-installer does
   * doc/apt-get.8.xml:
     - use apt-utils as package example instead of libc6
+  * apt-pkg/contrib/cmdline.cc:
+    - apply patch from Daniel Hartwig to fix a segfault in case
+      the LongOpt is empty (Closes: #676331)
+    - fix segfault with empty LongOpt in --no-* branch
+  * ftparchive/apt-ftparchive.cc:
+    - default to putting the Contents-* files below $(SECTION) as apt-file
+      expects them there - thanks Martin-Éric Racine! (Closes: #675827)
+  * apt-pkg/deb/deblistparser.cc:
+    - set pkgCacheGen::Essential to "all" again (Closes: #675449)
+  * apt-pkg/algorithms.cc:
+    - force install only for one essential package out of a group
+  * apt-pkg/aptconfiguration.cc:
+    - if APT::Languages=none save "none" in allCodes so that the detected
+      configuration is cached as intended (Closes: #674690, LP: #1004947)
+  * apt-pkg/cacheiterators.h:
+    - add an IsMultiArchImplicit() method for Dep- and PrvIterator
 
   [ Justin B Rye ]
   * doc/apt-cdrom.8.xml:
@@ -30,6 +54,9 @@ apt (0.9.5.2) UNRELEASED; urgency=low
     doc/apt_preferences.5.xml, doc/apt-secure.8.xml,
     doc/apt-sortpkgs.1.xml, sources.list.5.xml:
     - review and fix typo, grammar and style issues
+  * doc/apt.conf.5.xml:
+    - review and fix typo, grammar and style issues
+    - rephrase APT::Immediate-Configuration and many others
 
   [ Robert Luberda ]
   * Polish manpage translation update (Closes: #675603)
@@ -40,6 +67,12 @@ apt (0.9.5.2) UNRELEASED; urgency=low
   * French program and manpage translation update
   * Danish program translation by Joe Hansen. Closes: #675605
 
+  [ Thibaut Girka ]
+  * cmdline/apt-get.cc:
+    - complain correctly about :any build-dep on M-A:none packages
+  * apt-pkg/deb/deblistparser.cc:
+    - add support for arch-specific qualifiers in dependencies
+
  -- David Kalnischkies <kalnischkies@gmail.com>  Wed, 06 Jun 2012 23:54:01 +0200
 
 apt (0.9.5.1) unstable; urgency=low