]> git.saurik.com Git - apt.git/blobdiff - debian/rules
Merge remote-tracking branch 'mvo/feature/apt-show-nice' into debian/experimental...
[apt.git] / debian / rules
index fc44d5a688a5d68d9bcbc73c90e1b7962e45147e..3aa86480e36bd090948774eb82fffc5e40c68665 100755 (executable)
@@ -3,6 +3,9 @@
 # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
 # Some lines taken from debmake, by Christoph Lameter.
 
+# build in verbose mode by default to make it easy to diangose issues
+export NOISY=1
+
 export DEB_HOST_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
 export DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
 export DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
@@ -115,7 +118,7 @@ clean:
        [ ! -f Makefile ] || $(MAKE) clean distclean
        rm -rf build
        rm -f debian/$(LIBAPT_PKG).install debian/$(LIBAPT_INST).install \
-             debian/libapt-pkg-dev.install
+             debian/libapt-pkg-dev.install debian/apt.install
        test ! -L buildlib/config.guess || rm -f buildlib/config.guess
        test ! -L buildlib/config.sub || rm -f buildlib/config.sub
 
@@ -174,7 +177,7 @@ apt-doc: build-debiandoc
 # Build architecture-dependent files here.
 
 apt_MANPAGES = apt apt-cache apt-cdrom apt-config apt-get apt-key apt-mark apt-secure apt apt.conf apt_preferences sources.list
-apt: build-binary build-manpages
+apt: build-binary build-manpages debian/apt.install
        dh_testdir -p$@
        dh_testroot -p$@
        dh_prep -p$@
@@ -214,9 +217,10 @@ apt: build-binary build-manpages
        dh_strip -p$@
        dh_compress -p$@
        dh_fixperms -p$@
+       dh_makeshlibs -p$@
        dh_installdeb -p$@
        dh_shlibdeps -p$@
-       dh_gencontrol -p$@
+       dh_gencontrol -p$@ -- -Vapt:keyring="$(shell ./vendor/getinfo keyring-package)"
        dh_md5sums -p$@
        dh_builddeb -p$@