]> git.saurik.com Git - apt.git/blobdiff - debian/rules
* apt-pkg/acquire-item.cc:
[apt.git] / debian / rules
index 2dbb9707f0ecace63ae1450b52dbef7a61f21da4..a8bf88762e4fed8821d9f3f8bf480caf4cd94759 100755 (executable)
@@ -36,7 +36,8 @@ endif
 # Default rule
 build:
 
 # Default rule
 build:
 
-DEB_BUILD_PROG:=debuild --preserve-envvar PATH --preserve-envvar CCACHE_DIR -us -uc
+PKG=apt
+DEB_BUILD_PROG:=debuild --preserve-envvar PATH --preserve-envvar CCACHE_DIR -us -uc $(DEB_BUILD_PROG_OPTS)
 APT_DEBVER=$(shell dpkg-parsechangelog |sed -n -e '/^Version:/s/^Version: //p')
 APT_CONFVER=$(shell sed -n -e 's/^AC_DEFINE_UNQUOTED(VERSION,"\(.*\)")/\1/p' configure.in)
 APT_CVSTAG=$(shell echo "$(APT_DEBVER)" | sed -e 's/^/v/' -e 's/\./_/g')
 APT_DEBVER=$(shell dpkg-parsechangelog |sed -n -e '/^Version:/s/^Version: //p')
 APT_CONFVER=$(shell sed -n -e 's/^AC_DEFINE_UNQUOTED(VERSION,"\(.*\)")/\1/p' configure.in)
 APT_CVSTAG=$(shell echo "$(APT_DEBVER)" | sed -e 's/^/v/' -e 's/\./_/g')
@@ -58,9 +59,11 @@ endif
 
 # Rebuild configure.in to have the correct version from the change log
 ifneq ($(APT_DEBVER),$(APT_CONFVER))
 
 # Rebuild configure.in to have the correct version from the change log
 ifneq ($(APT_DEBVER),$(APT_CONFVER))
+ifneq ($(APT_DEBVER),)
 .PHONY: configure.in
 configure.in:
        sed -e 's/$(APT_CONFVER)/$(APT_DEBVER)/' $@ > $@.$$$$ && mv $@.$$$$ $@
 .PHONY: configure.in
 configure.in:
        sed -e 's/$(APT_CONFVER)/$(APT_DEBVER)/' $@ > $@.$$$$ && mv $@.$$$$ $@
+endif
 else
 configure.in:
 endif
 else
 configure.in:
 endif
@@ -106,7 +109,7 @@ build/configure-stamp: configure
        dh_testdir
        -mkdir build
        cp COPYING debian/copyright
        dh_testdir
        -mkdir build
        cp COPYING debian/copyright
-       cd build && ../configure $(confflags)
+       cd build && CXXFLAGS="$(confcxxflags)" ../configure $(confflags)
        touch $@
 
 build/build-stamp: build/configure-stamp
        touch $@
 
 build/build-stamp: build/configure-stamp
@@ -169,7 +172,7 @@ apt-doc: build-doc
 #
        # Copy the guides
        dh_installdocs -p$@ $(BLD)/docs/guide*.text $(BLD)/docs/guide*.html \
 #
        # Copy the guides
        dh_installdocs -p$@ $(BLD)/docs/guide*.text $(BLD)/docs/guide*.html \
-                      $(BLD)/docs/offline.text $(BLD)/docs/offline.html
+                      $(BLD)/docs/offline*.text $(BLD)/docs/offline*.html
        dh_installchangelogs -p$@
        dh_compress -p$@
        dh_fixperms -p$@
        dh_installchangelogs -p$@
        dh_compress -p$@
        dh_fixperms -p$@
@@ -187,25 +190,27 @@ apt: build debian/shlibs.local
        dh_testdir -p$@
        dh_testroot -p$@
        dh_clean -p$@ -k
        dh_testdir -p$@
        dh_testroot -p$@
        dh_clean -p$@ -k
-       dh_installdirs -p$@ /usr/share/bug/$@
+       dh_installdirs -p$@ /usr/share/bug/$@ /usr/share/$@
 #
 # apt install
 #
 #
 # apt install
 #
-       cp $(BLD)/bin/apt-* debian/apt/usr/bin/
+       cp $(BLD)/bin/apt-* debian/$@/usr/bin/
 
        # Remove the bits that are in apt-utils
 
        # Remove the bits that are in apt-utils
-       rm $(addprefix debian/apt/usr/bin/apt-,$(APT_UTILS))
+       rm $(addprefix debian/$@/usr/bin/apt-,$(APT_UTILS))
 
        # install the shared libs
 
        # install the shared libs
-       find $(BLD)/bin/ -type f -name "libapt-pkg*.so.*" -exec cp -a "{}" debian/apt/usr/lib/ \;
-       find $(BLD)/bin/ -type l -name "libapt-pkg*.so.*" -exec cp -a "{}" debian/apt/usr/lib/ \;
+       find $(BLD)/bin/ -type f -name "libapt-pkg*.so.*" -exec cp -a "{}" debian/$@/usr/lib/ \;
+       find $(BLD)/bin/ -type l -name "libapt-pkg*.so.*" -exec cp -a "{}" debian/$@/usr/lib/ \;
+
+       cp $(BLD)/bin/methods/* debian/$@/usr/lib/apt/methods/
 
 
-       cp $(BLD)/bin/methods/* debian/apt/usr/lib/apt/methods/
+       cp $(BLD)/scripts/dselect/* debian/$@/usr/lib/dpkg/methods/apt/
+       cp -r $(BLD)/locale debian/$@/usr/share/
 
 
-       cp $(BLD)/scripts/dselect/* debian/apt/usr/lib/dpkg/methods/apt/
-       cp -r $(BLD)/locale debian/apt/usr/share/
+       cp debian/bugscript debian/$@/usr/share/bug/apt/script
 
 
-       cp debian/bugscript debian/apt/usr/share/bug/apt/script
+       cp share/debian-archive.gpg debian/$@/usr/share/$@
 
 #      head -n 500 ChangeLog > debian/ChangeLog
 
 
 #      head -n 500 ChangeLog > debian/ChangeLog
 
@@ -219,7 +224,7 @@ apt: build debian/shlibs.local
        dh_fixperms -p$@
        dh_makeshlibs -p$@ -m$(LIBAPTPKG_MAJOR) -V '$(LIBAPTPKG_PROVIDE)'
        dh_installdeb -p$@
        dh_fixperms -p$@
        dh_makeshlibs -p$@ -m$(LIBAPTPKG_MAJOR) -V '$(LIBAPTPKG_PROVIDE)'
        dh_installdeb -p$@
-       dh_shlibdeps -p$@ -l`pwd`/debian/apt/usr/lib -- -Ldebian/shlibs.local.apt
+       dh_shlibdeps -p$@ -l`pwd`/debian/apt/usr/lib:`pwd`/debian/$@/usr/lib -- -Ldebian/shlibs.local.apt
        dh_gencontrol -p$@ -u -Vlibapt-pkg:provides=$(LIBAPTPKG_PROVIDE)
        dh_md5sums -p$@
        dh_builddeb -p$@
        dh_gencontrol -p$@ -u -Vlibapt-pkg:provides=$(LIBAPTPKG_PROVIDE)
        dh_md5sums -p$@
        dh_builddeb -p$@
@@ -265,6 +270,7 @@ apt-utils: build debian/shlibs.local
 
        cp $(addprefix $(BLD)/bin/apt-,$(APT_UTILS)) debian/$@/usr/bin/
        dh_installdocs -p$@
 
        cp $(addprefix $(BLD)/bin/apt-,$(APT_UTILS)) debian/$@/usr/bin/
        dh_installdocs -p$@
+       dh_installexamples -p$@
 
        # Install the man pages..
        dh_installman -p$@
 
        # Install the man pages..
        dh_installman -p$@
@@ -326,3 +332,10 @@ cvs-build:
 cvs-mkul:
        -mkdir -p ../upload-$(APT_DEBVER)
        cp `find debian/cvs-build -maxdepth 1 -type f` ../upload-$(APT_DEBVER)
 cvs-mkul:
        -mkdir -p ../upload-$(APT_DEBVER)
        cp `find debian/cvs-build -maxdepth 1 -type f` ../upload-$(APT_DEBVER)
+
+arch-build:
+       rm -rf debian/arch-build
+       mkdir -p debian/arch-build/apt-$(APT_DEBVER)
+       tar -c --exclude=arch-build --no-recursion -f - `bzr inventory` | (cd debian/arch-build/$(PKG)-$(APT_DEBVER);tar xf -)
+       $(MAKE) -C debian/arch-build/apt-$(APT_DEBVER) startup doc
+       (cd debian/arch-build/apt-$(APT_DEBVER); $(DEB_BUILD_PROG))