]> git.saurik.com Git - apt.git/blobdiff - debian/rules
Add changelog entries for my recent changes.
[apt.git] / debian / rules
index 3ebecfba4de55e07c475fb83e2b29f63fbe39414..006d2de8a61d3a68535aad60c4b6336091e4eccf 100755 (executable)
@@ -38,7 +38,7 @@ build:
 
 PKG=apt
 DEB_BUILD_PROG:=debuild --preserve-envvar PATH --preserve-envvar CCACHE_DIR -us -uc $(DEB_BUILD_PROG_OPTS)
 
 PKG=apt
 DEB_BUILD_PROG:=debuild --preserve-envvar PATH --preserve-envvar CCACHE_DIR -us -uc $(DEB_BUILD_PROG_OPTS)
-APT_DEBVER=$(shell dpkg-parsechangelog |sed -n -e '/^Version:/s/^Version: //p' -e 's/\+.*$$//')
+APT_DEBVER=$(shell dpkg-parsechangelog |sed -n -e '/^Version:/s/^Version: //p' | sed -e 's/\+.*$$//')
 APT_CONFVER=$(shell sed -n -e 's/^AC_DEFINE_UNQUOTED(VERSION,"\(.*\)")/\1/p' configure.in)
 APT_CVSTAG=$(shell echo "$(APT_DEBVER)" | sed -e 's/^/v/' -e 's/\./_/g')
 
 APT_CONFVER=$(shell sed -n -e 's/^AC_DEFINE_UNQUOTED(VERSION,"\(.*\)")/\1/p' configure.in)
 APT_CVSTAG=$(shell echo "$(APT_DEBVER)" | sed -e 's/^/v/' -e 's/\./_/g')
 
@@ -185,7 +185,7 @@ apt-doc: build-doc
 
 # Build architecture-dependent files here.
 
 
 # Build architecture-dependent files here.
 
-binary-arch: apt-transport-https apt libapt-pkg-dev apt-utils
+binary-arch: apt libapt-pkg-dev apt-utils apt-transport-https
 apt: build debian/shlibs.local
        dh_testdir -p$@
        dh_testroot -p$@
 apt: build debian/shlibs.local
        dh_testdir -p$@
        dh_testroot -p$@
@@ -204,11 +204,14 @@ apt: build debian/shlibs.local
        find $(BLD)/bin/ -type l -name "libapt-pkg*.so.*" -exec cp -a "{}" debian/$@/usr/lib/ \;
 
        cp $(BLD)/bin/methods/* debian/$@/usr/lib/apt/methods/
        find $(BLD)/bin/ -type l -name "libapt-pkg*.so.*" -exec cp -a "{}" debian/$@/usr/lib/ \;
 
        cp $(BLD)/bin/methods/* debian/$@/usr/lib/apt/methods/
+       # https has its own package
+       rm debian/$@/usr/lib/apt/methods/https
 
        cp $(BLD)/scripts/dselect/* debian/$@/usr/lib/dpkg/methods/apt/
        cp -r $(BLD)/locale debian/$@/usr/share/
 
        cp debian/bugscript debian/$@/usr/share/bug/apt/script
 
        cp $(BLD)/scripts/dselect/* debian/$@/usr/lib/dpkg/methods/apt/
        cp -r $(BLD)/locale debian/$@/usr/share/
 
        cp debian/bugscript debian/$@/usr/share/bug/apt/script
+       cp debian/apt.logrotate debian/$@/etc/logrotate.d/apt
 
        cp share/debian-archive.gpg debian/$@/usr/share/$@
        cp debian/apt.conf.autoremove debian/$@/etc/apt/apt.conf.d/01autoremove
 
        cp share/debian-archive.gpg debian/$@/usr/share/$@
        cp debian/apt.conf.autoremove debian/$@/etc/apt/apt.conf.d/01autoremove
@@ -291,7 +294,7 @@ apt-utils: build debian/shlibs.local
        dh_md5sums -p$@
        dh_builddeb -p$@
 
        dh_md5sums -p$@
        dh_builddeb -p$@
 
-apt-transport-https: build debian/shlibs.local
+apt-transport-https: build debian/shlibs.local libapt-pkg-dev
        dh_testdir -p$@
        dh_testroot -p$@
        dh_clean -p$@ -k
        dh_testdir -p$@
        dh_testroot -p$@
        dh_clean -p$@ -k
@@ -299,7 +302,7 @@ apt-transport-https: build debian/shlibs.local
 
        # install the method
        mkdir -p debian/$@/usr/lib/apt/methods
 
        # install the method
        mkdir -p debian/$@/usr/lib/apt/methods
-       mv $(BLD)/bin/methods/https debian/$@/usr/lib/apt/methods
+       cp $(BLD)/bin/methods/https debian/$@/usr/lib/apt/methods
 
        dh_installdocs -p$@
        dh_installexamples -p$@
 
        dh_installdocs -p$@
        dh_installexamples -p$@