]> git.saurik.com Git - apt.git/blobdiff - debian/rules
merge with debian/sid
[apt.git] / debian / rules
index 1446a039ee514f60c99f28f03dfcf95a1e6d6cfc..30474c06b71fb4cd9ac6adbd7a70a45119e97e52 100755 (executable)
@@ -100,7 +100,12 @@ build/build-stamp: build/configure-stamp
        # compat symlink for the locale split
        mkdir -p build/usr/share 
        cd build/usr/share && ln -f -s ../../locale .
-       # done here
+       # compile and run tests
+ifeq (,$(findstring nocheck, $(DEB_BUILD_OPTIONS)))
+       $(MAKE) test
+else
+       @echo "Tests DISABLED"
+endif
        touch $@
 
 build/build-doc-stamp: build/configure-stamp