+apt (1.2.3) unstable; urgency=high
+
+ [ Julian Andres Klode ]
+ * Set seekpos to 0 after reopening files in Seek() (Closes: #812994, #813000)
+
+ [ David Kalnischkies ]
+ * get dpkg lock in build-dep if cache was invalid again (Closes: 814139)
+
+ -- Julian Andres Klode <jak@debian.org> Wed, 10 Feb 2016 18:02:20 +0100
+
+apt (1.2.2) unstable; urgency=medium
+
+ [ David Kalnischkies ]
+ * always create pkg at the time pkg:arch is created
+ * reimplement build-dep via apts normal resolver
+ (Closes: #137560, #444930, #489911, #583914, #728317, #812173)
+ * parse version correctly from binary Source field (Closes: 812492)
+ * get sources for packages in multiple releases again (Closes: 812497)
+ * only warn about missing/invalid Date field for now (Closes: 809329)
+ * support <libc>-<kernel>-<cpu> in architecture specs.
+ Thanks to Bálint Réczey for initial patch (Closes: #812212)
+ * avoid building dependency tree in 'source' command
+
+ [ Stefan Bühler ]
+ * fix "Mismatched free() / delete / delete []" in simple_buffer
+
+ [ Julian Andres Klode ]
+ * Do not buffer writes larger than the buffer if possible
+ * Drop the g++ build-dep, transition is done
+ * NEWS: Prefix the keep deb option with Binary::apt:: (Closes: #812111)
+ * rred: If there were I/O errors, fail
+ * Correctly report write errors when flushing buffered writer
+ * test: Fix apt-key tests to work with current gpg 2.1
+
+ [ Manuel "Venturi" Porras Peralta ]
+ * Spanish program translation update (Closes: 813467)
+
+ [ Adrian Wielgosik ]
+ * Try avoiding loading long package description
+ * Avoid temporary strings in SubstVar.
+
+ [ Fredrik Fornwall ]
+ * edspsystem.cc: include <stdlib.h> for mkdtemp (Closes: #807367)
+
+ -- Julian Andres Klode <jak@debian.org> Thu, 04 Feb 2016 22:50:43 +0100
+
+apt (1.2.1) unstable; urgency=high
+
+ [ Zhou Mo ]
+ * po: update zh_CN programs translation
+
+ [ Julian Andres Klode ]
+ * Remap StringView instances pointing into the cache (Closes: #812251)
+
+ [ Michael Vogt ]
+ * Log calling SUDO_USER or PKEXEC_UID in history.log.
+ Thanks to Thomas Reusch
+
+ -- Julian Andres Klode <jak@debian.org> Mon, 25 Jan 2016 18:03:50 +0100
+
+apt (1.2) unstable; urgency=medium
+
+ [ Julian Andres Klode ]
+ * Do not break apt-file (<< 3.0~exp1~), 2.X works fine
+ * Version the build-depends on liblz4-dev to >= 0.0~r126
+ * search: Handle packages without description (Closes: #810622)
+ * Only enable pipelining if server is HTTP/1.1 (Closes: #810796)
+
+ [ Mattia Rizzolo ]
+ * Sort the list of sources to be built and linked (Closes: #810509)
+
+ [ Michael Vogt ]
+ * Do not show multiple identical apt-cache showsrc entries (Closes: #734922)
+
+ [ David Kalnischkies ]
+ * evaluate sourceslist-list-format entity in vendors sources.list.
+ Thanks to Niels Thykier for reporting on IRC
+ * update symbols file
+ * fix M-A:foreign provides creation for unknown archs
+ * revert file-hash based action-merging in acquire (Closes: 810046)
+ * return correct position in APT::StringView::(r)find
+
+ [ Zhou Mo ]
+ * po: update simplified chinese programs translation
+
+ -- Julian Andres Klode <jak@debian.org> Fri, 15 Jan 2016 19:52:19 +0100
+
+apt (1.2~exp1) experimental; urgency=medium
+
+ [ Beatrice Torracca ]
+ * Italian manpages translation update (Closes: 809522)
+
+ [ David Kalnischkies ]
+ * add optional support for comments in pkgTagFile
+ * support comments in debian/control parsing (Closes: 806775)
+ * properly parse comments in apt_preferences and deb822-style sources
+ * include all compressed Packages/Sources files in Release file
+ * use one 'store' method to rule all (de)compressors
+ * ensure compression cleanup even without lists-cleanup
+ * allow pdiff bootstrap from all supported compressors
+ * keep compressed indexes in a low-cost format
+ * support '-' and no parameter for stdin in apt-helper cat-file
+ * tests: limit autotest-functionname generation to sane characters
+ * use filesize of compressed pdiffs for the limit if possible
+ * remove uncompressed leftover partial file before pdiff bootstrap
+
+ [ Michael Vogt ]
+ * Add support for APT::Periodic::CleanInterval.
+ Thanks to Martin-Éric Racine
+ * Add bash-completion support for the "apt" command (Closes: #747094)
+ * Add new APT::Keep-Downloaded-Packages option (Closes: #160743)
+
+ [ Julian Andres Klode ]
+ * Change compressor costs to be 100 apart
+ * apt-cache: stats: Average is over used, not all, buckets
+ * Increase APT::Cache-HashTableSize default to 50503
+ * travis: pull liblz4-dev from wily
+ * FileFd: (native) LZ4 support
+ * apt-helper: cat-file: Add -C/--compress option
+ * CopyFile: Use 64 * 1024 instead of 64000 as buffer size
+ * acquire: Allow parallelizing methods without hosts
+ * rred: Run in parallel
+ * Introduce internal APT::StringView class
+ * Switch performance critical code to use APT::StringView
+ * pkgCacheGenerator::StoreString: Get rid of std::string
+ * pkgCacheGenerator: CurMd5.Value() cannot be empty
+ * AvailableDescriptionLanguages: Use one string for all iterations
+ * NEWS: Document recompression of indices
+ * Store the size of strings in the cache
+ * libapt-pkg5.0: Add Breaks appstream (<< 0.9.0-3~)
+
+ [ Helmut Grohne ]
+ * Allow building without libgtest-dev under <nocheck> build profile
+ (Closes: #809726)
+
+ -- Julian Andres Klode <jak@debian.org> Fri, 08 Jan 2016 21:41:10 +0100
+
+apt (1.1.10) unstable; urgency=medium
+
+ [ David Kalnischkies ]
+ * deal with empty values properly in deb822 parser (Closes: 808102)
+
+ [ Beatrice Torracca ]
+ * fix 3 typos/omissions in apt.conf(5) (Closes: 809160)
+
+ [ Julian Andres Klode ]
+ * BufferedWriter: flushing: Check for written < size instead of <=
+ * aptconfiguration: Set default compression level to 6
+ * BufferedFileFdPrivate: Make InternalFlush() save against errors
+ * Switch to DJB hashing and use prime number as table size
+ * Turn tolower_ascii() and isspace_ascii() into inline functions
+ * Fix test case that was broken by switch of hash function
+ * pkgTagSection::Scan: Fix read of uninitialized value
+ * pkgCacheGenerator: Allow passing down an already created cache
+ * Add support for calculating hashes over the entire cache
+ * Do not sync the cache file
+
+ -- Julian Andres Klode <jak@debian.org> Wed, 30 Dec 2015 00:40:53 +0100
+
+apt (1.1.9) unstable; urgency=medium
+
+ Highlights: buffered rred writes and slightly faster cache generation (~10%)
+
+ [ Julian Andres Klode ]
+ * Introduce isspace_ascii() for use by parsers
+ * Convert most callers of isspace() to isspace_ascii()
+ * pkgcachegen: Use std::unordered_map instead of std::map
+ * debListParser: ParseDepends: Only query native arch if needed
+ * debListParser: Do not validate Description-md5 for correctness twice
+ * ParseDepends: Mark branches for build-dep parsing as unlikely
+ * rred: Only call pkgInitConfig() in test mode
+ * FileFdPrivate: Add getter and setter for fields
+ * FildFd: Introduce a Flush() function and call it from Close()
+ * FileFd: Add a buffered writing mode
+ * rred: Use buffered writes
+ * pkgcachegen.h: Hack around unordered_map not existing before C++11
+ * doc/acquire-additional-files.txt: Mention apt-helper cat-file
+
+ [ Niels Thykier ]
+ * Hex2Digit: Do not use isxdigit()
+
+ [ David Kalnischkies ]
+ * allow repositories to forbid arch:all for specific index targets
+
+ -- Julian Andres Klode <jak@debian.org> Sun, 27 Dec 2015 19:16:36 +0100
+
+apt (1.1.8) unstable; urgency=medium
+
+ * apt-helper: Add a cat-file command for concatening files
+ * Change InternalReadLine to always use buffer.read() return value
+
+ -- Julian Andres Klode <jak@debian.org> Sat, 26 Dec 2015 23:23:02 +0100
+
+apt (1.1.7) unstable; urgency=medium
+
+ The real "speed up rred for uncompressed files" release
+
+ * Use a hardcoded buffer size of 4096 to fix performance
+ * rred: Allow passing files as arguments for compressor testing
+ * Get rid of memmove() in our read buffering
+
+ -- Julian Andres Klode <jak@debian.org> Sat, 26 Dec 2015 19:10:14 +0100
+
+apt (1.1.6) unstable; urgency=medium
+
+ Merry Christmas from the APT Team
+
+ [ Pino Toscano ]
+ * Fix FileUtlTest.GetTempDir failure when run as root (Closes: #808383)
+ * CopyFile: fix BufSize to a sane value (Closes: #808381)
+ * CopyFile: avoid failing on EOF on some systems (Closes: #808381)
+
+ [ Julian Andres Klode ]
+ * Do nothing in FileFd::Write() if Size is 0 (Closes: #808381)
+
+ [ David Kalnischkies ]
+ * avoid evaluating shell in paths used in apt-key
+ * avoid triggering gpg2 migration in apt-key
+ * follow dpkg and xz and use CRC64 for xz compression
+ * parse xz-compression level from configuration
+ * implement a buffer system for FileFd::ReadLine (Closes: 808579)
+ * ensure we got a lock in clean operation (Closes: 808561)
+
+ -- Julian Andres Klode <jak@debian.org> Thu, 24 Dec 2015 17:01:49 +0100
+
+apt (1.1.5) unstable; urgency=medium
+
+ [ Julian Andres Klode ]
+ * Do not swap required and important in pkgCache::Priority()
+ Thanks to Manuel A. Fernandez Montecelo for discovering this
+ (Closes: #807523)
+ * Convert package names from Packages files to lower case (Closes: #807012)
+ * test framework: Correctly generate new paths in noopchroot
+ * debian/apt.auto-removal.sh: Adjust -dbg exclusion for multi-arch
+ * pkgcache: Make hash arch-independent using fixed size integer
+ * test-apt-download-progress: Run the https test multiple times
+
+ [ David Kalnischkies ]
+ * update symbols files to 1.1.4 state of affairs
+ * parse .diff/Index hashes in reverse order
+ * redirect which stderr to /dev/null for consistency (Closes: 807373)
+ * show a more descriptive error for weak Release files (Closes: 806459)
+ * support regex and co in 'apt-cache policy $pkg' again (Closes: 807870)
+ * non-existing directories don't need to be cleaned (Closes: 807477)
+
+ [ Seo Sanghyeon ]
+ * fix incorrect Korean translation of "manually" and "automatically"
+
+ [ Andreas Metzler ]
+ * mention APT::AutoRemove::{Recommends,Suggests}Important option
+ (Closes: 807413)
+
+ -- Julian Andres Klode <jak@debian.org> Mon, 14 Dec 2015 16:56:11 +0100
+
+apt (1.1.4) unstable; urgency=medium
+
+ [ Julian Andres Klode ]
+ * defaults.mak: Set LC_COLLATE=C.UTF-8 for reproducible sort order
+ * Avoid overflow when summing up file sizes
+
+ [ David Kalnischkies ]
+ * add a apt breaks (apt-utils << 1.1.3) for partial-upgrades (Closes: 806765)
+ * require explicit paths to dsc/control as we do for deb files
+ (Closes: 806693)
+ * use @CHANGEPATH@ as placeholder in changelog URI templates
+ * replace "which" with "command -v" for portability.
+ Thanks to Mingye Wang for the suggestion. (Closes: 807144)
+ * replace run-parts with find|sort to avoid debianutils usage
+ * part revert, part redo 'which' replacement.
+ Thanks to Jakub Wilk for pointing out #747320
+
+ [ Fredrik Fornwall ]
+ * apt-helper.cc: include <stdlib.h> for atoi (Closes: 807031)
+
+ -- Julian Andres Klode <jak@debian.org> Mon, 07 Dec 2015 15:31:31 +0100
+
+apt (1.1.3) unstable; urgency=medium
+
+ [ David Kalnischkies ]
+ * use function pointers instead of weak symbols for cmdline parsing
+ * accept ../ on the cmdline as start for a deb file as well
+ * add apt-utils Depends apt (= ${binary:Version})
+
+ [ Andreas Cadhalpun ]
+ * do not override exact targetrelease matches with lesser matches
+ (Closes: 746412)
+
+ -- Michael Vogt <mvo@debian.org> Mon, 30 Nov 2015 08:49:40 +0100
+
+apt (1.1.2) unstable; urgency=medium
+
+ [ David Kalnischkies ]
+ * outsmart gcc -O3 over-optimization in pkgCdrom::FindPackages
+ * disable privilege-drop verification by default as fakeroot trips over it
+ (Closes: 806475)
+ * fix program name detection in rsh method
+ * disable privilege dropping for rsh/ssh method by default (Closes: 806511)
+
+ [ Michael Vogt ]
+ * do not use "-Wl,-Bsymbolic-functions" during the build to avoid breakage
+
+ -- Julian Andres Klode <jak@debian.org> Sat, 28 Nov 2015 22:47:40 +0100
+
+apt (1.1.1) unstable; urgency=medium
+
+ [ Michael Vogt ]
+ * Deal with killed acquire methods properly instead of hanging
+ (Closes: #806406)
+ * Check if the Apt::Sandbox::User exists in CheckDropPrivsMustBeDisabled()
+ (Closes: #806406)
+
+ [ David Kalnischkies ]
+ * appease adequate with some weak symbols for -private (Closes: #806422)
+
+ -- Michael Vogt <mvo@debian.org> Fri, 27 Nov 2015 16:04:59 +0100
+
+apt (1.1) unstable; urgency=medium
+
+ [ Justin B Rye ]
+ * review apt(8) manpage
+ * review apt-mark(8) manpage
+ * review apt-secure(8) manpage
+ * review sources.list(5) manpage
+
+ [ Michael Vogt ]
+ * upload ABI break version from experimental to unstable
+
+ -- Michael Vogt <mvo@debian.org> Thu, 26 Nov 2015 12:33:44 +0100
+
+apt (1.1~exp16) experimental; urgency=medium
+
+ [ David Kalnischkies ]
+ * do not use _apt for file/copy sources if it isn't world-accessible
+ (Closes: 805069)
+ * support setting empty values (sanely) & removing support
+ for space-gapping: '-o option= value'
+ Thanks to Daniel Hartwig for initial patch. (Closes: 693092)
+ * ignore lost+found in private directory cleanup (Closes: 805424)
+ * update libapt-{pkg,inst} symbols files
+ * do not rerun ./configure causing FTCBFS with newer autotools-dev.
+ Thanks to Helmut Grohne for the detailed bugreport. (Closes: 804923)
+ * do not segfault in cache generation on mmap failure (Closes: 803417)
+ * do not sent Last-Modified if we expect a changed file
+ * show potentially arch-qualified fullname in 'apt show'
+
+ [ Frans Spiesschaert ]
+ * Dutch manpages translation (NEW) (Closes: 805474)
+
+ [ Justin B Rye ]
+ * review of new/changed translatable program strings
+
+ -- Michael Vogt <mvo@debian.org> Tue, 24 Nov 2015 21:29:14 +0100
+
+apt (1.1~exp15) experimental; urgency=medium
+
+ [ Julian Andres Klode ]
+ * deblistparser: Make PrioList const
+ * srvrec: Do not expose C++11 tuple use in header
+ * cacheset: Fix compilation on new GCC in C++98 mode
+ * Provide tests for thread-safety
+
+ [ Mert Dirik ]
+ * Turkish program translation update (Closes: 802610)
+
+ [ David Kalnischkies ]
+ * implement a public pkgSystem::MultiArchSupported
+ * implement a public pkgSystem::ArchitecturesSupported
+ * implement operator* for cacheset iterators
+ * refactor dpkg execution in deb/debsystem
+ * provide public interface to hold/unhold packages
+ * allow all dpkg selections to be set via apt-mark and libapt
+ * drop privileges in file:// method as we do for decompressors
+ * unbreak the copy-method claiming hashsum mismatch since ~exp9
+ (Closes: 799158)
+ * show progress info while 'downloading' a local .deb file
+ * support .deb files in upgrade operations as well
+ * rework errors and warnings around insecure repositories (Closes: 796549)
+ * refer to apt-secure(8) in unsecure repositories warning
+ * suggest 'apt autoremove' to get right of unneeded packages (Closes: 801571)
+ * add binary-specific options via Binary scope
+ * revamp apt(8) to refer more instead of duplicating
+ * disable updating insecure repositories in apt by default
+ * new quiet level -qq for apt to hide progress output
+ * hidden support more apt-get/apt-cache commands in apt
+ (Closes: 778234, 780700, 781237)
+ * show version and type in "apt (r)depends" (Closes: 218995)
+ * revamp all tools help messages
+ * sanify API to get 'the' candidate version (Closes: #803471)
+ * support arch:all data e.g. in separate Packages file
+ * ignore newlines in dpkg-deb control output for installing debs
+ (Closes: 802553)
+ * allow acquire method specific options via Binary scope
+ * encode UTF-8 characters correctly in QuoteString (Closes: 799123)
+ * activate AI_IDN by default to support IDN domains (Closes: 763437)
+
+ -- Michael Vogt <mvo@debian.org> Wed, 11 Nov 2015 17:04:43 +0100
+
+apt (1.1~exp14) experimental; urgency=medium
+
+ [ Julian Andres Klode ]
+ * Revert "Fix select timeout to be 50msec instead of 0.5msec" for acquire
+ * .travis.yml: Add pinned vivid for gettext and clean up a bit
+ * Allow -i and -u as aliases for installed and upgradable in list
+
+ -- Michael Vogt <mvo@debian.org> Tue, 20 Oct 2015 18:25:04 +0200
+
+apt (1.1~exp13) experimental; urgency=medium
+
+ [ Michael Vogt ]
+ * Use xgettext --no-location in make update-pot
+ * Fix select timeout to be 50msec instead of 0.5msec (Closes: #799857)
+
+ [ David Kalnischkies ]
+ * M-A: allowed pkgs of unconfigured archs do not statisfy :any
+ * implement dpkgs vision of interpreting pkg:<arch> dependencies
+ * add Source-Version field for EDSP
+ * fix insecure use of /tmp in EDSP solver 'dump' (Closes: 795600)
+ * select kernels to protect from autoremove based on Debian version
+ (Closes: 787827)
+ * implement autobit and pinning in EDSP solver 'apt'
+ * do not discard new manual-bits while applying EDSP solutions
+ * include debug information in the autoremove-kernels file
+ * avoid using global PendingError to avoid failing too often too soon
+ * implement apt-get source msg 'Please use: $vcs' for git
+ * do not ignore differently versioned self-provides
+ * do not generate bogus hashes if hash is disabled in apt-ftparchive
+ * use APT::FTPArchive hash settings as default for APT::FPArchive::$filetype
+ * add --sha512 option + documentation for apt-ftparchive
+ * deal with spaces in path, command and filepaths in apt-key
+ * add by-hash sources.list option and document all of by-hash
+ * fallback to well-known URI if by-hash fails (Closes: 798919)
+
+ -- Michael Vogt <mvo@debian.org> Mon, 05 Oct 2015 18:27:22 +0200
+
+apt (1.1~exp12) experimental; urgency=medium
+
+ [ David Kalnischkies ]
+ * sources.list and indextargets option for pdiffs
+ * auto-prefix $(SITE) for indextargets Description field
+ * implement PDiff patching for compressed files
+ * implement indextargets option 'DefaultEnabled'
+ * try xz instead of bz2 first for compressed files
+ * implement $(NATIVE_ARCHITECTURE) substvar for indextargets
+ * detect and deal with indextarget duplicates
+ * ignore for _apt inaccessible TMPDIR in pkgAcqChangelog (Closes: 797270)
+ * if file is inaccessible for _apt, disable privilege drop in acquire
+ * remove Christian Perrier from Uploaders as requested.
+ Thanks to Christian for all the l10n, code & social contributions!
+ (Closes: #783337)
+ * use unusable-for-security hashes for integrity checks
+ * use clock() as source for SRV randomness
+
+ [ Miroslav Kure ]
+ * Czech program translation update (Closes: 797329)
+
+ [ Michael Vogt ]
+ * Consider md5sum no longer a usable hash
+ * Add support for writing by-hash dirs in apt-ftparchive
+
+ [ Julian Andres Klode ]
+ * apt-pkg/tagfile.h: Include stdint.h, fixes rdep build failures
+
+ -- Michael Vogt <mvo@debian.org> Fri, 11 Sep 2015 23:31:34 +0200
+
+apt (1.1~exp11) experimental; urgency=medium
+
+ [ Julian Andres Klode ]
+ * pkgcachegen: Account for remapping when parsing depends from NewPackage.
+ Thanks to Jakub Wilk for the bug report and the backtraces (Closes: #796999)
+ * debian/rules: Only do parallel build if specified in DEB_BUILD_OPTIONS.
+ Thanks to Jakub Wilk for the suggestion
+ * cacheset: Prefer the depcache over the policy again
+ * install: Set a local deb as the candidate for that package
+ * Always close compressed files in FileFd
+ * Use compressor support from FileFd for ExtractTar instead of programs
+ * Do not parse Status fields from remote sources
+
+ [ David Kalnischkies ]
+ * just-in-time removal of broken essential packages (Closes: 796070)
+ * correct 'apt update' download summary line
+ * ignore AllowMem parameter in cache generation (Closes: 796459)
+ * add a libapt-pkg recommends apt
+ * fix various typos reported by codespell
+ * use always priv-dropping for changelog download as root
+ * allow explicit dis/enable of IndexTargets in sources options
+
+ [ Anders Jonsson ]
+ * Swedish program translation update (Closes: 796059)
+
+ -- Julian Andres Klode <jak@debian.org> Thu, 27 Aug 2015 17:55:12 +0200
+