]> git.saurik.com Git - apt.git/blobdiff - debian/rules
* debian/rules:
[apt.git] / debian / rules
index 1c5b6d51575576df6e27fe2bee71d221eb7221ff..d8e4a88bdaad4f19f10cf1082deb4a27c6db5b94 100755 (executable)
@@ -3,6 +3,9 @@
 # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
 # Some lines taken from debmake, by Christoph Lameter.
 
+# build in verbose mode by default to make it easy to diangose issues
+export NOISY=1
+
 export DEB_HOST_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
 export DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
 
@@ -172,42 +175,35 @@ apt: build build-doc
 #
 # apt install
 #
-       cp $(BLD)/bin/apt-* debian/$@/usr/bin/
-
-       # Remove the bits that are in apt-utils
-       rm $(addprefix debian/$@/usr/bin/apt-,$(APT_UTILS))
-
-       # install the shared libs
-       find $(BLD)/bin/ -type f -name "libapt-pkg*.so.*" -exec cp -a "{}" debian/$@/usr/lib/ \;
-       find $(BLD)/bin/ -type l -name "libapt-pkg*.so.*" -exec cp -a "{}" debian/$@/usr/lib/ \;
-
-       cp $(BLD)/bin/methods/* debian/$@/usr/lib/apt/methods/
-       # https has its own package
-       rm debian/$@/usr/lib/apt/methods/https
-
-       cp $(BLD)/scripts/dselect/* debian/$@/usr/lib/dpkg/methods/apt/
-       cp -r $(BLD)/locale debian/$@/usr/share/
-
-       cp debian/bugscript debian/$@/usr/share/bug/apt/script
-       cp debian/apt.logrotate debian/$@/etc/logrotate.d/apt
-
        cp debian/apt.conf.autoremove debian/$@/etc/apt/apt.conf.d/01autoremove
+       cp debian/apt.conf.changelog debian/$@/etc/apt/apt.conf.d/20changelog
+       cp share/ubuntu-archive.gpg debian/$@/usr/share/$@
 
        # make rosetta happy and remove pot files in po/ (but leave stuff
        # in po/domains/* untouched) and cp *.po into each domain dir
        rm -f build/po/*.pot
        rm -f po/*.pot
 
+       dh_install -p$@ --sourcedir=$(BLD)
+
+       # Remove the bits that are in apt-utils
+       rm $(addprefix debian/$@/usr/bin/apt-,$(APT_UTILS))
+
+       # https has its own package
+       rm debian/$@/usr/lib/apt/methods/https
+
        # move the mirror failure script in place
        #mv debian/$@/usr/bin/apt-report-mirror-failure \
        #   debian/$@/usr/lib/apt/apt-report-mirror-failure \
 
+       dh_bugfiles -p$@
        dh_lintian -p$@
        dh_installexamples -p$@ $(BLD)/docs/examples/*
        dh_installman -p$@ $(wildcard $(patsubst %,doc/%.[158],$(apt_MANPAGES)) $(patsubst %,doc/*/%.*.[158],$(apt_MANPAGES)))
        dh_installcron -p$@
        dh_installdocs -p$@
        dh_installchangelogs -p$@
+       dh_installlogrotate -p$@
        dh_strip -p$@
        dh_compress -p$@
        dh_fixperms -p$@
@@ -226,13 +222,8 @@ libapt-pkg-dev: build
 #
 # libapt-pkg-dev install
 #
-       cp -a $(BLD)/bin/libapt-pkg*.so debian/libapt-pkg-dev/usr/lib/
-       cp -a $(BLD)/bin/libapt-inst*.so debian/libapt-pkg-dev/usr/lib/
-#      ln -s libapt-pkg.so.$(LIBAPTPKG_MAJOR) debian/libapt-pkg-dev/usr/lib/libapt-pkg.so
-       cp $(BLD)/include/apt-pkg/*.h debian/libapt-pkg-dev/usr/include/apt-pkg/
-
+       dh_install -p$@ --sourcedir=$(BLD)
        dh_installdocs -p$@
-
        dh_installchangelogs -p$@
        dh_strip -p$@
        dh_compress -p$@
@@ -249,11 +240,9 @@ apt-utils: build
        dh_prep -p$@
        dh_installdirs -p$@
 
-       # install the shared libs
-       find $(BLD)/bin/ -type f -name "libapt-inst*.so.*" -exec cp -a "{}" debian/$@/usr/lib/ \;
-       find $(BLD)/bin/ -type l -name "libapt-inst*.so.*" -exec cp -a "{}" debian/$@/usr/lib/ \;
-
        cp $(addprefix $(BLD)/bin/apt-,$(APT_UTILS)) debian/$@/usr/bin/
+
+       dh_install -p$@ --sourcedir=$(BLD)
        dh_installdocs -p$@
        dh_installexamples -p$@
 
@@ -277,10 +266,7 @@ apt-transport-https: build libapt-pkg-dev
        dh_prep -p$@
        dh_installdirs -p$@
 
-       # install the method
-       mkdir --parents debian/$@/usr/lib/apt/methods
-       cp $(BLD)/bin/methods/https debian/$@/usr/lib/apt/methods
-
+       dh_install -p$@ --sourcedir=$(BLD)
        dh_installdocs -p$@ debian/apt-transport-https.README
        dh_installexamples -p$@