+apt (0.7.26~exp5) UNRELEASED; urgency=low
+
+ [ Christian Perrier ]
+ * Slovak translation update. Closes: #581159
+ * Italian translation update. Closes: #581742
+
+ [ Martin Pitt ]
+ * debian/rules:
+ - Make DEB_BUILD_OPTIONS=noopt actually work by passing the right
+ CXXFLAGS.
+ * apt-pkg/contrib/fileutl.{h,cc}:
+ - Add support for transparent reading of gzipped files.
+ - Link against zlib (in apt-pkg/makefile) and add zlib build dependency.
+ - [ABI BREAK] This introduces a new protected member of FileFD and changes
+ the behaviour of FileFd for reading gzipped files.
+ * configure.in:
+ - Check for zlib library and headers.
+ * apt-pkg/deb/debindexfile.cc:
+ - If we do not find uncompressed package/source/translation indexes, look
+ for gzip compressed ones.
+ * apt-pkg/acquire-item.cc:
+ - If the Acquire::GzipIndexes option is true and we download a gzipped
+ index file, keep it as it is (and rename to .gz) instead of
+ uncompressing it.
+ * doc/apt.conf.5.xml:
+ - Document the new Acquire::GzipIndexes option.
+ * doc/po/apt-doc.pot, doc/po/de.po:
+ - German translation of new Acquire::GzipIndexes option.
+ * Add test/test-indexes.sh:
+ - Test behaviour of index retrieval and usage, in particular with
+ uncompressed and gzip compressed indexes.
+
+ -- Christian Perrier <bubulle@debian.org> Tue, 11 May 2010 19:52:00 +0200
+
+apt (0.7.26~exp4) unstable; urgency=low
+
+ * [ Abi break ] apt-pkg/acquire-item.{cc,h}:
+ - add "IsIndexFile" to constructor of pkgAcqFile so that it sends
+ the right cache control headers
+ * apt-pkg/depcache.cc:
+ - fix incorrect std::cout usage for debug output
+ * test/libapt/getlanguages_test.cc:
+ - Add test for Esperanto that has nocounty associated with them
+ (LP: #560956)
+ * apt-pkg/deb/debrecords.cc:
+ - fix max tag buffer size (LP: #545336, closes: #578959)
+ * debian/rules:
+ - install html doxygen in libapt-pkg-doc as well
+
+ -- Michael Vogt <michael.vogt@ubuntu.com> Tue, 04 May 2010 09:55:08 +0200
+
apt (0.7.26~exp3) UNRELEASED; urgency=low
[ Christian Perrier ]
* apt-pkg/policy.cc:
- Always return a candidate if there is at least one version pinned > 0
(Closes: #512318)
+ * ftparchive/apt-ftparchive.cc:
+ - Read default configuration (Closes: #383257)
* debian/rules:
- Fix the libraries name to be e.g. libapt-pkg4.9 instead of
libapt-pkg-4.9.
+ [ Michael Vogt ]
+ * apt-pkg/deb/dpkgpm.cc:
+ - fix backgrounding when dpkg runs (closes: #486222)
+ * cmdline/apt-mark:
+ - show error on incorrect aguments (LP: #517917), thanks to
+ Torsten Spindler
+ * cmdline/apt-get.cc:
+ - if apt-get source foo=version or foo/distro can not be found,
+ error out (LP: #502641)
+ * apt-pkg/packagemanager.cc:
+ - better debug output
+ * doc/examples/configure-index:
+ - add missing Debug::pkgPackageManager option
+
-- Christian Perrier <bubulle@debian.org> Wed, 24 Feb 2010 22:13:50 +0100
apt (0.7.26~exp2) experimental; urgency=low