-apt (0.8.16~exp9) UNRELEASED; urgency=low
+apt (0.8.16~exp14) UNRELEASED; urgency=low
+
+ [ Michael Vogt ]
+ * apt-pkg/packagemanager.cc:
+ - fix inconsistent clog/cout usage in the debug output
+
+ [ David Kalnischkies ]
+ * debian/libapt-pkg4.12:
+ - update symbols file
+ * apt-pkg/packagemanager.cc:
+ - recheck all dependencies if we changed a package in SmartConfigure
+ as this could break an earlier dependency (LP: #940396)
+ - recheck dependencies in SmartUnpack after a change, too
+ * apt-pkg/acquire-worker.cc:
+ - check return of write() as gcc recommends
+ * apt-pkg/acquire.cc:
+ - check return of write() as gcc recommends
+ * apt-pkg/cdrom.cc:
+ - check return of chdir() and link() as gcc recommends
+ * apt-pkg/clean.cc:
+ - check return of chdir() as gcc recommends
+ * apt-pkg/contrib/netrc.cc:
+ - check return of asprintf() as gcc recommends
+ * methods/makefile:
+ - do not link rred against libz anymore as FileFd handles all
+ this transparently now
+
+ -- David Kalnischkies <kalnischkies@gmail.com> Tue, 20 Mar 2012 18:29:33 +0100
+
+apt (0.8.16~exp13) experimental; urgency=low
+
+ [ David Kalnischkies ]
+ * apt-pkg/acquire-item.cc:
+ - remove 'old' InRelease file if we can't get a new one before
+ proceeding with Release.gpg to avoid the false impression of a still
+ trusted repository by a (still present) old InRelease file.
+ Thanks to Simon Ruderich for reporting this issue! (CVE-2012-0214)
+ - add Debug::pkgAcqArchive::NoQueue to disable package downloading
+ * apt-pkg/deb/dpkgpm.cc:
+ - chroot if needed before dpkg --assert-multi-arch
+ - ensure that dpkg binary doesn't have the chroot-directory prefixed
+ - call dpkg --assert-multi-arch with execvp instead of execv
+ - save the universe by not printing messages about apport if a package
+ with this name is not installed (Closes: #619646)
+ - handle a SIGINT in all modes as a break after the currently running
+ dpkg transaction instead of ignoring it completely
+ * apt-pkg/depcache.cc:
+ - if a M-A:same package is marked for reinstall, mark all it's installed
+ silbings for reinstallation as well (LP: #859188)
+ * apt-pkg/contrib/configuration.cc:
+ - do not stop parent transversal in FindDir if the value is empty
+ * methods/http{s,}.cc:
+ - if a file without an extension is requested send an 'Accept: text/*'
+ header to avoid that the server chooses unsupported compressed files
+ in a content-negotation attempt (Closes: #657560)
+ - remove the arbitrary MAXLEN limit for response lines (Closes: #658346)
+ * apt-pkg/aptconfiguration.cc:
+ - chroot if needed before calling dpkg --print-foreign-architectures
+ - ensure that architectures are not added multiple times
+ * cmdline/apt-mark.cc:
+ - detect if dpkg has multiarch support before calling --set-selections
+ - correctly ignore already (un)hold packages
+ * apt-pkg/cachefile.cc:
+ - clean up lost atomic cachefiles with 'clean' (Closes: #650513)
+ * apt-pkg/indexrecords.cc:
+ - do not create empty Entries as a sideeffect of Lookup()
+ * apt-pkg/acquire-item.cc:
+ - drop support for i18n/Index file (introduced in 0.8.11) and use
+ the Release file instead to get the Translations (Closes: #649314)
+ - use pdiff for Translation-* files if available (Closes: #657902)
+ * ftparchive/writer.cc:
+ - add 'Translation-*' to the default patterns
+ * cmdline/apt-get.cc:
+ - if a package can't be removed as it is not installed, suggest to
+ the user an (installed) multiarch silbing with 'Did you mean?'
+ - improve 'error' message for packages which are only referenced
+ e.g. in a Depends line and are now requested for removal
+ * cmdline/apt-cache.cc:
+ - correct --pre-depends option by using dash consistently (LP: #940837)
+ * apt-pkg/packagemanager.cc:
+ - do not try to a void a breaks if the broken package pre-depends
+ on the breaker, but let dpkg auto-deconfigure it
+ * apt-pkg/contrib/fileutl.cc:
+ - do not warn about the ignoring of directories (Closes: #662762)
+
+ [ Steve Langasek ]
+ * cmdline/apt-get.cc:
+ - for cross-build-dependencies M-A: none should be DEB_HOST_ARCH,
+ not DEB_BUILD_ARCH (Closes: #646288)
+
+ [ Colin Watson ]
+ * apt-pkg/algorithms.cc:
+ - don't break out of the main-resolver loop for Breaks to deal with all
+ of them in a single iteration (Closes: #657695, LP: #922485)
+ - use a signed int instead of short for score calculation as upgrades
+ become so big now that it can overflow (Closes: #657732, LP: #917173)
+ * Fix IndexCopy::CopyPackages and TranslationsCopy::CopyTranslations to
+ handle compressed files again (LP: #924182, closes: #658096)
+
+ [ Michael Vogt ]
+ * apt-pkg/deb/dpkgpm.cc:
+ - fix crash when a package is in removed but residual config state
+ (LP: #923807)
+ * apt-pkg/contrib/fileutl.h:
+ - fix compat with FileFd::OpenDescriptor() in ReadOnlyGzip mode
+ * apt-pkg/packagemanager.cc:
+ - fix bug in predepends handling - ensure that packages that needs
+ unpackaging are unpacked before they are configured (LP: #927993)
+
+ [ Julian Andres Klode ]
+ * apt-pkg/deb/deblistparser.cc:
+ - Set the Essential flag on APT instead of only Important
+ * apt-pkg/packagemanager.cc:
+ - Do not use immediate configuration for packages with the Important flag
+ * Treat the Important flag like the Essential flag with those differences:
+ - No Immediate configuration (see above)
+ - Not automatically installed during dist-upgrade
+ - No higher score for installation ordering
+
+ -- Michael Vogt <mvo@debian.org> Tue, 06 Mar 2012 18:12:57 +0100
+
+apt (0.8.16~exp12) experimental; urgency=low
+
+ [ Michael Vogt ]
+ * apt-pkg/deb/dpkgpm.cc:
+ - fix segfault on pkg removal
+
+ [ David Kalnischkies ]
+ * apt-pkg/cacheiterators.h:
+ - return the correct version arch for all+foreign, too
+ * apt-pkg/packagemanager.cc:
+ - ignore breaks on not-installed versions while searching for
+ breakage loops as we don't have to avoid them
+ * debian/control:
+ - remove APT from the short descriptions as lintian doesn't like it
+ and it doesn't transport any information for a reader anyway
+ - apply typofixes by Pascal De Vuyst, thanks! (Closes: #652834, #652835)
+ * debian/rules:
+ - apply patch to enable usage of hardning CPPFLAGS and LDFLAGS by
+ Moritz Muehlenhoff, thanks! (Closes: #653504)
+ * methods/https.cc:
+ - use curls list append instead of appending Range and If-Range by hand
+ which generates malformed requests, thanks Mel Collins for the hint!
+ (Closes: #646381)
+ * test/libapt/run-tests:
+ - hurd doesn't have dmesg yet and we don't really need it either,
+ so use with $0 a more stable data source for hashsumming
+
+ [ Pino Toscano ]
+ * test/libapt/globalerror_test.cc:
+ - errno 0 has a different strerror on hurd, so generate the expected
+ message dynamically instead of hardcoding 'Success' (Closes: #656530)
+
+ -- Michael Vogt <mvo@debian.org> Tue, 24 Jan 2012 12:24:38 +0100
+
+apt (0.8.16~exp11) experimental; urgency=low
+
+ [ David Kalnischkies ]
+ * apt-pkg/deb/dpkgpm.cc:
+ - redirect out/input of dpkg --assert-multi-arch to /dev/null
+ - if multi-arch is detected ensure that pkg:all is reported as pkg:all
+
+ -- Michael Vogt <mvo@debian.org> Thu, 19 Jan 2012 13:48:18 +0100
+
+apt (0.8.16~exp10) experimental; urgency=low
+
+ [ David Kalnischkies ]
+ * apt-pkg/depcache.cc:
+ - implicit conflicts (for multiarch) are supposed to conflict
+ only with real packages, not with virtual providers
+ * apt-pkg/pkgcache.cc:
+ - ignore implicit conflicts on providers in AllTarget, too
+ * apt-pkg/deb/dpkgpm.cc:
+ - check if dpkg supports multiarch with --assert-multi-arch
+ and if it does be always explicit about the architecture
+ * apt-pkg/contrib/fileutl.h:
+ - store the offset in the internal fd before calculate size of
+ the zlib-handled file to jump back to this place again
+
+ [ Michael Vogt ]
+ * apt-pkg/contrib/fileutl.h:
+ - fix segfault triggered by the python-apt testsuite
+
+ -- Michael Vogt <mvo@debian.org> Wed, 18 Jan 2012 12:52:26 +0100
+
+apt (0.8.16~exp9) experimental; urgency=low
[ Julian Andres Klode ]
* apt-pkg/cdrom.cc:
* debian/control:
- bump debhelper build-dep to debhelper (>= 8.1.3~)
- set libapt-pkg-dev to multi-arch: same too
+ * g++ 4.7 fixes
[ Colin Watson ]
* Convert libapt-pkg4.12 and libapt-inst1.4 to Multi-Arch: same.
* apt-pkg/cdrom.cc:
- support InRelease files on cdrom
- -- David Kalnischkies <kalnischkies@gmail.com> Sun, 11 Dec 2011 19:34:58 +0100
+ -- Michael Vogt <mvo@debian.org> Thu, 05 Jan 2012 20:26:31 +0100
apt (0.8.16~exp8) experimental; urgency=low
-- Michael Vogt <mvo@debian.org> Wed, 29 Jun 2011 12:40:31 +0200
+apt (0.8.15.10) UNRELEASEDunstable; urgency=low
+
+ [ David Kalnischkies ]
+ * algorithms.cc:
+ - show a debug why a package was kept by ResolveByKeep()
+ * doc/manpage-style.xml:
+ - put <brackets> around email addresses
+ * apt-pkg/aptconfiguration.cc:
+ - parse dpkg --print-foreign-architectures correctly in
+ case archs are separated by newline instead of space, too.
+ (Closes: #655590)
+ * doc/po/de.po:
+ - apply typo-fix from Michael Basse, thanks! (LP: #900770)
+
+ [ Chris Leick ]
+ * German manpage translation update
+ * doc/*.xml:
+ - find and fix a bunch of misspellings
+
+ [ Program translation updates ]
+ * Dutch (Jeroen Schot). Closes: #652230
+ * Slovak (Ivan Masar). Closes: #652985
+ * Russian (Yuri Kozlov). Closes: #654844
+ * Hungarian (Gabor Kelemen). Closes: #655238
+
+ -- David Kalnischkies <kalnischkies@gmail.com> Fri, 13 Jan 2012 17:30:36 +0100
+
apt (0.8.15.9) unstable; urgency=low
[ David Kalnischkies ]