]> git.saurik.com Git - wxWidgets.git/blobdiff - wxX11.spec
minor Unicode overview corrections
[wxWidgets.git] / wxX11.spec
index 916de2c54ac02fdcc134ab4da8071898d8829b60..62135b2953a8ff036873d2cda1b53fb812e229bc 100644 (file)
@@ -1,6 +1,6 @@
 %define pref /usr
-%define ver  2.6.2
-%define ver2 2.6
+%define ver  2.9.0
+%define ver2 2.9
 %define rel  1
 
 # Configurable settings (use --with(out) unicode on rpmbuild cmd line):
@@ -105,9 +105,8 @@ cd obj-shared
 %if %{unicode}
                               --enable-unicode \
 %else
-                              --with-odbc \
+                              --disable-unicode \
 %endif
-                              --with-opengl
 $MAKE
 
 cd contrib/src
@@ -120,7 +119,7 @@ cd obj-static
 %if %{unicode}
                               --enable-unicode \
 %else
-                              --with-odbc \
+                              --disable-unicode \
 %endif
                               --with-opengl
 $MAKE
@@ -141,15 +140,22 @@ wx/apptrait.h
 wx/archive.h
 wx/arrimpl.cpp
 wx/arrstr.h
+wx/atomic.h
+wx/base64.h
 wx/beforestd.h
 wx/buffer.h
 wx/build.h
+wx/chartype.h
 wx/chkconf.h
 wx/clntdata.h
+wx/cmdargs.h
 wx/cmdline.h
 wx/confbase.h
 wx/config.h
+wx/convauto.h
 wx/containr.h
+wx/cpp.h
+wx/crt.h
 wx/datetime.h
 wx/datstrm.h
 wx/dde.h
@@ -164,6 +170,7 @@ wx/encconv.h
 wx/event.h
 wx/except.h
 wx/features.h
+wx/flags.h
 wx/ffile.h
 wx/file.h
 wx/fileconf.h
@@ -172,6 +179,8 @@ wx/filename.h
 wx/filesys.h
 wx/fontenc.h
 wx/fontmap.h
+wx/fs_arc.h
+wx/fs_filter.h
 wx/fs_mem.h
 wx/fs_zip.h
 wx/hash.h
@@ -185,8 +194,7 @@ wx/iosfwrap.h
 wx/ioswrap.h
 wx/ipc.h
 wx/ipcbase.h
-wx/isql.h
-wx/isqlext.h
+wx/link.h
 wx/list.h
 wx/listimpl.cpp
 wx/log.h
@@ -201,8 +209,12 @@ wx/msgout.h
 wx/mstream.h
 wx/object.h
 wx/platform.h
+wx/platinfo.h
+wx/power.h
 wx/process.h
 wx/ptr_scpd.h
+wx/ptr_shrd.h
+wx/recguard.h
 wx/regex.h
 wx/scopeguard.h
 wx/snglinst.h
@@ -215,36 +227,58 @@ wx/stopwatch.h
 wx/strconv.h
 wx/stream.h
 wx/string.h
+wx/stringimpl.h
+wx/stringops.h
+wx/strvararg.h
 wx/sysopt.h
+wx/tarstrm.h
 wx/textbuf.h
 wx/textfile.h
 wx/thread.h
 wx/thrimpl.cpp
 wx/timer.h
 wx/tokenzr.h
+wx/tracker.h
 wx/txtstrm.h
 wx/types.h
+wx/unichar.h
 wx/uri.h
 wx/utils.h
 wx/variant.h
 wx/vector.h
 wx/version.h
 wx/volume.h
+wx/weakref.h
 wx/wfstream.h
 wx/wx.h
 wx/wxchar.h
+wx/wxcrt.h
+wx/wxcrtbase.h
+wx/wxcrtvararg.h
 wx/wxprec.h
+wx/xlocale.h
 wx/xti.h
 wx/xtistrm.h
 wx/zipstrm.h
 wx/zstream.h
+wx/meta/convertible.h
+wx/meta/if.h
+wx/meta/int2type.h
+wx/meta/movable.h
+wx/private/fdiodispatcher.h
+wx/private/selectdispatcher.h
+wx/unix/app.h
 wx/unix/apptbase.h
 wx/unix/apptrait.h
-wx/unix/execute.h
-wx/unix/mimetype.h
+wx/unix/chkconf.h
+wx/unix/evtloop.h
 wx/unix/pipe.h
-wx/unix/stackwalk.h
 wx/unix/stdpaths.h
+wx/unix/stackwalk.h
+wx/unix/execute.h
+wx/unix/mimetype.h
+wx/unix/private.h
+wx/private/gsocketiohandler.h
 wx/fs_inet.h
 wx/gsocket.h
 wx/protocol/file.h
@@ -259,9 +293,6 @@ wx/url.h
 wx/unix/gsockunx.h
 wx/xml/xml.h
 wx/xtixml.h
-wx/db.h
-wx/dbkeyg.h
-wx/dbtable.h
 EOF
 # --- wxBase headers list ends here ---
 for f in `cat wxbase-headers-list` ; do
@@ -335,9 +366,6 @@ rm -f %{_bindir}/%{wxconfiglink}
 %doc COPYING.LIB *.txt
 %{_libdir}/libwx_%{portname}*_adv-%{ver2}.so.*
 %{_libdir}/libwx_%{portname}*_core-%{ver2}.so.*
-%if !%{unicode}
-    %{_libdir}/libwx_%{portname}*_dbgrid-%{ver2}.so.*
-%endif
 %{_libdir}/libwx_%{portname}*_html-%{ver2}.so.*
 %{_libdir}/libwx_%{portname}*_media-%{ver2}.so.*
 %{_libdir}/libwx_%{portname}*_qa-%{ver2}.so.*
@@ -348,9 +376,6 @@ rm -f %{_bindir}/%{wxconfiglink}
 %defattr(-,root,root)
 %{_libdir}/libwx_%{portname}*_adv-%{ver2}.so
 %{_libdir}/libwx_%{portname}*_core-%{ver2}.so
-%if !%{unicode}
-    %{_libdir}/libwx_%{portname}*_dbgrid-%{ver2}.so
-%endif
 %{_libdir}/libwx_%{portname}*_gl-%{ver2}.so
 %{_libdir}/libwx_%{portname}*_html-%{ver2}.so
 %{_libdir}/libwx_%{portname}*_media-%{ver2}.so