%define _prefix /usr
-%define ver 2.7.0
-%define ver2 2.7
+%define ver 2.9.0
+%define ver2 2.9
%define rel 1
# Configurable settings (use --with(out) {unicode,gtk2} on rpmbuild cmd line):
--enable-unicode \
%else
--disable-unicode \
- --with-odbc \
%endif
--with-opengl
$MAKE
--enable-unicode \
%else
--disable-unicode \
- --with-odbc \
%endif
--with-opengl
$MAKE
# --- wxBase headers list begins here ---
cat <<EOF >wxbase-headers.files
wx/afterstd.h
+wx/anystr.h
wx/app.h
wx/apptrait.h
wx/archive.h
wx/arrimpl.cpp
wx/arrstr.h
+wx/atomic.h
+wx/base64.h
wx/beforestd.h
wx/buffer.h
wx/build.h
+wx/chartype.h
+wx/checkeddelete.h
wx/chkconf.h
wx/clntdata.h
+wx/cmdargs.h
wx/cmdline.h
wx/confbase.h
wx/config.h
wx/convauto.h
wx/containr.h
wx/cpp.h
+wx/crt.h
wx/datetime.h
wx/datstrm.h
wx/dde.h
wx/defs.h
wx/dir.h
wx/dlimpexp.h
+wx/dlist.h
wx/dynarray.h
wx/dynlib.h
wx/dynload.h
wx/event.h
wx/except.h
wx/features.h
+wx/flags.h
wx/ffile.h
wx/file.h
-wx/fileback.h
wx/fileconf.h
wx/filefn.h
wx/filename.h
wx/filesys.h
wx/fontenc.h
wx/fontmap.h
+wx/fs_arc.h
+wx/fs_filter.h
wx/fs_mem.h
wx/fs_zip.h
wx/hash.h
wx/ioswrap.h
wx/ipc.h
wx/ipcbase.h
-wx/isql.h
-wx/isqlext.h
+wx/kbdstate.h
wx/link.h
wx/list.h
wx/listimpl.cpp
wx/memtext.h
wx/mimetype.h
wx/module.h
+wx/mousestate.h
wx/msgout.h
wx/mstream.h
wx/object.h
wx/power.h
wx/process.h
wx/ptr_scpd.h
+wx/ptr_shrd.h
wx/recguard.h
wx/regex.h
+wx/scopedarray.h
+wx/scopedptr.h
wx/scopeguard.h
+wx/sharedptr.h
wx/snglinst.h
wx/sstream.h
wx/stack.h
wx/strconv.h
wx/stream.h
wx/string.h
+wx/stringimpl.h
+wx/stringops.h
+wx/strvararg.h
wx/sysopt.h
+wx/tarstrm.h
wx/textbuf.h
wx/textfile.h
wx/thread.h
wx/thrimpl.cpp
wx/timer.h
+wx/tls.h
wx/tokenzr.h
+wx/tracker.h
wx/txtstrm.h
wx/types.h
+wx/unichar.h
wx/uri.h
+wx/ustring.h
wx/utils.h
wx/variant.h
wx/vector.h
wx/version.h
wx/volume.h
+wx/weakref.h
wx/wfstream.h
wx/wx.h
wx/wxchar.h
+wx/wxcrt.h
+wx/wxcrtbase.h
+wx/wxcrtvararg.h
wx/wxprec.h
+wx/xlocale.h
wx/xti.h
wx/xtistrm.h
wx/zipstrm.h
wx/zstream.h
+wx/meta/convertible.h
+wx/meta/if.h
+wx/meta/int2type.h
+wx/meta/movable.h
+wx/unix/app.h
wx/unix/apptbase.h
wx/unix/apptrait.h
-wx/unix/execute.h
-wx/unix/mimetype.h
+wx/unix/chkconf.h
+wx/unix/evtloop.h
wx/unix/pipe.h
-wx/unix/private.h
-wx/unix/stackwalk.h
wx/unix/stdpaths.h
+wx/unix/stackwalk.h
+wx/unix/tls.h
+wx/unix/execute.h
+wx/unix/mimetype.h
wx/fs_inet.h
-wx/gsocket.h
wx/protocol/file.h
wx/protocol/ftp.h
wx/protocol/http.h
+wx/protocol/log.h
wx/protocol/protocol.h
wx/sckaddr.h
wx/sckipc.h
wx/sckstrm.h
wx/socket.h
wx/url.h
-wx/unix/gsockunx.h
wx/xml/xml.h
wx/xtixml.h
-wx/db.h
-wx/dbkeyg.h
-wx/dbtable.h
EOF
# --- wxBase headers list ends here ---
cat <<EOF >wxbase-headers.paths
%{_includedir}/wx-%{ver2}/wx/url.h
%{_includedir}/wx-%{ver2}/wx/xml/xml.h
%{_includedir}/wx-%{ver2}/wx/xtixml.h
-%{_includedir}/wx-%{ver2}/wx/db.h
-%{_includedir}/wx-%{ver2}/wx/dbkeyg.h
-%{_includedir}/wx-%{ver2}/wx/dbtable.h
%{_includedir}/wx-%{ver2}/wx/unix/apptbase.h
%{_includedir}/wx-%{ver2}/wx/unix/apptrait.h
%{_includedir}/wx-%{ver2}/wx/unix/execute.h
%{_libdir}/libwx_%{buildname}_adv-%{ver2}.so.*
%{_libdir}/libwx_%{buildname}_aui-%{ver2}.so.*
%{_libdir}/libwx_%{buildname}_core-%{ver2}.so.*
-%if !%{unicode}
- %{_libdir}/libwx_%{buildname}_dbgrid-%{ver2}.so.*
-%endif
%{_libdir}/libwx_%{buildname}_html-%{ver2}.so.*
%{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so.*
%{_libdir}/libwx_%{buildname}_qa-%{ver2}.so.*
%{_libdir}/libwx_%{buildname}_adv-%{ver2}.so
%{_libdir}/libwx_%{buildname}_aui-%{ver2}.so
%{_libdir}/libwx_%{buildname}_core-%{ver2}.so
-%if !%{unicode}
- %{_libdir}/libwx_%{buildname}_dbgrid-%{ver2}.so
-%endif
%{_libdir}/libwx_%{buildname}_gl-%{ver2}.so
%{_libdir}/libwx_%{buildname}_html-%{ver2}.so
%{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so
%{_libdir}/libwx_%{buildname}_adv-%{ver2}.a
%{_libdir}/libwx_%{buildname}_aui-%{ver2}.a
%{_libdir}/libwx_%{buildname}_core-%{ver2}.a
-%if !%{unicode}
- %{_libdir}/libwx_%{buildname}_dbgrid-%{ver2}.a
-%endif
%{_libdir}/libwx_%{buildname}_gl-%{ver2}.a
%{_libdir}/libwx_%{buildname}_html-%{ver2}.a
%{_libdir}/libwx_%{buildname}_qa-%{ver2}.a