]> git.saurik.com Git - wxWidgets.git/blobdiff - wxBase.spec
improved dependencies for Info.plist
[wxWidgets.git] / wxBase.spec
index 2e220086184a494d6793a0be93faab35772a0350..5b38f95a9b180581060b55ae8a20923395344918 100644 (file)
@@ -1,7 +1,7 @@
-# Note that this is NOT a relocatable package
 %define pref /usr
-%define ver 2.1.16
-%define rel 0
+%define ver 2.3.2
+%define ver2 2.3
+%define rel 1
 
 Summary: wxBase library - non-GUI support classes of wxWindows toolkit
 Name: wxBase
@@ -9,10 +9,11 @@ Version: %{ver}
 Release: %{rel}
 Copyright: wxWindows Licence
 Group: Development/Libraries
-Source: wxBase-%{ver}.tar.gz
-URL: none
+Source: wxBase-%{ver}.tar.bz2
+URL: http://www.wxwindows.org
 Packager: Vadim Zeitlin <vadim@wxwindows.org>
-BuildRoot: /tmp/wxBase_rpm
+Prefix: %{pref}
+BuildRoot: /var/tmp/%{name}-root
 
 %description
 wxBase is a collection of C++ classes providing basic data structures (strings,
@@ -26,14 +27,20 @@ the following platforms: Win32, generic Unix (Linux, FreeBSD, Solaris, HP-UX,
 %package devel
 Summary: wxBase headers needed for developping with wxBase
 Group: Development/Libraries
-Requires: wxBase
+Requires: wxBase = %{ver}
 
 %description devel
 Header files for wxBase. You need them to develop programs using wxBase.
 
+%package static
+Summary: wxBase static libraries
+Group: Development/Libraries
+
+%description static
+Static libraries for wxBase. You need them if you want to link statically against wxBase.
+
 %prep
-%setup -n wxBase
-./configure --prefix=%{pref} --disable-gui --disable-std_iostreams
+%setup -n wxBase-%{ver}
 
 %build
 if [ "$SMP" != "" ]; then
@@ -41,11 +48,25 @@ if [ "$SMP" != "" ]; then
 else
   export MAKE="make"
 fi
+
+mkdir obj-shared
+cd obj-shared
+../configure --prefix=%{pref} --enable-soname --disable-gui --disable-std_iostreams
+$MAKE
+cd ..
+
+mkdir obj-static
+cd obj-static
+../configure --prefix=%{pref} --disable-shared --disable-gui --disable-std_iostreams
 $MAKE
+cd ..
 
 %install
 rm -rf $RPM_BUILD_ROOT
-make prefix=$RPM_BUILD_ROOT%{pref} install
+(cd obj-static ; make prefix=$RPM_BUILD_ROOT%{pref} install)
+(cd obj-shared ; make prefix=$RPM_BUILD_ROOT%{pref} install)
+
+%find_lang wxstd
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -56,16 +77,37 @@ rm -rf $RPM_BUILD_ROOT
 %postun
 /sbin/ldconfig
 
-%files
-%defattr (644, root, root, 755)
-%doc COPYING.LIB INSTALL.txt LICENCE.txt README.txt SYMBOLS.txt TODO.txt
-%attr(755, -, -) %{pref}/lib/libwxbase*
-%dir %{pref}/lib/wx
-%dir %{pref}/lib/wx/include
-%dir %{pref}/lib/wx/include/wx
-%{pref}/lib/wx/include/wx/setup.h
+%post devel
+# Install wx-config if there isn't any
+if test ! -f %{_bindir}/wx-config ; then
+    ln -sf wxbase-%{ver2}-config %{_bindir}/wx-config
+fi
+
+%preun devel
+# Remove wx-config if it points to this package
+if test -f %{_bindir}/wx-config -a -f /usr/bin/md5sum ; then
+  SUM1=`md5sum %{_bindir}/wxbase-%{ver2}-config | cut -c 0-32`
+  SUM2=`md5sum %{_bindir}/wx-config | cut -c 0-32`
+  if test "x$SUM1" = "x$SUM2" ; then
+    rm -f %{_bindir}/wx-config
+  fi
+fi
+
+%files -f wxstd.lang
+%defattr (-,root,root)
+%doc COPYING.LIB *.txt
+%{_libdir}/libwx_base*so.*
 
-%files devel -f src/rpmfiles.lst
-%defattr (644, root, root, 755)
-%attr(755, -, -) %{pref}/bin/wx-config
+%files devel
+%defattr (-,root,root)
+%dir %{_includedir}/wx
+%{_includedir}/wx/*
+%{_libdir}/libwx_base*.so
+%dir %{_libdir}/wx
+%{_libdir}/wx/*
+%{_bindir}/wxbase-%{ver2}-config
+%{_datadir}/aclocal/*.m4
 
+%files static
+%defattr (-,root,root)
+%{_libdir}/lib*.a