- @for d in $(objdir_examples)/demos $(objdir_examples)/samples; do \
- (cd $$d \
- && mv Makefile.in Makefile \
- && rm -f configure* \
- && find -name 'Makefile.in' -exec rm -f '{}' ';' \
- && for f in $$(find -type d); do \
- if [ -f $$f/makefile.unx ]; then \
- mv $$f/makefile.unx $$f/Makefile; \
- fi; \
- done) \
- done;
+
+ touch $@
+
+build-i18n-stamp: build-gtk-shared-stamp
+ dh_testdir
+
+ # touch .po files first, since if they are not already up
+ # to date then _now_ is not the time to fix it.
+ # That should have been been done before cvs was tagged.
+ cd $(objdir_i18n) \
+ && touch *.po \
+ && $(MAKE) allmo
+ touch $@
+
+purge-release-py:
+ @if [ ! -e build-gtk-dbg-py-stamp ]; then \
+ $(MAKE) -f debian/rules clean-py; \
+ fi
+ $(RM) build-gtk-py-stamp
+
+build-gtk-dbg-py-stamp: build-gtk-debug-stamp purge-release-py
+ dh_testdir
+ touch docs/lgpl.txt
+ cd wxPython \
+ && $(python_ver) ./setup.py build \
+ WX_CONFIG='$(wxconfig-dbg)' \
+ WXPORT=gtk2 \
+ UNICODE=1 \
+ FLAVOUR=$(addsuffix -,$(DEBIAN_WXFLAVOUR))dbg
+ touch $@
+
+
+configure-msw-shared-stamp:
+ dh_testdir
+ mkdir -p $(objdir_msw_shared)
+ cd $(objdir_msw_shared) \
+ && ../configure --prefix=/usr/$(cross_host) \
+ --cache-file=$(config_cache_cross) \
+ --host=$(cross_host) \
+ --build=$(cross_build) \
+ --with-flavour=$(DEBIAN_WXFLAVOUR)
+ touch $@
+
+build-msw-shared-stamp: configure-msw-shared-stamp
+ dh_testdir
+ cd $(objdir_msw_shared) && $(FAST_MAKE)
+ touch $@
+
+configure-msw-static-stamp:
+ dh_testdir
+ mkdir -p $(objdir_msw_static)
+ cd $(objdir_msw_static) \
+ && ../configure --prefix=/usr/$(cross_host) \
+ --cache-file=$(config_cache_cross) \
+ --host=$(cross_host) \
+ --build=$(cross_build) \
+ --with-flavour=$(DEBIAN_WXFLAVOUR) \
+ --disable-shared
+ touch $@
+
+build-msw-static-stamp: configure-msw-static-stamp
+ dh_testdir
+ cd $(objdir_msw_static) && $(FAST_MAKE)
+ touch $@
+
+configure-msw-dbg-stamp:
+ dh_testdir
+ mkdir -p $(objdir_msw_dbg)
+ cd $(objdir_msw_dbg) \
+ && ../configure --prefix=/usr/$(cross_host) \
+ --cache-file=$(config_cache_cross) \
+ --host=$(cross_host) \
+ --build=$(cross_build) \
+ --with-flavour=$(DEBIAN_WXFLAVOUR) \
+ --enable-debug
+ touch $@
+
+build-msw-dbg-stamp: configure-msw-dbg-stamp
+ dh_testdir
+ cd $(objdir_msw_dbg) && $(FAST_MAKE)