+build-gtk-debug-stamp: configure-gtk-debug-stamp
+ dh_testdir
+ cd $(objdir_gtk_debug) && $(FAST_MAKE)
+ touch $@
+
+
+build-gtk-shared-contrib-stamp: build-gtk-shared-stamp
+ dh_testdir
+ cd $(objdir_gtk_shared)/contrib/src && $(FAST_MAKE)
+ cd $(objdir_gtk_shared)/contrib/utils/wxrc && $(FAST_MAKE)
+ cd $(objdir_gtk_shared)/contrib/utils/wxrcedit && $(FAST_MAKE)
+ touch $@
+
+build-gtk-static-contrib-stamp: build-gtk-static-stamp
+ dh_testdir
+ cd $(objdir_gtk_static)/contrib/src && $(FAST_MAKE)
+ touch $@
+
+build-gtk-debug-contrib-stamp: build-gtk-debug-stamp
+ dh_testdir
+ cd $(objdir_gtk_debug)/contrib/src && $(FAST_MAKE)
+ touch $@
+
+
+purge-dbg-py:
+ @if [ ! -e build-gtk-py-stamp ]; then \
+ $(MAKE) -f debian/rules clean-py; \
+ fi
+ $(RM) build-gtk-dbg-py-stamp
+
+build-gtk-py-stamp: build-gtk-shared-stamp purge-dbg-py
+ dh_testdir
+ touch docs/lgpl.txt
+ cd wxPython \
+ && $(python_ver) ./setup.py build \
+ WX_CONFIG='$(wxconfig)' \
+ WXPORT=gtk2 \
+ UNICODE=1
+ touch $@
+
+build-doc-stamp: build-gtk-shared-stamp
+ dh_testdir
+ cd $(objdir_gtk_shared)/utils/tex2rtf/src && $(FAST_MAKE)
+ rm -rf $(objdir_doc)
+ rm -rf $(objdir_doc_cruft)
+ mkdir $(objdir_doc)
+ mkdir $(objdir_doc_cruft)
+ cd $(objdir_doc_cruft) \
+ && LD_LIBRARY_PATH=../$(objdir_gtk_shared)/lib:$(LD_LIBRARY_PATH) \
+ ../$(objdir_gtk_shared)/utils/tex2rtf/src/tex2rtf \
+ ../docs/latex/wx/manual.tex \
+ ../$(objdir_doc)/wx$(release)-manual.html \
+ -twice -html
+ cp docs/latex/wx/*.gif $(objdir_doc)
+ rm -rf $(objdir_doc_cruft)
+ rm -f $(objdir_doc)/wxwin.con $(objdir_doc)/wxwin.hh* \
+ $(objdir_doc)/wxwin.htx $(objdir_doc)/wxwin.ref
+ touch $@
+
+build-examples-stamp: build-gtk-shared-stamp
+ dh_testdir
+ mkdir -p $(objdir_examples)
+
+ # copy all samples and the Makefile generated for libwxgtk.
+ cp -a samples $(objdir_examples)
+ rm -f $(objdir_examples)/samples/Makefile
+ cp -a $(objdir_gtk_shared)/samples/Makefile $(objdir_examples)/samples
+
+ cd $(objdir_examples)/samples \
+ && find -name 'Makefile.in' -exec rm -f '{}' ';' \
+ && for d in $$(find -type d); do \
+ if [ -f $$d/makefile.unx ]; then \
+ mv $$d/makefile.unx $$d/Makefile; \
+ fi; \
+ done \
+
+ cp -a wxPython/demo $(objdir_examples)/wxPython
+
+ touch $@
+
+build-i18n-stamp: build-gtk-shared-stamp
+ dh_testdir
+
+ # touch .po files first, since if they are not already up
+ # to date then _now_ is not the time to fix it.
+ # That should have been been done before cvs was tagged.
+ cd $(objdir_i18n) \
+ && touch *.po \
+ && $(MAKE) allmo
+ touch $@
+
+purge-release-py:
+ @if [ ! -e build-gtk-dbg-py-stamp ]; then \
+ $(MAKE) -f debian/rules clean-py; \
+ fi
+ $(RM) build-gtk-py-stamp
+
+build-gtk-dbg-py-stamp: build-gtk-debug-stamp purge-release-py
+ dh_testdir
+ touch docs/lgpl.txt
+ cd wxPython \
+ && $(python_ver) ./setup.py build \
+ WX_CONFIG='$(wxconfig-dbg)' \
+ WXPORT=gtk2 \
+ UNICODE=1
+ touch $@
+
+
+configure-msw-shared-stamp:
+ dh_testdir
+ mkdir -p $(objdir_msw_shared)
+ cd $(objdir_msw_shared) \
+ && ../configure --prefix=/usr/$(cross_host) \
+ --cache-file=$(config_cache_cross) \
+ --host=$(cross_host) \
+ --build=$(cross_build) \
+ --with-flavour=$(DEBIAN_WXFLAVOUR)
+ touch $@
+
+build-msw-shared-stamp: configure-msw-shared-stamp
+ dh_testdir
+ cd $(objdir_msw_shared) && $(FAST_MAKE)
+ touch $@
+
+configure-msw-static-stamp:
+ dh_testdir
+ mkdir -p $(objdir_msw_static)
+ cd $(objdir_msw_static) \
+ && ../configure --prefix=/usr/$(cross_host) \
+ --cache-file=$(config_cache_cross) \
+ --host=$(cross_host) \
+ --build=$(cross_build) \
+ --with-flavour=$(DEBIAN_WXFLAVOUR) \
+ --disable-shared
+ touch $@
+
+build-msw-static-stamp: configure-msw-static-stamp
+ dh_testdir
+ cd $(objdir_msw_static) && $(FAST_MAKE)
+ touch $@
+
+configure-msw-dbg-stamp:
+ dh_testdir
+ mkdir -p $(objdir_msw_dbg)
+ cd $(objdir_msw_dbg) \
+ && ../configure --prefix=/usr/$(cross_host) \
+ --cache-file=$(config_cache_cross) \
+ --host=$(cross_host) \
+ --build=$(cross_build) \
+ --with-flavour=$(DEBIAN_WXFLAVOUR) \
+ --enable-debug
+ touch $@
+
+build-msw-dbg-stamp: configure-msw-dbg-stamp
+ dh_testdir
+ cd $(objdir_msw_dbg) && $(FAST_MAKE)
+ touch $@
+
+
+clean-py:
+ cd wxPython \
+ && rm -rf licence \
+ && rm -rf build* \
+ && rm -rf docs/xml-raw \
+ && rm -rf wx/*.py
+
+ # What to do about src/__version__.py ???
+
+
+# We do the equivalent of this above by removing build, unfortunately
+# its not enough by itself to get the tree properly clean again.
+# && ./setup.py clean
+
+clean: debian/control clean-py