+install-gtk-py-lib: DH_OPTIONS=-p$(package_gtk_py_lib)
+install-gtk-py-lib: build-gtk-py-stamp
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+ cd wxPython \
+ && $(python_ver) ./setup.py install \
+ --prefix=`pwd`/../debian/$(package_gtk_py_lib)/usr \
+ WX_CONFIG='$(wxconfig)' \
+ WXPORT=gtk2 \
+ UNICODE=1 \
+ FLAVOUR=$(DEBIAN_WXFLAVOUR)
+
+ find debian/$(package_gtk_py_lib)/$(pydir) -name '*.py?' -exec rm '{}' ';'
+
+ # This is rather bogus, its included in the main copyright file now though.
+ rm -f debian/$(package_gtk_py_lib)/$(wxpydir)/wx/tools/XRCed/license.txt
+
+install-gtk-py: DH_OPTIONS=-p$(package_gtk_py)
+install-gtk-py: install-gtk-py-lib
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+
+ dh_movefiles --sourcedir=debian/$(package_gtk_py_lib) \
+ usr/bin \
+ $(pydir)/{wxversion.py,wx.pth}
+ rm -r debian/$(package_gtk_py_lib)/usr/bin
+
+ dh_installman debian/wxPython-tools.1
+ dh_link usr/share/man/man1/wxPython-tools.1 usr/share/man/man1/img2py.1 \
+ usr/share/man/man1/wxPython-tools.1 usr/share/man/man1/img2xpm.1 \
+ usr/share/man/man1/wxPython-tools.1 usr/share/man/man1/img2png.1 \
+ usr/share/man/man1/wxPython-tools.1 usr/share/man/man1/pycrust.1 \
+ usr/share/man/man1/wxPython-tools.1 usr/share/man/man1/pyshell.1 \
+ usr/share/man/man1/wxPython-tools.1 usr/share/man/man1/xrced.1 \
+ usr/share/man/man1/wxPython-tools.1 usr/share/man/man1/helpviewer.1 \
+ usr/share/man/man1/wxPython-tools.1 usr/share/man/man1/pyalacarte.1 \
+ usr/share/man/man1/wxPython-tools.1 usr/share/man/man1/pyalamode.1 \
+ usr/share/man/man1/wxPython-tools.1 usr/share/man/man1/pywrap.1 \
+ usr/share/man/man1/wxPython-tools.1 usr/share/man/man1/pywxrc.1
+
+
+install-common: DH_OPTIONS=-p$(package_common)
+install-common: install-gtk-shared-stamp
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+
+ dh_install $(objdir_gtk_install)/share/aclocal usr/share
+ dh_installman debian/wx-config.1
+
+ dh_install $(objdir_gtk_shared)/utils/wxrc/wxrc usr/bin
+# dh_install $(objdir_gtk_shared)/contrib/utils/wxrcedit/wxrcedit usr/bin
+
+ dh_installman debian/wxrc-tools.1
+ dh_link usr/share/man/man1/wxrc-tools.1 usr/share/man/man1/wxrc.1
+# dh_link usr/share/man/man1/wxrc-tools.1 usr/share/man/man1/wxrcedit.1
+
+
+install-headers: DH_OPTIONS=-p$(package_headers)
+install-headers: install-gtk-shared-stamp
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+
+# The only way to be really sure we get the univ headers correct is to install
+# them. Do that in a scratch dirs, and move the gtk ones last, so at least
+# they win in the result of any uncaught conflict.
+
+# cd $(objdir_gtk_univ) \
+# && $(MAKE) install prefix=`pwd`/../$(objdir_univ_install)/usr
+
+# dh_movefiles --sourcedir=$(objdir_univ_install)
+ dh_install $(objdir_gtk_install)/include usr
+
+install-i18n: DH_OPTIONS=-p$(package_i18n)
+install-i18n: build-i18n-stamp install-gtk-shared-stamp
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+ dh_install $(objdir_gtk_install)/share/locale usr/share
+
+install-doc: DH_OPTIONS=-p$(package_doc)
+install-doc: build-doc-stamp
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+
+install-examples: DH_OPTIONS=-p$(package_examples)
+install-examples: build-examples-stamp
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+
+install-gtk-dbg-py: DH_OPTIONS=-p$(package_gtk_dbg_py)
+install-gtk-dbg-py: build-gtk-dbg-py-stamp
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+ cd wxPython \
+ && $(python_ver) ./setup.py install \
+ --prefix=`pwd`/../debian/$(package_gtk_dbg_py)/usr \
+ WX_CONFIG='$(wxconfig-dbg)' \
+ WXPORT=gtk2 \
+ UNICODE=1 \
+ FLAVOUR=$(addsuffix -,$(DEBIAN_WXFLAVOUR))dbg
+
+ find debian/$(package_gtk_dbg_py)/$(pydir) -name '*.py?' -exec rm '{}' ';'
+ rm -rf usr/bin $(pydir)/{wxversion.py,wx.pth}
+
+ # This is rather bogus, its included in the main copyright file now though.
+ rm -f debian/$(package_gtk_dbg_py)/$(wxpydir)/wx/tools/XRCed/license.txt
+
+
+install-msw-dev: DH_OPTIONS=-p$(package_msw_dev)
+install-msw-dev: build-msw-shared-stamp build-msw-static-stamp
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+ dh_install $(objdir_msw_shared)/lib/*.dll* usr/$(cross_host)/lib
+ dh_install $(objdir_msw_shared)/lib/wx/include usr/$(cross_host)/lib/wx
+ dh_install $(objdir_msw_shared)/lib/wx/config/$(cross_host)* usr/$(cross_host)/lib/wx/config
+ dh_install $(objdir_msw_static)/lib/*.a usr/$(cross_host)/lib
+ dh_install $(objdir_msw_static)/lib/wx/include usr/$(cross_host)/lib/wx
+ dh_install $(objdir_msw_static)/lib/wx/config/$(cross_host)* usr/$(cross_host)/lib/wx/config
+ $(cross_host)-strip --strip-debug debian/$(package_msw_dev)/usr/$(cross_host)/lib/*.a
+
+ @# As a special case for the cross packages, we link their config
+ @# under /usr as well as under the normal cross prefix. This way
+ @# --prefix=/usr/$(cross_host) and --prefix=/usr --host=$(cross_host)
+ @# will have a congruent effect on wx-config.
+ @( for f in `ls -1 debian/$(package_msw_dev)/usr/$(cross_host)/lib/wx/config`; do \
+ all_cfg="$${all_cfg} usr/$(cross_host)/lib/wx/config/$$f usr/lib/wx/config/$$f"; \
+ echo "linking cross config /usr/$(cross_host)/lib/wx/config/$$f"; \
+ done; \
+ dh_link $${all_cfg}; \
+ )
+
+install-msw-dbg: DH_OPTIONS=-p$(package_msw_dbg)
+install-msw-dbg: build-msw-dbg-stamp
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+ dh_install $(objdir_msw_dbg)/lib/*.dll* usr/$(cross_host)/lib
+ dh_install $(objdir_msw_dbg)/lib/wx/include usr/$(cross_host)/lib/wx
+ dh_install $(objdir_msw_dbg)/lib/wx/config/$(cross_host)* usr/$(cross_host)/lib/wx/config
+ # No static lib, they're freakin' huge!
+ #$(cross_host)-strip --strip-debug debian/$(package_msw_dbg)/usr/$(cross_host)/lib/*.a
+
+ @( for f in `ls -1 debian/$(package_msw_dbg)/usr/$(cross_host)/lib/wx/config`; do \
+ all_cfg="$${all_cfg} usr/$(cross_host)/lib/wx/config/$$f usr/lib/wx/config/$$f"; \
+ echo "linking cross config /usr/$(cross_host)/lib/wx/config/$$f"; \
+ done; \
+ dh_link $${all_cfg}; \
+ )
+
+install-headers-msw: DH_OPTIONS=-p$(package_headers_msw)
+install-headers-msw:
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+
+ cd $(objdir_msw_shared) \
+ && $(MAKE) install prefix=`pwd`/../$(objdir_msw_install)
+
+# Symlink all the headers that will be installed by the main -headers
+# package to where the cross compiler will expect them.
+ @( for f in `ls -1 $(objdir_msw_install)/include/wx-$(release)/wx`; do \
+ all_h="$${all_h} usr/include/wx-$(release)/wx/$$f usr/$(cross_host)/include/wx-$(release)/wx/$$f"; \
+ echo "linking header /usr/include/wx-$(release)/wx/$$f"; \
+ done; \
+ dh_link $${all_h}; \
+ )