]> git.saurik.com Git - wxWidgets.git/blobdiff - wxGTK.spec
don't use -single_module together with -bundle under Darwin (ld gives an error for...
[wxWidgets.git] / wxGTK.spec
index 131bdd80021d7b93f1ce049e00b7a0e63e963b7e..8f0c52cd17d9dc2ff444580d474e2a09c5faeb31 100644 (file)
@@ -1,5 +1,5 @@
 %define _prefix /opt/gnome
-%define ver  2.6.0
+%define ver  2.6.2
 %define ver2 2.6
 %define rel  1
 
@@ -82,11 +82,11 @@ wxWidgets is a free C++ library for cross-platform GUI development.
 With wxWidgets, you can create applications for different GUIs (GTK+,
 Motif, MS Windows, MacOS X, Windows CE, GPE) from the same source code.
 
-%package -n wx-i28n
+%package -n wx-i18n
 Summary: The translations for the wxWidgets library.
 Group: X11/Libraries
 
-%description -n wx-i28n
+%description -n wx-i18n
 The translations files for the wxWidgets library.
 
 %package devel
@@ -233,7 +233,7 @@ rm -rf $RPM_BUILD_ROOT
 (cd obj-shared; make DESTDIR=$RPM_BUILD_ROOT install)
 
 # --- wxBase headers list begins here ---
-cat <<EOF >wxbase-headers-list
+cat <<EOF >wxbase-headers.files
 wx/afterstd.h
 wx/app.h
 wx/apptrait.h
@@ -250,7 +250,6 @@ wx/confbase.h
 wx/config.h
 wx/containr.h
 wx/datetime.h
-wx/datetime.inl
 wx/datstrm.h
 wx/dde.h
 wx/debug.h
@@ -287,6 +286,7 @@ wx/ipc.h
 wx/ipcbase.h
 wx/isql.h
 wx/isqlext.h
+wx/link.h
 wx/list.h
 wx/listimpl.cpp
 wx/log.h
@@ -298,12 +298,12 @@ wx/memtext.h
 wx/mimetype.h
 wx/module.h
 wx/msgout.h
-wx/msgout.h
 wx/mstream.h
 wx/object.h
 wx/platform.h
 wx/process.h
 wx/ptr_scpd.h
+wx/recguard.h
 wx/regex.h
 wx/scopeguard.h
 wx/snglinst.h
@@ -339,6 +339,14 @@ wx/xti.h
 wx/xtistrm.h
 wx/zipstrm.h
 wx/zstream.h
+wx/unix/apptbase.h
+wx/unix/apptrait.h
+wx/unix/execute.h
+wx/unix/mimetype.h
+wx/unix/pipe.h
+wx/unix/private.h
+wx/unix/stackwalk.h
+wx/unix/stdpaths.h
 wx/msw/apptrait.h
 wx/msw/apptbase.h
 wx/msw/chkconf.h
@@ -348,10 +356,28 @@ wx/msw/debughlp.h
 wx/msw/gccpriv.h
 wx/msw/mimetype.h
 wx/msw/stackwalk.h
+wx/msw/stdpaths.h
 wx/msw/winundef.h
 wx/msw/wrapcctl.h
 wx/msw/wrapcdlg.h
 wx/msw/wrapwin.h
+wx/unix/apptbase.h
+wx/unix/apptrait.h
+wx/unix/execute.h
+wx/unix/mimetype.h
+wx/unix/pipe.h
+wx/unix/private.h
+wx/unix/stackwalk.h
+wx/unix/stdpaths.h
+wx/mac/corefoundation/cfstring.h
+wx/mac/corefoundation/hid.h
+wx/mac/corefoundation/stdpaths.h
+wx/palmos/apptbase.h
+wx/palmos/apptrait.h
+wx/palmos/chkconf.h
+wx/palmos/mimetype.h
+wx/palmos/stdpaths.h
+wx/msdos/mimetype.h
 wx/fs_inet.h
 wx/gsocket.h
 wx/protocol/file.h
@@ -363,7 +389,11 @@ wx/sckipc.h
 wx/sckstrm.h
 wx/socket.h
 wx/url.h
+wx/unix/gsockunx.h
 wx/msw/gsockmsw.h
+wx/unix/gsockunx.h
+wx/unix/gsockunx.h
+wx/mac/carbon/gsockmac.h
 wx/xml/xml.h
 wx/xtixml.h
 wx/db.h
@@ -594,7 +624,7 @@ rm -f %{_bindir}/%{wxbaseconfiglink}
 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.so.*
 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.so.*
 
-%files -n wx-i28n
+%files -n wx-i18n
 %defattr(-,root,root)
 %{_datadir}/locale/*/*/*