]> git.saurik.com Git - wxWidgets.git/blobdiff - wxBase.spec
wxMac apparently doesn't send EVT_SHOW, so just use wx.CallAfter instead
[wxWidgets.git] / wxBase.spec
index 4ded4738aebd0ba938671ab78709c755a969101f..3f8a054ef3f429b8686a4ef987021cd179e9f4d8 100644 (file)
@@ -91,8 +91,13 @@ cd ..
 
 %install
 rm -rf $RPM_BUILD_ROOT
-(cd obj-static ; make DESTDIR=$RPM_BUILD_ROOT prefix=%{pref} install)
-(cd obj-shared ; make DESTDIR=$RPM_BUILD_ROOT prefix=%{pref} install)
+make -C locale allmo
+make -C obj-static DESTDIR=$RPM_BUILD_ROOT prefix=%{pref} install
+make -C obj-shared DESTDIR=$RPM_BUILD_ROOT prefix=%{pref} install
+
+# we need to modify the absolute wx-config link to be relative or rpm complains
+# (and our package wouldn't be relocatable)
+ln -sf ../lib/wx/config/%{wxconfig} $RPM_BUILD_ROOT/%{pref}/bin/wx-config
 
 %find_lang wxstd