-# RPM .spec file for wxMotif. Based on the .spec file for wxGTK
-# (c) by Robert Roebling. Modifications (c) 2000/03 by Robert Fendt.
-
-# Note that this is NOT a relocatable package
%define pref /usr
-%define ver 2.5.2
+%define ver 2.5.3
%define ver2 2.5
%define rel 1
License: wxWindows Licence
Group: X11/Libraries
Source: wxMOTIF-%{ver}.tar.bz2
-URL: http://www.wxwindows.org
-Packager: Robert Fendt <rfendt@myokay.net>
+URL: http://www.wxwidgets.org
+Packager: wxWindows developers <wx-dev@lists.wxwidgets.org>
BuildRoot: /tmp/wxmotif_root
# all packages providing an implementation of wxWindows library (regardless of
wx/buffer.h
wx/build.h
wx/chkconf.h
+wx/clntdata.h
wx/cmdline.h
wx/confbase.h
wx/config.h
wx/regex.h
wx/scopeguard.h
wx/snglinst.h
+wx/sstream.h
wx/stack.h
+wx/stockitem.h
wx/stopwatch.h
wx/strconv.h
wx/stream.h
EOF
# --- wxBase headers list ends here ---
for f in `cat wxbase-headers-list` ; do
- rm -f $RPM_BUILD_ROOT%{_includedir}/$f
+ rm -f $RPM_BUILD_ROOT%{_includedir}/wx-*/$f
done
# list of all core headers:
%postun gl
/sbin/ldconfig
-%post devel
-# Install wx-config if there isn't any
-if test ! -f %{_bindir}/wx-config ; then
- ln -sf %{wxconfigname} %{_bindir}/wx-config
-fi
-
-%preun devel
-# Remove wx-config if it points to this package
-if test -f %{_bindir}/wx-config -a -f /usr/bin/md5sum ; then
- SUM1=`md5sum %{_bindir}/%{wxconfigname} | cut -c 0-32`
- SUM2=`md5sum %{_bindir}/wx-config | cut -c 0-32`
- if test "x$SUM1" = "x$SUM2" ; then
- rm -f %{_bindir}/wx-config
- fi
-fi
-
%files
%defattr(-,root,root)
%files static
%defattr (-,root,root)
%{_libdir}/libwx_%{portname}*.a
+