]> git.saurik.com Git - wxWidgets.git/blobdiff - wxMGL.spec
added wxCStrData::operator+(long) overload (this fixes some compilation errors in...
[wxWidgets.git] / wxMGL.spec
index fe4a9857315ce5770c8e67ae2673474455141198..34958d9aa4ba58ac38b4b6d6a686f16bdf716eec 100644 (file)
@@ -1,13 +1,13 @@
 %define pref /usr
-%define ver 2.5.0
-%define ver2 2.5
+%define ver 2.9.0
+%define ver2 2.9
 %define rel 1
 
 Summary: The SciTech MGL port of the wxWindows library
 Name: wxMGL
 Version: %{ver}
 Release: %{rel}
-Copyright: wxWindows Licence
+License: wxWindows Licence
 Group: System/Libraries
 Source: wxMGL-%{ver}.tar.bz2
 URL: http://www.wxwindows.org
@@ -58,13 +58,13 @@ fi
 
 mkdir obj-shared
 cd obj-shared
-../configure --prefix=%{pref} --enable-soname --with-mgl
+../configure --prefix=%{pref} --with-mgl --disable-fs_inet
 $MAKE
 cd ..
 
 mkdir obj-static
 cd obj-static
-../configure --prefix=%{pref} --disable-shared --with-mgl
+../configure --prefix=%{pref} --disable-shared --with-mgl --disable-fs_inet
 $MAKE
 cd ..
 
@@ -84,35 +84,16 @@ rm -rf $RPM_BUILD_ROOT
 %postun
 /sbin/ldconfig
 
-%post devel
-# Install wx-config if there isn't any
-if test ! -f %{_bindir}/wx-config ; then
-    ln -sf wxmgl-%{ver2}-config %{_bindir}/wx-config
-fi
-
-%preun devel
-# Remove wx-config if it points to this package
-if test -f %{_bindir}/wx-config -a -f /usr/bin/md5sum ; then
-  SUM1=`md5sum %{_bindir}/wxmgl-%{ver2}-config | cut -c 0-32`
-  SUM2=`md5sum %{_bindir}/wx-config | cut -c 0-32`
-  if test "x$SUM1" = "x$SUM2" ; then
-    rm -f %{_bindir}/wx-config
-  fi
-fi
-
-
 %files -f wxstd.lang
 %defattr(-,root,root)
 %doc COPYING.LIB *.txt
-%dir %{_datadir}/wx
-%{_datadir}/wx/*
 %{_libdir}/libwx_mgl*-%{ver2}*.so.*
 
 %files devel
 %defattr(-,root,root)
 %{_libdir}/libwx_mgl*-%{ver2}*.so
-%dir %{_includedir}/wx
-%{_includedir}/wx/*
+%dir %{_includedir}/wx-*
+%{_includedir}/wx-*/*
 %dir %{_libdir}/wx
 %{_libdir}/wx/*
 %{_bindir}/wxmgl*-config